After uploading a video nothing happens

edited December 2011 in Bugs and Errors
One more problem: After a video is uploaded, I do not see more to it. So I thought it could be a wrong path to php (similar case as 'uploaded video not showing up').
I used commando 'which ffmpeg' (result: /usr/bin/ffmpeg ) and 'which php' (result: /usr/bin/php )
Here I found one file, type: link to executable.
The path to php '/usr/bin/php' then seems to be correct.

I turned “Log Encoding” on, tried to upload a video and got a converter.log in /cc-core/logs. Here it is:

/usr/bin/php: /opt/lampp/lib/ no version information available (required by /usr/bin/php)
/usr/bin/php: /opt/lampp/lib/ no version information available (required by /usr/bin/php)
Unable to connect to database“

Regarding the database, the database credentials in config.php are correct, the tables are installed and contains correct data.

Does anyone know what might be wrong here?



  • I moved this thread to the Bugs and Errors category if you don't mind. It's more appropriate there.

    You were very close in trying to execute 'which php' to find the correct path to PHP.

    The issue I think you're having which is the same one other people have had isn't exactly that the path to PHP is wrong. It's that the PHP path provided won't workon the command line or cron jobs; I believe this is called PHP CLI if I'm not mistaken.

    Usually webhosts have different or alternate paths to this executable. In your case you're using XAMPP, so try using this as your PHP path:


    Let me know if that works.
  • Yes, '/opt/lampp/bin/php' worked!
    But still some problems. This is the text from the error-logs:

    ### Converter Called...
    Values passed to encoder:
    [0] => /opt/lampp/htdocs/cumulus/cc-core/system/encode.php
    [1] => --video=10

    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: FLV Encoding...
    FLV Encoding Command: /usr/bin/ffmpeg -i /opt/lampp/htdocs/cumulus/cc-content/uploads/temp/x5EPk0wvYRBHzK4Tiwk2.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv /opt/lampp/htdocs/cumulus/cc-content/uploads/flv/x5EPk0wvYRBHzK4Tiwk2.flv >> /opt/lampp/htdocs/cumulus/cc-core/logs/x5EPk0wvYRBHzK4Tiwk2.log 2>&1
    Verifying FLV video was created...
    sh: /usr/sbin/sendmail: not found
    Could not instantiate mail function.
    The FLV file was not created. The id of the video is: 10

    FLV Encoding Command: /usr/bin/ffmpeg -i /opt/lampp/htdocs/cumulus/cc-content/uploads/temp/Tgh7dnSbcsEZdpzJR8sZ.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv /opt/lampp/htdocs/cumulus/cc-content/uploads/flv/Tgh7dnSbcsEZdpzJR8sZ.flv >> /opt/lampp/htdocs/cumulus/cc-core/logs/Tgh7dnSbcsEZdpzJR8sZ.log 2>&1FLV Encoding Output:

    /usr/bin/ffmpeg: /opt/lampp/lib/ version `GCC_4.0.0' not found (required by /usr/lib/
    /usr/bin/ffmpeg: /opt/lampp/lib/ version `GCC_4.2.0' not found (required by /usr/lib/

  • What happens if you run this from the command line?

    /usr/bin/ffmpeg -i /opt/lampp/htdocs/cumulus/cc-content/uploads/temp/Tgh7dnSbcsEZdpzJR8sZ.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv /opt/lampp/htdocs/cumulus/cc-content/uploads/flv/Tgh7dnSbcsEZdpzJR8sZ.flv
  • A flv file was encoded from the uploaded mp4 file and placed in uploads/flv. But still this message at the site: “No videos added yet.” The following is the output in the the terminal window:

    FFmpeg version 0.6-4:0.6-2ubuntu6.2, Copyright (c) 2000-2010 the FFmpeg developers
    built on Sep 16 2011 17:11:24 with gcc 4.4.5
    configuration: --extra-version=4:0.6-2ubuntu6.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
    WARNING: library configuration mismatch
    libavutil configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libavcodec configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libavformat configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libavdevice configuration: --extra-version=4:0.6-2ubuntu6.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libavfilter configuration: --extra-version=4:0.6-2ubuntu6.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libswscale configuration: --extra-version=4:0.6-2ubuntu6.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libpostproc configuration: --extra-version=4:0.6-2ubuntu6.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-x11grab --enable-libdc1394 --shlibdir=/usr/lib/i686/cmov --cpu=i686 --enable-shared --disable-static --disable-ffmpeg --disable-ffplay
    libavutil 50.15. 1 / 50.15. 1
    libavcodec 52.72. 2 / 52.72. 2
    libavformat 52.64. 2 / 52.64. 2
    libavdevice 52. 2. 0 / 52. 2. 0
    libavfilter 1.19. 0 / 1.19. 0
    libswscale 0.11. 0 / 0.11. 0
    libpostproc 51. 2. 0 / 51. 2. 0
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/opt/lampp/htdocs/cumulus/cc-content/uploads/temp/Tgh7dnSbcsEZdpzJR8sZ.mp4':
    major_brand : isom
    minor_version : 512
    compatible_brands: isomiso2avc1mp41
    encoder : Lavf52.64.2
    Duration: 00:00:20.08, start: 0.000000, bitrate: 1858 kb/s
    Stream #0.0(und): Video: h264, yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 1598 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc
    Stream #0.1(und): Audio: mp3, 44100 Hz, 2 channels, s16, 255 kb/s
    Output #0, flv, to '/opt/lampp/htdocs/cumulus/cc-content/uploads/flv/Tgh7dnSbcsEZdpzJR8sZ.flv':
    encoder : Lavf52.64.2
    Stream #0.0(und): Video: flv, yuv420p, 640x480 [PAR 4:3 DAR 16:9], q=2-31, 800 kb/s, 1k tbn, 25 tbc
    Stream #0.1(und): Audio: libmp3lame, 44100 Hz, 2 channels, s16, 96 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #0.1 -> #0.1
    Press [q] to stop encoding
    frame= 502 fps= 43 q=7.9 Lsize= 2660kB time=20.08 bitrate=1085.1kbits/s
    video:2404kB audio:236kB global headers:0kB muxing overhead 0.763878%

  • Okay, the problem you're having, unfortunately, is environment related, (XAMPP, etc), no due to CumulusClips.

    Originally you were getting errors because the default PHP installation on your Ubuntu machine (/usr/bin/php) didn't work via the command line.

    We fixed this by using the XAMPP version of PHP which has PHP CLI, this was located at /opt/lampp/bin/php.

    However now, the XAMPP version of PHP throws errors when executing FFMPEG via CLI. We can prove this is not related to CumulusClips by creating a brand new PHP script and calling an FFMPEG encoding command using 'exec' from this script. You should get the same error you received earlier.

    I can only think of two things to solve your problem.


    1 - Install an updated copy of PHP with CLI from the Ubuntu repositories, pretty simple. Run this command and say yes (Y) when prompted.

    sudo aptitude install php5-cli php5-common php5-mysql php5-gd php5-curl

    Then supply your new PHP path to CumulusClips. You get this by running:

    whereis php

    And you should select the one that looks like this: '/usr/local/bin/php'


    2 - Install the latest version of FFMPEG, directly from the manufacturers, a little bit more involved, but still pretty easy.

    Follow the instructions on this guide (stop after Step 6):

    Then supply your new FFMPEG path to CumulusClips. You get this by running:

    whereis ffmpeg

    And you should select the one that looks like this: '/usr/local/bin/ffmpeg'


    Personally, I would even consider doing both of these, just in case. Let me know how it goes.
  • Sorry about late response. I reinstalled php5-cli and the latest version of FFMPEG.
    When I tried:
    aages@aages-desktop:~$ /usr/local/bin/ffmpeg -i /opt/lampp/htdocs/cumulus/cc-content/uploads/temp/Ny3EN3KVQm3Lsp4rUDqQ.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv /opt/lampp/htdocs/cumulus/cc-content/uploads/flv/Ny3EN3KVQm3Lsp4rUDqQ.flv

    I got no error-message and the flv version was produced.

    But in Coverter.log, still this error:
    "/usr/bin/php: /opt/lampp/lib/ no version information available (required by /usr/bin/php)
    /usr/bin/php: /opt/lampp/lib/ no version information available (required by /usr/bin/php)
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/' - /usr/lib/php5/20090626+lfs/ undefined symbol: gdImageCreateFromGif in Unknown on line 0
    Unable to connect to database"

    When using whereis php, I get:
    php: /usr/bin/php /usr/share/php /opt/lampp/bin/php
  • I did forget to add plain PHP to the command I listed above. You needed to upgrade your standard PHP version as well along with the other stuff I mentioned. Please run this command:

    sudo aptitude install php5

    I'm assuming you followed already installed FFMPEG via the instructions in the link I posted above, as well as already upgraded php-cli, etc. per my instructions. So at this point you should have all your php and ffmpeg executables up-to-date.

    Now try this.

    1) Make sure 'safe_mode' is off and 'register_globals' is off as well in your php.ini. This file should be located in one of these locations:


    ALSO make sure those settings are off in XAMP's version of the php.ini as well, I think it's located in:

    /opt/lampp/conf/php.ini (or something like that)

    2) In Admin Panel -> Settings -> Video, add:


    as the FFMPEG path and:


    as the PHP path. Delete all your logs and try again. If that fails, leave the FFMPEG path alone, but change the PHP path back to:


    delete your logs once more and try again. If both of those fail then I'm out of ideas.
  • I have followed your instructions, but still get error-messages due to some sort of misconfiguration.

    I will, when I have a better time than now, reinstall LAMP on my computer.
    Thanks a lot for your extensive help!
  • Hey aages,

    I was able to reproduce the problem you were having, and fortunately I was able to find a solution.

    Here's how, from the command line:

    1) locate
    2) mv /opt/lampp/lib/ /opt/lampp/lib/
    3) ln -s /lib/i386-linux-gnu/ /opt/lampp/lib/
    4) Admin Panel -> Settings -> Video:

    PHP Path: /opt/lampp/bin/php
    FFMPEG Path: /usr/local/bin/ffmpeg

    Things to note:

    For step #1, my system returned: /lib/i386-linux-gnu/, this is what I used in step #3. You should use whatever your system returns.

    You might also see an error related to:, if so repeat steps 1-3 but replace libgcc_s.so1 with
  • Yeees.
    Now it works!
    Thank you for your excellent and helpful support!
This discussion has been closed.