Not Getting Video To Show

Thanks, for helping me getting my script working. Now, I cannot get the videos to show up. I have read every discussion I can read on the forum and none of the remedies are helping me. Can you give me any more of your help?


  • Go to Admin Panel -> Dashboard -> System Logs and purge the logs.

    Then go to Admin Panel -> Settings -> Video -> Log Encoding and set this to "enabled"

    Next try your upload again. After a few minutes go back to the logs page and attach the contents of the two log files here.
  • Thanks, here are the two logs and an error message from my website.
  • here is a pdf of errors
    Error Logs.pdf
  • You're using an old version of FFMPEG. Please follow the instructions in the following post to upgrade to the latest version:

    That error message you're seeing in your PHP error logs, is a warning caused by your web host. It can be ignored for now.
  • I have done that already and tried several paths to ffmpeg, but still same results
  • Please purge all the logs, try another upload with the updated ffmpeg from my instructions above. Then post the new set of logs here.
  • Attached are the requested logs following your instructions. I hope I am not being too much trouble.
  • Hmm, that's strange. Can you set he permissions on the FFMPEG file you added to 777 and try again. Please attach the logs afterwards.

    If that doesn't work, would you be open to having one of our engineers login to your system and help debug the problem?
  • I had tried that before (777) and this time it did not work either. I do not mind if you want to climb under the hood. Let's communicate privately by email. Thanks, so very much for your interest. I am on Pacific Host, if that matters any.
  • Please send your login & server credentials to support [at] cumulusclips [dot] org. I will forward the information to an engineer who will look into this for you.

    We typically don't do this, however this is a unique error (No output from FFMPEG), that a few users have experienced and we can't reproduce. This is why we would like to login to your server to debug the issue hands on and find the solution.
  • Hello, we received your details and have sent them to our engineer. It's a bit late, so I don't think they'll work on your account today. I'll keep you posted with their findings.
  • edited October 2015
    Got a response from our engineer. See below:


    The user has a shared hosting account with limited resources. Memory was continously exhausted (435MB out of 0 bytes).

    After running /path/to/static/ffmpeg -v several times the result was always a segmentation fault.

    Segmentation fault is caused by one of the following:
    1) Insufficient RAM or CPU allocated to the account
    2) SELinux interrupting execution of the script
    3) Corrupt binary

    Number 3 is not the case because we tried the binary on different servers and it worked 100% of the time.

    Our experience with FFMPEG is almost exclusively Number 1 being the culprit, especially given that the cPanel states the account having exhausted all memory.

    I recommend using a VPS, cloud, or dedicated server with more dedicated RAM and CPU and trying again there. This will fix the problem.

    The sad part is that not all users of that web host will experience this problem, because it all depends on the particular server the account is on and what are the consumption habbits of the other tenants and users on that server.


    So basically he is saying the server your host has you on doesn't have enough resources and he recommends you get a VPS, cloud, or dedicated server and go that route.

    We actually recommend that anyways. This also helps with the download and playback speed of your videos.
This discussion has been closed.