[Solved] Received Signal 15; terminating

edited April 2016 in Bugs and Errors
Get the following error during FFMPEG video encoding:

Received Signal 15; terminating


  • edited August 2015
    Bigger files 100+ mb will terminated . log is attached
  • This means something or someone on your system terminated the FFMPEG encoding process before it could finish. See your log file:

    Received Signal 15; terminating

    You need to make sure there is nothing installed on your system that would do this.

    Do all large videos do this or some of the large videos?

    Also, just for testing please follow the instructions in the following post to upgrade FFMPEG to the latest version:


    I can see you are already using a newer version, be sure to grab the latest git version, and try both the 32 and 64 bit versions. I want to make sure this is not an FFMPEG issue.
  • I use only a 64bit server the ffmpeg32bit works on it ?
    The videos larged than 60-70mb "Received signal 15: terminating.
    " .. is there a timerset for encoding somewhere ?
  • Did you remove the "nohup" from earlier? That command is meant to prevent commands from terminating when your TTY closes or times out.

    Let's try to turn on debugging in FFMPEG. Open the file /cc-core/system/encode.php and search and replace:

    $ffmpegPath -i

    with this:

    $ffmpegPath -loglevel debug -i

    This will provide us with more detailed logs.

    Yes, the 32bit will work on a 64bit system. I want you to try it to ensure the the FFMPEG version we're using did not get corrupted. Make sure you grab the Git version. Try both, one at a time.
  • I have never seen this error before, so I am learning with you on this one.
  • edited August 2015
    sometimes this is working and sometimes i have the problem with a 30mb file :(
    i have testet with 32bit ffmpeg also..
    other thing is was i testet was upload a bigger file (210mb) and yes i updated the php.ini :
    upload_max_filesize = 550M
    post_max_size = 550M

    max_execution_time = 3600
    memory_limit = 550M

    apache restart also

    the upload stuck in 99% for 5 min or so
    and i see the follow error ..

    Are there any other restrictions in another Cumulusclips files?

    746 x 259 - 63K
  • $ffmpegPath -loglevel debug -i , is set
    I had uploaded a mp4 file (113mb),

    thx for your time
  • edited August 2015
    How much RAM, CPU, and hard drive space does your server have? It looks like it is having a hard time encoding these large files.

    Just for testing, can you go to Admin Panel -> Settings -> Video and replace h264 & mobile encoding options with:
    -vcodec copy -acodec copy -f mp4

    and thumbnail options with:
    -s 640x480 -vframes 1 -f mjpeg
  • System : Linux 3.11.6-042stab092.3 auf x86_64
    Intel(R) Xeon(R) CPU E5-2680 v2 @ 2.80GHz, 2 Kerne
    RAM :4 GB Diskspace : 200 GB

    The other options testing now..
  • my H.264 Encoding Options look like this in at the moment:
    -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -strict -2 -ab 96k -ar 44100 -f mp4
    Thumbnail Options:
    -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vframes 1 -f mjpeg

    Where should I replace what now ?

  • Go to Admin Panel -> Settings -> Video

    In the h264 Options field, replace the current value with:

    -vcodec copy -acodec copy -f mp4

    Do the same with the Mobile Options field.

    In the Thumb Options field, replace the current value with:

    -s 640x480 -vframes 1 -f mjpeg

    Hmm, that CPU looks good, but I'm wondering if that might be too little RAM to process large videos. I would love to try that encoding on a server with more RAM to see if that has any effect.

    Can you provide us with a download link to download one of the large videos that is failing? We will try the encoding on our server to see if we can reproduce the issue.
  • edited August 2015
    the first test with a 117mb file is working with the new settings but this is only a 1-1 copy and not encoding , right ?

    And here athe downloadling for a 117mb mp4 file was i have testet:
    https://www.dropbox.com/s/25ly349pzgdfnpu/B-R5 grösstes Titanmassaker in Eve online.mp4?dl=0
  • Correct, those settings are just a copy and no encoding takes place. I wanted to ensure that there was nothing wrong with the script or your configuration.

    Since you confirmed that it worked, then we now know the issue is not with the script or configuration. The problem is with the actual encoding process on your server.

    I suspect that the encoding process is taking too many resources on your server and the OS terminates the culprit process. This theory is further validated by the error shown in your logs: Received Signal 15; terminating. A Google search shows results of people stating that the OS is terminating the process.

    I recommend trying to install the script on a different server, with a different OS with more RAM.

    I just uploaded the video you provided in the link to an installation of CumulusClips on a server with CentOS, 8GB RAM, Intel i5 and it encoded perfectly.
  • Thx.
    I will try to upgrade my Server to 8gb ram today and will test again with the other settings
  • Also, I'm not sure what you're situation is, but if it were me, I would setup two new servers. Both with 8gb of ram. However one would be the Linux distribution you were using, Suse, the other would be CentOS/RHEL/Ubuntu.

    This is simply to verify that the OS is not causing any problems. Different vendors sometimes package software, SELinux, God, Monit, etc. that may interfere with what you're doing.

    Once you determine the OS is not an issue, you can get rid of the server you're not using. Just a thought.

    Great let me know how it goes.
  • After the upgrade to 8 GB , it works very well within 160 MB files .
    A Stresstest with a 350 MB file failed, after 99% upload, the upload started again ..
  • I'm glad it's working now.

    I have a an idea of what's going on with the 99% progress failure. It's actually a separate error. Please open a separate forum thread for this and I can help you there.
This discussion has been closed.