- Invalid path to FFMPEG

I just installed FFMPEG using the guide here: https://trac.ffmpeg.org/wiki/CompilationGuide/Centos
and I am getting the invalid path to FFMPEG when entering /root/ffmpeg_sources/ffmpeg, /root/bin, /root/bin/ffmpeg

I am just not sure what I am doing wrong. Any help would be greatly appreciated. Thank you in advance.

Comments

  • Where is the the FFMPEG binary located after you finished installing it?

    What version are you using, i.e. run /path/to/ffmpeg -version
  • ffmpeg version git-2015-05-31-ebe919c Copyright (c) 2000-2015 the FFmpeg developers
    built with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-11)
    configuration: --prefix=/root/ffmpeg_build --extra-cflags=-I/root/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --bindir=/root/bin --pkg-config-flags=--static --enable-gpl --enable-nonfree --enable-libfdk_aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265
    libavutil 54. 26.100 / 54. 26.100
    libavcodec 56. 41.100 / 56. 41.100
    libavformat 56. 34.100 / 56. 34.100
    libavdevice 56. 4.100 / 56. 4.100
    libavfilter 5. 16.101 / 5. 16.101
    libswscale 3. 1.101 / 3. 1.101
    libswresample 1. 1.100 / 1. 1.100
    libpostproc 53. 3.100 / 53. 3.100
  • edited June 2015
    /root/bin/ffmpeg

    And thank you for your response
  • edited June 2015
    I think the script can't use that path due to permissions. Try moving it to a more neutral location and ensure that any user can execute it.
  • Do I just need the ffmpeg file, or the full installation?
  • Got ffmpeg working!

    Just had to place it in the same directory as the rest of the website... Annnd now we're getting
    Notice:

    The following requirements were not met. As a result video uploads have been disabled.

    - Unable to locate path to PHP-CLI
  • Resolved. Just had to put php in with the website as well. It was all just a matter of permissions. Thanks So much for all of your help on this, I am So glad to finally have this working.
This discussion has been closed.