Try CumulusClips Cloud Hosting

Unable to upgrade from 2.2.0 to 2.5.2

Hi, I'm trying to update from version 2.2.0 to 2.5.2 and using the automatic method it fails and when using the manual method I get this:

"CumulusClips is unable to perform filesystem operations natively. Please provide FTP credentials."

and trying to install using the web interface I get this error "Unable to connect to FTP host ()"
all files in the cumulus folder are owned by www-data

Comments

  • You need to make sure that all of the files (recursively) are owned by Apache; typically www-data or apache. This will bypass the FTP screen. To be safe make Apache the owner of the parent directory as well.
  • DanDan
    edited August 21
    I started from scratch and made sure to chmod -R 777 and chown -R www-data:www-data everything within the cumulus directory including the parent directory (I didn't previously include the parent) and the automatic update worked, however it deleted everything from the mysql database and if I try and restore from a backup the page no longer loads.

    Is there anything you'd suggest I try?
  • Your problem was that you tried to use an older version database with a newer version codebase.

    You have to completely restore both files and DB from a backup to your original 2.2.0 version. Keep your backups handy just in case. Then once you are fully operational with 2.2.0 set the ownership as I described earlier to all files and the parent directory. Then perform the automatic update from the admin panel.
Sign In or Register to comment.