Try CumulusClips Cloud Hosting

Unable to upload video

Hello Cumulusclips Guru,

I'm not able to upload video. I'm getting this error below:
*The final H.264 file was not created. The id of the video is: 114
H.264 SHIFT MOOV ATOM
* encountered non-QT top-level atom (is this a QuickTime file?)
last atom in file was not a moov atom

Please see attached logs.

configuration:
cumulusclips 2.4.1
apache - 2.2.15
php - 5.3.3
ffmpeg-php - 0.6.2


Thanks.
JunG


log
log
converter.log
1K
log
log
NmUuZZWsr4b2qQhlsz8a.log
8K

Comments

  • Hello Damian, can you help me. Thanks..
  • That error means that the Moov atom (aka movie atom) is not at the end of the video or missing altogether.

    Can you provide a link to both the raw file (located in cc-content/uploads/temp) and the h264 temp file (located in cc-content/uploads/h264)? It would help find a problem with the file.
  • Hi Damian,
    Thanks for replying swiftly. My site is a local one because it contain oracle training intended for internal use. However, when i copied the two video from "cc-content/uploads/temp and h264 and played it in another computer, it's playing good.
    Note also that I uploaded several training videos in the past without any issue but now i can't. I tried uploading the same video which i uploaded before but it's not working now.

    Here are the encoding options:

    h.264 Encoding option:
    -vcodec libx264 -vf 'scale=1280:trunc(ow/a/2)*2' -ac 2 -ab 128k -ar 44100 -f flv -vcodec libx264 -crf 10


    WebM Encoding Option:
    -vcodec libvpx -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvorbis -ab 96k -ar 44100 -f

    Webmobile Encoding Option:
    -vcodec libx264 -vf "scale=min(480\,iw):trunc(ow/a/2)*2" -qscale 1 -ac 2 -ab 96k -ar 44100 -f mp4 -threads 0

    Theora Encoding Option:
    -vcodec libtheora -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -qscale 8 -vb 800k -acodec libvorbis -ab 96k -ar 44100 -f ogg

    Thanks.
    JunG
  • Do you have FFMPEG installed on your server? I'm wondering if the new version of FFMPEG that ships with the scrip is causing your issue. Go to Admin Panel -> Settings -> Video and change the FFMPEG path to the one that's already installed on your server and try again with a video that previously worked.
  • Hello Damian,
    I'm still getting the same error after setting the ffmpeg path to: /var/www/html/cumulusclips/cc-core/system/bin/ffmpeg-32-bit/ffmpeg.
    and even changing it to: /var/www/html/cumulusclips/cc-core/system/bin/ffmpeg-64-bit/ffmpeg.
    note that the two ffmpeg path is present when i issue the command "find / -name "ffmpeg"

    Note: i did not change any settings because it's working before and i'm able to upload almost 70 training videos.

    Thanks.
    JunG
  • Can you provide me with links to these two files so that I can help debug the problem:

    /cc-content/uploads/temp/NmUuZZWsr4b2qQhlsz8a.mp4

    /cc-content/uploads/h264/NmUuZZWsr4b2qQhlsz8a_temp.mp4
  • Good morning Damian,
    I'm afraid i cannot give you the link because it is just a local, installed in Virtual Box and exported in Xenserver.
    i can give you the above mentioned two files but i think i cannot attached it here.
    /cc-content/uploads/temp/NmUuZZWsr4b2qQhlsz8a.mp4 - 1.1mb
    /cc-content/uploads/h264/NmUuZZWsr4b2qQhlsz8a_temp.mp4 - 4.7mb

    I'm sorry, but i cannot find any workaround in google.

    Thanks.
    JunG


Sign In or Register to comment.