Try CumulusClips Cloud Hosting

PHP "Strict Standards" errors at top of screen

edited April 15 in Bugs and Errors
I just installed CC via Softaculous on cPanel. At the top of the page I see the following errors.

Strict Standards: Non-static method Language::loadEntries() should not be called statically in /home/foo/home/cc-core/lib/Language.php on line 65

Strict Standards: Non-static method Language::loadEntries() should not be called statically in /home/foo/home/cc-core/lib/Language.php on line 338

Comments

  • Open your php.ini file, and find the "error_reporting" line. Change it's value to this:

    E_ALL ^ E_STRICT

    Save and restart Apache
  • I used shared hosting, so I do not have access to php.ini. Can this be fixed in .htaccess?
  • On most shared hosting platforms, you can create your own php.ini in your document root to overwrite the default php.ini
  • What's the minimum CumulusClips needs in its' php.ini to work if I make one in the document root?
  • I'm not sure what you mean by minimum. Any error reporting level other than strict or deprecated should be fine.
Sign In or Register to comment.