Try CumulusClips Cloud Hosting

Bus error

Hey there,
installed CumulusClips on my VPS yesterday, had some problems but fixed almost all of them, except that on;

I tried to upload a videofile about 2.5 MB but get an error at shifting moov atom on H.264 video.

Video log:

System Logs

5aFYIu4FvWtfoRFcpHxM.log Purge All Logs



==================================================================
H.264 ENCODING
==================================================================

H.264 Encoding Command: /usr/bin/ffmpeg -i /home/*****/public_html/*****/cc-content/uploads/temp/5aFYIu4FvWtfoRFcpHxM.mp4 -vcodec copy -acodec libmp3lame -f mp4 /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM_temp.mp4 >> /home/*****/public_html*****/cc-core/logs/5aFYIu4FvWtfoRFcpHxM.log 2>&1

H.264 Encoding Output:


ffmpeg version 3.1.4-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2016 the FFmpeg developers
built with gcc 5.4.1 (Debian 5.4.1-2) 20160904
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --enable-libzimg --cc=gcc-5 --disable-ffplay
libavutil 55. 28.100 / 55. 28.100
libavcodec 57. 48.101 / 57. 48.101
libavformat 57. 41.100 / 57. 41.100
libavdevice 57. 0.101 / 57. 0.101
libavfilter 6. 47.100 / 6. 47.100
libswscale 4. 1.100 / 4. 1.100
libswresample 2. 1.100 / 2. 1.100
libpostproc 54. 0.100 / 54. 0.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/*****/public_html/*****/cc-content/uploads/temp/5aFYIu4FvWtfoRFcpHxM.mp4':
Metadata:
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
creation_time : 2014-02-11 08:49:55
copyright :
copyright-eng :
Duration: 00:00:40.36, start: 0.000000, bitrate: 429 kb/s
Stream #0:0(und): Audio: aac (HE-AAC) (mp4a / 0x6134706D), 24000 Hz, stereo, fltp, 63 kb/s (default)
Metadata:
creation_time : 2014-02-11 08:49:55
handler_name : GPAC ISO Audio Handler
Stream #0:1(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 480x352 [SAR 1:1 DAR 15:11], 366 kb/s, 10 fps, 10 tbr, 10k tbn, 20 tbc (default)
Metadata:
creation_time : 2014-02-11 08:49:55
handler_name : temp_m_video.h264 - Imported with GPAC 0.5.0-rev4065
[mp4 @ 0x405b5e0] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
Last message repeated 1 times
Output #0, mp4, to '/home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM_temp.mp4':
Metadata:
major_brand : isom
minor_version : 1
compatible_brands: isomavc1
copyright-eng :
copyright :
encoder : Lavf57.41.100
Stream #0:0(und): Video: h264 ([33][0][0][0] / 0x0021), yuv420p, 480x352 [SAR 1:1 DAR 15:11], q=2-31, 366 kb/s, 10 fps, 10 tbr, 10k tbn, 10k tbc (default)
Metadata:
creation_time : 2014-02-11 08:49:55
handler_name : temp_m_video.h264 - Imported with GPAC 0.5.0-rev4065
Stream #0:1(und): Audio: mp3 (libmp3lame) (i[0][0][0] / 0x0069), 24000 Hz, stereo, fltp (default)
Metadata:
creation_time : 2014-02-11 08:49:55
handler_name : GPAC ISO Audio Handler
encoder : Lavc57.48.101 libmp3lame
Stream mapping:
Stream #0:1 -> #0:0 (copy)
Stream #0:0 -> #0:1 (aac (native) -> mp3 (libmp3lame))
Press [q] to stop, [?] for help
frame= 41 fps=0.0 q=-1.0 size= 138kB time=00:00:04.00 bitrate= 281.7kbits/s speed=7.62x
frame= 83 fps= 77 q=-1.0 size= 292kB time=00:00:08.20 bitrate= 291.3kbits/s speed=7.59x
frame= 130 fps= 81 q=-1.0 size= 521kB time=00:00:12.90 bitrate= 330.8kbits/s speed=8.04x
frame= 174 fps= 82 q=-1.0 size= 726kB time=00:00:17.30 bitrate= 344.0kbits/s speed=8.13x
frame= 216 fps= 82 q=-1.0 size= 960kB time=00:00:21.50 bitrate= 365.6kbits/s speed=8.15x
frame= 263 fps= 83 q=-1.0 size= 1246kB time=00:00:26.20 bitrate= 389.5kbits/s speed=8.31x
frame= 301 fps= 82 q=-1.0 size= 1446kB time=00:00:30.00 bitrate= 394.9kbits/s speed=8.21x
frame= 348 fps= 83 q=-1.0 size= 1749kB time=00:00:34.70 bitrate= 412.8kbits/s speed= 8.3x
frame= 386 fps= 82 q=-1.0 size= 2008kB time=00:00:38.50 bitrate= 427.3kbits/s speed=8.18x
frame= 400 fps= 80 q=-1.0 Lsize= 2116kB time=00:00:40.36 bitrate= 429.4kbits/s speed=8.12x
video:1790kB audio:316kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.493784%




==================================================================
H.264 SHIFT MOOV ATOM
==================================================================

H.264 Shift Moov Atom Command: /home/*****/public_html/*****/cc-core/system/bin/ffmpeg-64-bit/qt-faststart /home*****/public_html*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM_temp.mp4 /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM.mp4 >> /home/*****/public_html/*****/cc-core/logs/5aFYIu4FvWtfoRFcpHxM.log 2>&1

H.264 Shift Moov Atom Output:



Converter log

Purge All Logs
Zend OPcache requires Zend Engine API version 220121212.
The Zend Engine API version 220131226 which is installed, is newer.
Contact Zend Technologies at http://www.zend.com/ for a later version of Zend OPcache.



// Converter Called...
Values passed to encoder:
Array
(
[0] => /home/*****/public_html/*****/cc-core/system/encode.php
[1] => --video=21
)


Checking FFMPEG permissions...

Checking qt-faststart permissions...
Validating requested video...
Establishing variables...
Verifying raw video exists...
Verifying raw video was valid size...

Preparing for: H.264 Encoding...
H.264 Encoding Command: /usr/bin/ffmpeg -i /home/*****/public_html/*****/cc-content/uploads/temp/5aFYIu4FvWtfoRFcpHxM.mp4 -vcodec copy -acodec libmp3lame -f mp4 /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM_temp.mp4 >> /home/*****/public_html/*****/cc-core/logs/5aFYIu4FvWtfoRFcpHxM.log 2>&1
Verifying H.264 video was created...

Shifting moov atom on H.264 video...
H.264 Shift Moov Atom Command: /home/*****/public_html/*****/cc-core/system/bin/ffmpeg-64-bit/qt-faststart /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM_temp.mp4 /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM.mp4 >> /home/*****/public_html/*****/cc-core/logs/5aFYIu4FvWtfoRFcpHxM.log 2>&1
sh: line 1: 2005 Bus error /home/*****/public_html/*****/cc-core/system/bin/ffmpeg-64-bit/qt-faststart /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM_temp.mp4 /home/*****/public_html/*****/cc-content/uploads/h264/5aFYIu4FvWtfoRFcpHxM.mp4 >> /home/*****/public_html/*****/cc-core/logs/5aFYIu4FvWtfoRFcpHxM.log 2>&1
Verifying final H.264 file was created...
The final H.264 file was not created. The id of the video is: 21

Comments

  • No solution...?
  • Your log indicates that you are using the 64 bit version of FFMPEG. Is your server a 64 bit machine?

    Do you get the same error when you go to Admin Panel -> Settings -> Video and change the FFMPEG path from 64 to 32 or vice versa?

    Also, how big is the video file and how much RAM and CPU are on your server?
  • Thanks for your reply!
    I'm running a TMDHosting dualcore VPS with 2GB of DDR4 and its running with CentOS 64bit. The videofile has about 2.5MB.

    I set the FFMPEG path to the 32bit version, the converter error changed from Bus error to Segmentation fault;

    Video Log still shows the same as above, converter log changed to this;


    Zend OPcache requires Zend Engine API version 220121212.
    The Zend Engine API version 220131226 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend OPcache.



    // Converter Called...
    Values passed to encoder:
    Array
    (
    [0] => /home/***/public_html/***/cc-core/system/encode.php
    [1] => --video=32
    )


    Checking FFMPEG permissions...

    Checking qt-faststart permissions...
    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: H.264 Encoding...
    H.264 Encoding Command: /usr/local/bin/ffmpeg -i /home/***/public_html/***/cc-content/uploads/temp/KgKnT4qn4riULAU8uJ8t.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -strict experimental -ab 96k -ar 44100 -f mp4 /home/***/public_html/***/cc-content/uploads/h264/KgKnT4qn4riULAU8uJ8t_temp.mp4 >> /home***/public_html/***/cc-core/logs/KgKnT4qn4riULAU8uJ8t.log 2>&1
    Verifying H.264 video was created...

    Shifting moov atom on H.264 video...
    H.264 Shift Moov Atom Command: /home/***/public_html/***/cc-core/system/bin/ffmpeg-32-bit/qt-faststart /home/***/public_html/***/cc-content/uploads/h264/KgKnT4qn4riULAU8uJ8t_temp.mp4 /home/***/public_html/***/cc-content/uploads/h264/KgKnT4qn4riULAU8uJ8t.mp4 >> /home/***/public_html/***/cc-core/logs/KgKnT4qn4riULAU8uJ8t.log 2>&1
    sh: line 1: 15922 Segmentation fault /home/***/public_html/***/cc-core/system/bin/ffmpeg-32-bit/qt-faststart /home/***/public_html/***/cc-content/uploads/h264/KgKnT4qn4riULAU8uJ8t_temp.mp4 /home/***/public_html/***/cc-content/uploads/h264/KgKnT4qn4riULAU8uJ8t.mp4 >> /home/***/public_html/***/cc-core/logs/KgKnT4qn4riULAU8uJ8t.log 2>&1
    Verifying final H.264 file was created...
    The final H.264 file was not created. The id of the video is: 32
  • The problem occurs with qt-faststart and the Segmentation Fault occurs as a result of running the app in 32bit mode on your 64bit machine. So you definitely need to set it back to 64.

    What Linux flavor is this? Is this ubuntu by any chance?

    GM
  • Ok, thanks for the hint, i switched back to the 64bit directory.
    Surprisingly the bus error occurred again ^^

    Nope, distro it is CentOS.
  • Do you see any storage errors in /var/log/messages?

    Try downloading this ffmpeg binary package, which comes with qt-faststart, and see if that one works better: https://johnvansickle.com/ffmpeg/releases/ffmpeg-release-64bit-static.tar.xz

    GM
  • Thanks! I'll try that and report a lil bit later :)
  • Funny thing... copied the downloaded qt-faststart into the 64bit directory...
    Getting a segmentation error now.


    Shifting moov atom on H.264 video...
    H.264 Shift Moov Atom Command: /home/***/public_html/***/cc-core/system/bin/ffmpeg-64-bit/qt-faststart /home/***/public_html/***/cc-content/uploads/h264/yFv5yhiAWVL4SalwOmZ6_temp.mp4 /home/***/public_html/***/cc-content/uploads/h264/yFv5yhiAWVL4SalwOmZ6.mp4 >> /home/***/public_html***/cc-core/logs/yFv5yhiAWVL4SalwOmZ6.log 2>&1
    sh: line 1: 7341 Segmentation fault /home/***/public_html/***/cc-core/system/bin/ffmpeg-64-bit/qt-faststart /home***/public_html/***/cc-content/uploads/h264/yFv5yhiAWVL4SalwOmZ6_temp.mp4 /home/***/public_html/***/cc-content/uploads/h264/yFv5yhiAWVL4SalwOmZ6.mp4 >> /home/***/public_html/***/cc-core/logs/yFv5yhiAWVL4SalwOmZ6.log 2>&1
    Verifying final H.264 file was created...
    The final H.264 file was not created. The id of the video is: 34
  • Very odd. Can you scan through your /var/log/messages file to see if it is reporting any hardware errors?
  • No hardware errors at all, just that;


    ffmpeg version 3.0.2 Copyright (c) 2000-2016 the FFmpeg developers
    built with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-17)
    configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --enable-libmp3lame --enable-libx264 --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-gray --enable-libopenjpeg --enable-gnutls --enable-libfaac --enable-nonfree --disable-indev=sndio --disable-outdev=sndio --cc=gcc
    libavutil 55. 17.103 / 55. 17.103
    libavcodec 57. 24.102 / 57. 24.102
    libavformat 57. 25.100 / 57. 25.100
    libavdevice 57. 0.101 / 57. 0.101
    libavfilter 6. 31.100 / 6. 31.100
    libswscale 4. 0.100 / 4. 0.100
    libswresample 2. 0.101 / 2. 0.101
    libpostproc 54. 0.100 / 54. 0.100
    [mov,mp4,m4a,3gp,3g2,mj2 @ 0x3ab32a0] moov atom not found
    /home/*****/public_html/*****/media/videos/hd/2.mp4: Invalid data found when processing input
  • Did a fresh new install, everything is working fine now. Thanks for your support.
Sign In or Register to comment.