Try CumulusClips Cloud Hosting

Bug When trying to upload. It stays it is Processing and Video never get uploaded

edited July 2016 in Bugs and Errors
Hi all. Trying to upload videos however im getting the error The temp H.264 file was not created. The id of the video is: 17.

Through log i can see:

==================================================================
H.264 ENCODING
==================================================================

H.264 Encoding Command: /home/kingcomb/public_html/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/kingcomb/public_html/cc-content/uploads/temp/5VPz9isXqx9YgcblKPfR.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvo_aacenc -ab 96k -ar 44100 -f mp4 /home/kingcomb/public_html/cc-content/uploads/h264/5VPz9isXqx9YgcblKPfR_temp.mp4 >> /home/kingcomb/public_html/cc-core/logs/5VPz9isXqx9YgcblKPfR.log 2>&1

H.264 Encoding Output:


AND THROUGH CONVERTER.LOG I CAN SEE:

// Converter Called...
Values passed to encoder:
Array
(
[0] => /home/kingcomb/public_html/cc-core/system/encode.php
[1] => --video=18
)


Checking FFMPEG permissions...

Checking qt-faststart permissions...
Validating requested video...
Establishing variables...
Verifying raw video exists...
Verifying raw video was valid size...

Preparing for: H.264 Encoding...
H.264 Encoding Command: /home/kingcomb/public_html/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/kingcomb/public_html/cc-content/uploads/temp/5VPz9isXqx9YgcblKPfR.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvo_aacenc -ab 96k -ar 44100 -f mp4 /home/kingcomb/public_html/cc-content/uploads/h264/5VPz9isXqx9YgcblKPfR_temp.mp4 >> /home/kingcomb/public_html/cc-core/logs/5VPz9isXqx9YgcblKPfR.log 2>&1
Verifying H.264 video was created...
The temp H.264 file was not created. The id of the video is: 18

Comments

  • Do all videos have this probelm? Try uploading a small short video, to see if you have the same issue.

    Your encoding log was cut off. This usually happens for one of several reasons:

    1) Not enough RAM on the server or allocated to your account

    2) Permission denied to PHP user

    3) FFMPEG CPU prifile incompatible with processor architecture

    4) Restrictions on script/binaries by host or control panel

    Run this command from the root of the script:

    chmod -R 777 cc-core/system/bin

    Also try changing the 64-bit ffmpeg for the 32-bit. You can do this in the Admin Panel -> Settings -> Video -> FFMPEG Path. Simply replace 64 with 32. This most likely is not the issue, but we want to verify that both are having the same problem.

    Ask your webhost if there are any limitations in Apache running an executable. Sometimes they block this.

    Verify your PHP/Apache user has permissions to run executables.

    Lastly, make sure your server has decent RAM, 4GB+ dedicated to your account.
Sign In or Register to comment.