Just Installed - cannot execute binary file

Trying to upload my first video and this is what I get. Any ideas?

Thank you,


H.264 Encoding Command: /home/yogama3/global.cinetribe.club/stream/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/yogama3/global.cinetribe.club/stream/cc-content/uploads/temp/849HBaSm0NhBdeEd6smz.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -ab 96k -ar 44100 -f mp4 /home/yogama3/global.cinetribe.club/stream/cc-content/uploads/h264/849HBaSm0NhBdeEd6smz_temp.mp4 >> /home/yogama3/global.cinetribe.club/stream/cc-core/logs/849HBaSm0NhBdeEd6smz.log 2>&1

H.264 Encoding Output:

sh: /home/yogama3/global.cinetribe.club/stream/cc-core/system/bin/ffmpeg-64-bit/ffmpeg: cannot execute binary file


  • Are the permissions set to allow the file to be executable?
  • Thank you for responding.

    I did follow the installation instructions to make that small list of directories with the right permissions. I wonder if there's other permissions that need changing, other than the ones mentioned in the instructions - http://cumulusclips.org/docs/installation/.

  • I wonder, does the cc-content directory itself need 0777, or just the relevant inner directories.

    Meaning, if the inner directories (from the instructions) are 0777, can cc-content itself be 0755 and work okay?
  • How are the permissions currently set for ffmpeg? Are you able to run/execute the binary on the command line? If so, does it work there? I think the binary itself will need it's permissions set so that it's executable, i.e. via something like chmod 0775 /home/yogama3/global.cinetribe.club/stream/cc-core/system/bin/ffmpeg-64-bit/ffmpeg

  • Thank you for responding.

    the two files inside 'ffmpeg-64-bit' are set as 0777
    the two files inside 'ffmpeg-32-bit' are set as 0755

    Unfortunately tinkering on the the command line level is beyond my comfortable abilities. If Cumulus Clips requires that level of knowledge I'll need to find a different solution.

    Question, does the 'ffmpeg-64-bit' directory also need to be set to 0777, or is it sufficient for the internal files to be set to 0777 and the containing folder is fine as 0755 (which is what it is now)?

    Last question - although slightly off topic. Is there an easy way to by-pass re-encoding?

    Thanks again. Appreciate the guidance.

  • I don't think command line is required - just that if you have access it might help to narrow things down a bit, i.e. see if the OS was able to run it. Do you happen to get the same error when you set the path for ffmpeg in Settings->Video to use the 32 bit binary?

    I'm not sure there's an easy way to turn off encoding. Note that doing so might pose various problems for visitors trying to watch the uploaded videos...
  • I tried switching the path to 32 bit and although it tells me in the interface (as it was doing before) that the video was created, I immediately get an email saying, "The temp H.264 file was not created. The id of the video is: 4 "

    The upload is in the temp folder, but no other file has been created. And no videos actually show on the site.

    I was really hoping for a solution that was simple to setup and use!

    If it's an easy task to use the command line interface to test, I might be able to do it.?.

    I appreciate your help. Sorry we couldn't just fix it.
  • Well, a different error message counts as progress in my book. :) Do you see anything in the logs pertaining to that video id? i.e. either in converter.log or in the log for that specific video?
  • What OS are you running this on?

  • Thank you both for sticking with this!

    I never checked the converter.log until now. Here is what it says:

    // Converter Called...
    Values passed to encoder:
    [video] => 2

    Checking FFMPEG permissions...

    Checking qt-faststart permissions...
    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: H.264 Encoding...
    H.264 Encoding Command: /home/yogama3/global.cinetribe.club/stream/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/yogama3/global.cinetribe.club/stream/cc-content/uploads/temp/JzlBJjLBPPcfhxRYDB3h.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -ab 96k -ar 44100 -f mp4 /home/yogama3/global.cinetribe.club/stream/cc-content/uploads/h264/JzlBJjLBPPcfhxRYDB3h_temp.mp4 >> /home/yogama3/global.cinetribe.club/stream/cc-core/logs/JzlBJjLBPPcfhxRYDB3h.log 2>&1
    Verifying H.264 video was created...
    The temp H.264 file was not created. The id of the video is: 2
  • When you ask what OS this is running on, I assume you mean the web server.

    Operating System linux
    Apache Version 2.4.46
    PHP Version 7.2.33
    MySQL Version 5.6.47
    Architecture x86_64
  • What is in the log for that video (i.e. JzlBJjLBPPcfhxRYDB3h.log )?
  • I concur with Henry. It would help to see the contents of JzlBJjLBPPcfhxRYDB3h.log.

    As far as the OS, do you know what flavor of Linux? (CentOS, Red Hat, Debian etc?) Reason I ask is because I don't think it's supported on every Linux version, and difference between versions (i.e. libraries etc) could definitely have an impact.
Sign In or Register to comment.