CC 2.5.2 - fresh install - ftp error


I have this error (see attach file), when I do a fresh install of CC2.5.2. No problem with update, no problem with 2.5.1 fresh install.



  • You received this error because the script thought it didn't need FTP access, but later encountered a file which did require FTP access.

    Make sure all the files are owned by Apache user. They need to be owned by the Apache user, changing permissions is not enough.
  • o71o71
    edited April 2017
    I have do it,
    /var/www/html# chown www-data:www-data * -R

    And I have the ftp error :-(

    Why in the previously picture, the host is blank ? I have wrote 'localhost' in the form.
  • Can you post the results of "ls -la" from the root of the script
  • The root is cc-install directory ?

    drwxrwxrwx 8 www-data www-data 4096 avril 20 15:25 .
    drwxrwxrwx 6 www-data www-data 4096 avril 20 15:25 ..
    -rwxrwxrwx 1 www-data www-data 3483 avril 20 15:25 complete.php
    drwxrwxrwx 2 www-data www-data 4096 avril 20 15:25 css
    -rwxrwxrwx 1 www-data www-data 7286 avril 20 15:25 database.php
    -rwxrwxrwx 1 www-data www-data 4962 avril 20 15:25 ftp.php
    drwxrwxrwx 2 www-data www-data 4096 avril 20 15:25 images
    drwxrwxrwx 2 www-data www-data 4096 avril 20 15:25 includes
    -rwxrwxrwx 1 www-data www-data 1104 avril 20 15:25 index.php
    drwxrwxrwx 2 www-data www-data 4096 avril 20 15:25 js
    -rwxrwxrwx 1 www-data www-data 4304 avril 20 15:25 requirements.php
    -rwxrwxrwx 1 www-data www-data 2774 avril 20 15:25 site-details.php
    drwxrwxrwx 5 www-data www-data 4096 avril 20 15:25 tipsy
    -rwxrwxrwx 1 www-data www-data 2093 avril 20 15:25 update.php
    drwxrwxrwx 2 www-data www-data 4096 avril 20 15:25 views
    -rwxrwxrwx 1 www-data www-data 394 avril 20 15:25 welcome.php

  • no, the root of CumulusClips, the parent directory of cc-install. Run "ls -la" at the root.
  • ok

    drwxrwxrwx 6 www-data www-data 4096 avril 20 15:41 .
    drwxr-xr-x 5 root root 4096 avril 19 17:57 ..
    drwxrwxrwx 6 www-data www-data 4096 avril 20 15:41 cc-admin
    drwxrwxrwx 7 www-data www-data 4096 avril 20 15:41 cc-content
    drwxrwxrwx 9 www-data www-data 4096 avril 20 15:41 cc-core
    drwxrwxrwx 8 www-data www-data 4096 avril 20 15:41 cc-install
    -rwxrwxrwx 1 www-data www-data 1150 avril 20 15:41 favicon.ico
    -rwxrwxrwx 1 www-data www-data 137 avril 20 11:36 .htaccess
    -rwxrwxrwx 1 www-data www-data 390 avril 20 15:41 index.php
    -rwxrwxrwx 1 www-data www-data 18932 avril 20 15:41 LICENSE.txt
    -rwxrwxrwx 1 www-data www-data 1523 avril 20 15:41 README.txt
  • Ok, that looks good. Lets verify if the ownership change worked:

    1) Clear all the cookies and cache in your browser
    2) Navigate to /cc-install in your browser
    3) Start the Install process from the very beginning

    Let me know if you get prompted for provide FTP details (you shouldn't because Apache owns the files) and if you still get the error above.

    You must 100% make sure that you delete the cookies, otherwise the installer will try to pick up where you last left off.
  • So, I have installed a new debian virtual machin and its works with it.

    My first test was done on a debian server that already had a cumulus website. I wanted to install another one (different database and different directory).

    First site:
    - database: cumulus
    - directory: /var/www/html/cumulus

    Twice site:
    - database: cumulus2
    - directory: /var/www/html/cumulus2

    Why it isn't possible ? It's a problem with ftp ?

  • o71o71
    edited April 2017
    If on my server who have one cumulus website, I install another Cumuls CC 2.5.1 (new database and new directory) and I update to CC 2.5.2, its works. Why I can't install CC 2.5.2 directly ?
  • It should work.

    There is only a problem if the file ownership is incorrect. For example, if the files are owned by Apache, the script will proceed as normal. If the files are not owned by Apache, you will be prompted for FTP credentials.

    In your first attempt from earlier, the root was owned by Apache but not the files. This caused the script to get confused. You fixed it by performing chown on all the files. However you didn't clear your cookies and cache and re-attempt to verify that it was fixed.

    You need to either make sure that all the files are owned by Apache, or be prepared to provide FTP credentials before you begin the installer.

    We are working on updating our install instructions to make this more clear, but essentially those are your options.
  • First, I thank you for your patience.

    I try again, but unsuccessfully.

    I do it :

    #cp /root/cumulusclips-2.5.2/ /var/www/html/ -R
    #mv /var/www/html/cumulusclips-2.5.2/ /var/www/html/cumulusclips2
    #chown www-data:www-data /var/www/html/cumulusclips2/ -R

    Are there any other files that should be owned by apache ?

    And :

    #mysql -u root -p
    mysql> create database cumulusclips2;
    mysql> grant all on cumulusclips2.* to 'cumulus'@'localhost';

    PS : the user cumulus exists.

    To do the web install, I used chrome in private mode and I had test with IE (I had never used it before to install CC.). I have always the problem. In yellow on the capture, the text I wrote.
    1198 x 935 - 237K
  • I find my problem. It's my fault.

    I have use this tar.gz :
    With this file, no problem :

    I thought it was the same files. What is the difference ?
  • They are the same. I'm not sure why one worked and the other didn't.
  • o71o71
    edited April 2017
    The size is different :

    - github

    -rw-r--r-- 1 root root 2950707 avril 20 21:21 2.5.2.tar.gz

    - The other

    -rw-r--r-- 1 root root 34215909 avril 19 10:14 cumulusclips.2.5.2.tar.gz
  • edited April 2017
    Yes, because we don't store the FFMPEG executables in GitHub. GitHub contains only code, the archives found on our website contain the code plus the FFMPEG executables.
  • Strange, I just tried again with the link github, and it doesn't work. But the main thing is that I get there with the other :-)
  • Hello,

    I made a last test unsuccessful.
    1- Using a clean Debian (from a template)
    2- installation with github.tar.gz
    3- it's fail with ftp error

    I test with the file --> error ftp

    But its works perfectly with this file :

    I stop my investigations :-)
Sign In or Register to comment.