I upload a short video and it stays days processing, any solution?

I upload a short video and it stays days processing, any solution?


  • Go to Admin Panel -> Dashboard -> System Logs and purge the logs.

    Then go to Admin Panel -> Settings -> Video -> Log Encoding and set this to "enabled"

    Next try your upload again. After a few minutes go back to the logs page and attach the contents of the two log files here.

  • Thanks for replying, update the script and I made a mistake in plugins and in creating page and also when I want to upload a video I get this error Errors were encountered during the processing of your file, and it can not be uploaded at this time. We apologize for this inconvenience.

  • This is the error uploading the video
    1224 x 676 - 163K
  • Hello Carlos, we will need to see your logs. You can find them in the admin panel -> dashboard -> system logs.

  • Uploads the video but never appears on the page
  • The video I uploaded never appears on the page
    1233 x 987 - 189K
    1233 x 987 - 374K
  • I go to system log and purge records
    1233 x 987 - 341K
  • I'm going to setup video encoding and it's active and to a if the videos you posted do not appear
    328 x 948 - 114K
  • I see the issue already. Go to Admin Panel - Settings - Video - H.264 Options and replace "libvo_aacenc" with just "aac". Then purge your logs and try again.

  • I already did and I did not work, friend :( I have 3 weeks and I was unable to upload a single video, please give me the solution, I'm tired of trying things that do not fix the problem
    691 x 518 - 127K
  • Please do the following:

    1) Change the H.264 Options to lowercase "aac". You currently have it as uppercase which is incorrect
    2) In Admin Panel -> Settings -> Video Disable WebM, Theora, and Mobile encoding.
    3) Go to Admin Panel -> Dashboard -> System Logs and click purge logs.
    4) Try your upload again.
    5) After about five minutes go back to Admin Panel -> Dashboard -> System Logs and you should see two (2) entries in the select box. Select one and copy and paste all of the contents of the grey box here in this post. Do this for both logs in the select box.

    We need the entire logs, screenshots are not enough.
  • Try these settings:

    -threads 0 -vcodec libx264 -vf "scale=1280:trunc(ow/a/2)*2" -acodec aac -ab 128k -ar 44100 -f mp4 -strict -2

    -threads 0 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 600k -ac 2 -ab 96k -ar 44100 -f mp4 -strict -2
  • convert.log

    // Converter Called...
    Values passed to encoder:
    [video] => 19

    Checking FFMPEG permissions...

    Checking qt-faststart permissions...
    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: H.264 Encoding...
    H.264 Encoding Command: /home/videosca/public_html/yousextube/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/videosca/public_html/yousextube/cc-content/uploads/temp/pUpu0P9DXpXdN5mYllt7.mp4 -threads 0 -vcodec libx264 -vf "scale=1280:trunc(ow/a/2)*2" -acodec aac -ab 128k -ar 44100 -f mp4 -strict -2 /home/videosca/public_html/yousextube/cc-content/uploads/h264/pUpu0P9DXpXdN5mYllt7_temp.mp4 >> /home/videosca/public_html/yousextube/cc-core/logs/pUpu0P9DXpXdN5mYllt7.log 2>&1
    Verifying H.264 video was created...
    The temp H.264 file was not created. The id of the video is: 19
  • ==================================================================
    H.264 ENCODING

    H.264 Encoding Command: /home/videosca/public_html/yousextube/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/videosca/public_html/yousextube/cc-content/uploads/temp/pUpu0P9DXpXdN5mYllt7.mp4 -threads 0 -vcodec libx264 -vf "scale=1280:trunc(ow/a/2)*2" -acodec aac -ab 128k -ar 44100 -f mp4 -strict -2 /home/videosca/public_html/yousextube/cc-content/uploads/h264/pUpu0P9DXpXdN5mYllt7_temp.mp4 >> /home/videosca/public_html/yousextube/cc-core/logs/pUpu0P9DXpXdN5mYllt7.log 2>&1

    H.264 Encoding Output:

    ffmpeg version 3.2.4-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2017 the FFmpeg developers
    built with gcc 5.4.1 (Debian 5.4.1-5) 20170205
    configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc-5 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gray --enable-libass --enable-libfreetype --enable-libfribidi --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzimg
    libavutil 55. 34.101 / 55. 34.101
    libavcodec 57. 64.101 / 57. 64.101
    libavformat 57. 56.101 / 57. 56.101
    libavdevice 57. 1.100 / 57. 1.100
    libavfilter 6. 65.100 / 6. 65.100
    libswscale 4. 2.100 / 4. 2.100
    libswresample 2. 3.100 / 2. 3.100
    libpostproc 54. 1.100 / 54. 1.100
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/videosca/public_html/yousextube/cc-content/uploads/temp/pUpu0P9DXpXdN5mYllt7.mp4':
    major_brand : qt
    minor_version : 512
    compatible_brands: qt
    encoder : Lavf55.33.100
    Duration: 00:01:04.83, start: 0.000000, bitrate: 5014 kb/s
    Stream #0:0(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 5003 kb/s, 30 fps, 30 tbr, 15360 tbn, 60 tbc (default)
    handler_name : DataHandler
    encoder : libx264
    Stream #0:1(eng): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 3 kb/s (default)
    handler_name : DataHandler
    [AVFilterGraph @ 0x4cb1340] Error initializing threading.
    [AVFilterGraph @ 0x4cb1340] Error creating filter 'anull'
    Error opening filters!

  • there they are
  • Thank you. The error you are receiving looks like it's resource related.

    One of the following could be your problem:

    1) Your operating system has a limit on the number of threads a processes that a program or user can consume
    2) There are too many concurrent processes running competing for CPU usage
    3) There is not enough memory available on the server.

    Try setting "-threads 1" in the H.264 encoding options. If that doesn't work, set it to "-threads 0" or try removing it altogether. Run "ulimit -u" to see the current process limit.

    Ultimately this is an issue with resources needed to transcode this particular video versus what you're allowed or able to consume on that server.
  • Use of CumulusClips for adult content is prohibited. We can no longer assist you.
This discussion has been closed.