"Were unable to connect to your FTP"

Hello... I'm currently running Ubuntu Meet all the requirements. etc... how ever.. I'm stuck on this part of the install... I'm getting "We were unable to connect to the FTP server you specified, please verify it is correct" I've tried local host.. public IP for the server and Private.. and I'm still getting the same error.. tried to make a new username.. new group.. I can connect fine though filezilla.. how ever i keep getting this same issue when trying to install.. any advise?


  • Did you try
  • I have... Is there any way to by pass the FTP for install... I don't mind doing manual updates... I have tried adding "www-data" to the directory for cumulus but It still prompts me for FTP info with the same error.
  • I did some research and found this in the fourms...

    "Option 2:

    1) Add the Apache user to the group which currently owns all your files.
    2) Change the permissions on your files to: 775 for directories and 664 for files.

    This takes care of the warning from option 1, and you'll still be able to manually do FTP when you want. You will also no longer be prompted for FTP during install."

    Now if I Create a group for ex: "user" and I add "www-data" to that group and add that group to the directory for cumulus.. will this enable me to bypass the FTP screen and continue the installation?

    Thank you
  • I was able to bypass the above issue... but now I am getting HTTP error 500 when submitting my database info.. I checked my php error logs and this is what I got. PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/html/cc-install/database.php
  • Here is the full error
    PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/html/cc-install/database.php:76\nStack trace:\n#0 /var/www/html/cc-install/index.php(37): include_once()\n#1 {main}\n thrown in /var/www/html/cc-install/database.php on line 76, referer:
  • What version of PHP do you have?
  • Should I revert back to PHP 5.0 do you think?

    sudo apt-get remove php7
    sudo apt-get install php5

  • Yes, I would recommend doing so. Anything 5.x that is 5.3 or greater.

    PHP 7 deprecated and removed some things which breaks the installer. The main script is also untested with it.
  • getting there... I've done a fresh install of ubuntu 14.04 .. with all the requirements. .. changed the directory ownership to www-data and created a group for that directory so I still had FTP access.. This bypassed the FTP part of the installer... I'm now stuck on the database part of the install.. I created a database and user with phpmyadmin.. added those credentials to the installer.. how ever I get this error now..... Unable to connect to FTP host ()

  • hmm so I restarted my server and I was able to complete the install and got past the error above.. how ever.. when I click on any link like videos... log out etc.. it takes me to a 404 page not found
  • @Damian ... I'm able to upload a test video through the admin panal... but I did notice this in the log and no video
    Unknown encoder 'libvo_aacenc'
  • I tried changing out 'libvo_aacenc' with 'acc' and got " unknown encoder acc"
  • I think the instructions you found are a bit old. The way the FTP check currently works is that the script checks to see if the user running PHP (Apache "www-data" in your case) owns the files. If it does, then FTP is bypassed, if it does not, then FTP is requested.

    In your case, you actually discovered a weak check in our installer that needs to be made stricter.

    There technically is no FTP workaround anymore. If you do, you will get errors during certain file operations i.e. changing file permissions, because they can only be executed by the owner of the file.

    The correct approach is to either:

    1) Run in CGI mode, using php-fpm. This will bypass FTP in the script, and allow you to FTP your files as normal

    2) Run as Apache module (mod_php). You will not need FTP in the script, however you will not be able to modify the files (upload/download) using a different FTP user.

    You are currently using method number 2. You were asked for FTP because you uploaded the files via FTP using a user different than the Apache user.

    To fix your libvo_aacenc error, replace libvo_aacenc with just aac in Admin Panel -> Settings -> Video -> H.246 Options.

    Hope this helps.
  • edited August 2016
    Ftp errors are all taken care off. I'm only left with two issues.
    1. Any links outside of my admin panel bring me to a dead end error 404

    2. I tried changing libvo aacenc with acc in settings video h.246. And I now get unknown encoder "acc" in my log

    Thanks for all your time. I really appreciate it
  • For issue 1. the htaaccess file is indeed there. I also ran the command sudo a2enmod rewrite.. still getting 404 on every page
  • Okay lol... I fixed Issue 1.. When i changed Allow override from none to All I had a typo and put Al .. was missing an L.... so all I'm left with is issue number 2. unknown encoder "acc"
  • Just an update.. I reinstalled ffmpeg and everything seems to be working now.
This discussion has been closed.