Video Upload Error

This discussion was created from comments split from: No files uploaded.


  • I have the same issue!

    Mu php.ini has this: max_execution_time = 5000
    file_uploads = On
    post_max_size = xxxxM
    upload_max_filesize = xxxxM

    but can't upload!
  • I get this message at my email about the error: The raw video file transfer failed. Video File: /home/oscararx/public_html/tvcotorrea/cc-content/uploads/temp/tLZKwGj5mHjqdLIbvvqp.mp4
  • The funny thing is that when I first install the script I was able to upload a video! and now I can't!
  • Make sure all the folders in /cc-content/uploads have 777 permissions, including the /cc-content/uploads/temp folder.
  • Hello

    I have done that and it works now!
  • Ok

    Now it got stuck on processing it's been almost 15 minutes now and nothing yet! the video is just 14mb
  • While I wait for you! I have tried different things but to no avail!
    I now get this e-mail message: The temp H.264 file was not created. The id of the video is: 19
    I created that h.264 file but no luck (I since deleted it)
    another video was upload it but still it gets stuck on processing!
  • Can you enable "Log Encoding" in the Admin Panel -> Settings -> Video. The go to Admin Panel -> Dashboard -> System Logs and purge all logs. Then try upload again. After a while, when it fails, go back to the logs and attach them both here.
  • T did as told to no avail! this is what you requested:

    H.264 ENCODING

    H.264 Encoding Command: /home/oscararx/public_html/tvcotorrea/cc-core/system/bin/ffmpeg-32-bit/ffmpeg -i /home/oscararx/public_html/tvcotorrea/cc-content/uploads/temp/AHoPXW5AHveJuYQSZDnB.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvo_aacenc -ab 96k -ar 44100 -f mp4 /home/oscararx/public_html/tvcotorrea/cc-content/uploads/h264/AHoPXW5AHveJuYQSZDnB_temp.mp4 >> /home/oscararx/public_html/tvcotorrea/cc-core/logs/AHoPXW5AHveJuYQSZDnB.log 2>&1

    H.264 Encoding Output:

    ffmpeg version 3.1-static Copyright (c) 2000-2016 the FFmpeg developers
    built with gcc 5.4.0 (Debian 5.4.0-4) 20160609
    configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --enable-libmfx --enable-libzimg --cc=gcc
    libavutil 55. 27.100 / 55. 27.100
    libavcodec 57. 48.101 / 57. 48.101
    libavformat 57. 40.101 / 57. 40.101
    libavdevice 57. 0.101 / 57. 0.101
    libavfilter 6. 46.102 / 6. 46.102
    libswscale 4. 1.100 / 4. 1.100
    libswresample 2. 1.100 / 2. 1.100
    libpostproc 54. 0.100 / 54. 0.100
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/oscararx/public_html/tvcotorrea/cc-content/uploads/temp/AHoPXW5AHveJuYQSZDnB.mp4':
    major_brand : isom
    minor_version : 0
    compatible_brands: isom3gp4
    creation_time : 2014-03-04 22:07:53
    Duration: 00:00:07.25, start: 0.000000, bitrate: 2991 kb/s
    Stream #0:0(eng): Video: mpeg4 (Simple Profile) (mp4v / 0x7634706D), yuv420p, 800x480 [SAR 1:1 DAR 5:3], 1986 kb/s, 29.90 fps, 30 tbr, 90k tbn, 1k tbc (default)
    creation_time : 2014-03-04 22:07:53
    handler_name : VideoHandle
    encoder :
    Stream #0:1(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 156 kb/s (default)
    creation_time : 2014-03-04 22:07:53
    handler_name : SoundHandle
    Unknown encoder 'libvo_aacenc'


    The temp H.264 file was not created. The id of the video is: 21
  • I see the problem, go to Admin Panel - Settings - Video - H.264 Options and replace "lib_aacenc" with "aac". Save the settings, purge the logs again, and try to upload the video again.
  • Damian

    Now is working like is supposed to!

    - About the live link on the description -Till next updated then?

    Oscar Medina
Sign In or Register to comment.