Install goes fine, admin page fine, main page fine. 404 on all other pages

edited March 2013 in Customizations
I have tried this install a few times now.

I copy the files into the website. I make sure all files and folders have permission 755 and that the upload and log dir have the 777 permissions.

Install goes fine, no errors. It loads me to the admin page and it functions. I then goto the main page. Click on upload, I get a 404 error, I click the videos button and get a 404 error and I click on the members and get a 404 error.

On the links it seems like it tries going to directories that were never created such as

I look and there is no /members directory or /videos or /upload for that matter.....

Anyone have this issue?



  • You're missing the .htaccess file
  • so I should try re-downloading the software again?
  • I tried, still the same thing.... what could I be doing wrong?
  • The .htaccess file is a hidden file. You need be able to view hidden files in your file browser or FTP client in order to see the file. When you find it, upload it to the root of your CumulusClips site and you'll be good to go.
  • ok, I looked in the folder of the cumulus download with the "show hidden files" I also tried downloading it again and then uploading it and decompressing it with the cpanel file manager. no .htaccess file... Do you think this could be something they forgot to include with the download package?
  • You must be doing something incorrectly. I just downloaded it and the file is there.

    Also, just to make sure, verify your webhost is using Apache 2 and that mod_rewrite is enabled in Apache.
  • are you seeing the .htaccess file in a particular folder? I'll downloaded it again and look.
  • Is this your own server? Are you able to customize your apache vhost settings? Try the solutions mentioned in
  • i think someone can just send him the content of the .htaccess file and he can upoad it

    will that work?
    i think so


    he can actually find the root cause of this so he can stop and avoid it
This discussion has been closed.