error after installation

edited January 2013 in Bugs and Errors
I get this error after installation

"Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /..../cc-core/lib/Functions.php on line 330"

Why do i get this error and what do i do to fix it?

Thanks a lot!


  • By reading that error message it sounds like your hosting environment isn't configured to meet our minimum requirements. You need curl installed in PHP, and safe_mode needs to be off. See our requirements here:
  • edited February 2013
    ok curl is enabled and safe_mode is off
    but still get the error

    you can check my phpinfo here <Link removed by moderator>
  • try changing the value of open_basedir to none
  • you mean?

    open_basedir = none

    Right now it is commented

    ;open_basedir = off
  • now i changed it to

    open_basedir =

    restarted apache

    and still get the error
  • Ok, so looking at the error message you're receiving the problem is either with safe_mode or open_basedir. Sometimes, curl/php-curl not being setup can also lead to this error.

    Are both curl and php-curl installed? Can you verify? From what I understand, php-curl won't operate fully if curl isn't installed.
  • edited January 2013
    ok i entered

    yum install curl

    and i got this

    Setting up Install Process
    Package curl-7.19.7-26.el6_2.4.x86_64 already installed and latest version
    Nothing to do
  • i am using centos 6.3
    so how do i check or install php-curl?

    because i tried entering

    yum install php-curl
    yum install php5-curl

    and none of those worked it says no package available
  • yum search php curl
  • here is what i have

    [root@web ~]# yum search php curl
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    epel/metalink | 18 kB 00:00
    epel-testing/metalink | 18 kB 00:00
    epel-testing-source/metalink | 18 kB 00:00
    * epel:
    * epel-testing:
    * epel-testing-source:
    * rpmforge:
    base | 3.7 kB 00:00
    centosplus | 3.5 kB 00:00
    contrib | 951 B 00:00
    extras | 3.5 kB 00:00
    rpmforge | 1.9 kB 00:00
    updates | 3.5 kB 00:00
    =============================== N/S Matched: php ===============================
    cups-php.x86_64 : Common Unix Printing System - php module
    eclipse-phpeclipse.noarch : PHP Eclipse plugin
    graphviz-php.x86_64 : PHP extension for graphviz
    nntpgrab-php.x86_64 : PHP module which allows PHP scripts to communicate with
    : NNTPGrab
    perl-PHP-Perlinfo.noarch : Clone of PHP's phpinfo function for Perl
    perl-PHP-Serialization.noarch : Convert PHP's serialize() output into Perl
    : memory structure, and back.
    remctl-php.x86_64 : PHP interface to remctl
    rrdtool-php.x86_64 : PHP RRDtool bindings
    uuid-php.x86_64 : PHP support for Universally Unique Identifier library
    icinga-api.x86_64 : PHP api for icinga
    lighttpd-fastcgi.x86_64 : FastCGI module and spawning helper for lighttpd and
    : PHP configuration
    limph.noarch : A PHP5-compatible network host/service poller with web interface
    squirrelmail.noarch : webmail client written in php
    tiquit.noarch : A PHP5-compatible help desk incident tracking/knowledgebase
    : system
    xhprof.noarch : A Hierarchical Profiler for PHP - Web interface

    ============================== N/S Matched: curl ===============================
    asterisk-curl.x86_64 : Modules for Asterisk that use cURL
    curlpp.i686 : A C++ wrapper for libcURL
    curlpp.x86_64 : A C++ wrapper for libcURL
    curlpp-devel.i686 : Development files for curlpp
    curlpp-devel.x86_64 : Development files for curlpp
    flickcurl-devel.x86_64 : Header files, libraries and development documentation
    : for flickcurl.
    libcurl-devel.i686 : Files needed for building applications with libcurl
    libcurl-devel.x86_64 : Files needed for building applications with libcurl
    perl-WWW-Curl.x86_64 : Perl extension interface for libcurl
    python-pycurl.x86_64 : A Python interface to libcurl
    curl.x86_64 : A utility for getting files from remote servers (FTP, HTTP, and
    : others)
    flickcurl.x86_64 : C library for the Flickr API and utility programs
    libcurl.i686 : A library for getting files from web servers
    libcurl.x86_64 : A library for getting files from web servers

    Name and summary matches mostly, use "search all" for everything.
  • edited January 2013
    so what do i do now?
    safe_mode is off and open_basedir is NOT set to anything
  • Searching around, and it seems that on CentOS/Red Hat should only require:

    sudo yum install php-curl

    I did review again your php info file you posted earlier and I still see a value for open_basedir. Can you please add the following to your vhost/httpd config file:

    php_admin_value open_basedir none

    We need to be 100% this is eliminated as a possible issue.
  • ok when i typed

    sudo yum install php-curl

    i got

    Setting up Install Process
    No package php-curl available.
    Error: Nothing to do

    Ok well i asked what do you want me to put in this line?
    which one?

    open_basedir =


    open_basedir = none


    ;open_basedir =
  • i am checking the vhost/httpd config file and i see this line

    php_admin_value open_basedir /home/wapp/:/tmp:/var/tmp:/usr/local/lib/php/

    What should this line be changed to?
  • Should be changed to:

    php_admin_value open_basedir none
  • ok i did and the error doesn't show anymore!

    but now i still cannot upload a video
    i get this

    Uploads Disabled

    Your server does not meet the minimum requirements for video encoding. As a result video uploads have been disabled. Please check with your web host to ensure they fully support CumulusClips.

    Visit the Admin Panel -> Settings -> Video, to re-check your system and enable uploads. You could also use a plugin to manage video encoding for you.
  • it shows

    Video Uploads: Disabled

    How do i enable video uploads?
  • Ok worked!!!

    I followed this and changed -vb to -b

    Thanks a lot Damian.
    I sent you a personal message, waiting for a reply.
  • Another error again :(

    After video uploading reached 100% then i got error message

    Errors were encountered during the processing of your file, and it cannot be uploaded at this time. We apologize for this inconvenience.
  • ok followed this and was able to change permissions to 777 and video uploaded fine but now i cannot see the video

    Looks like these errors keep what do i do now? I do see under video categories in admin panel is says 1 videos but then no where to find this video
  • I think it took time for the video to show up..i see the video now

    wow...what a roller coaster...happy to be finally done with installation and setup now

    Now heading to customization..hope i find this fun :)
  • Closing as original topic seems to be resolved. Please open a separate thread for other issues.
This discussion has been closed.