Upload Issue

edited April 2013 in Bugs and Errors
N/A

Comments

  • Hmm, the FFMPEG error you're receiving looks like an issue with your path for your apache/php user.

    Can you try this command from the command line and post the results:

    php -r "echo exec('whereis ffmpeg');"
  • Okey cool :)

    when i type php -r "echo exec('whereis ffmpeg');"

    I get: sh: /whereis: No such file or directory

    So i typed "whereis ffmpeg" and got:

    ffmpeg:

    /usr/src/ffmpegscript/ffmpeg
    /usr/src/ffmpeginstaller.7.3/ffmpeg.sh
    /usr/bin/ffmpeg
    /usr/local/bin/ffmpeg

    hope this was the result you needed :)
  • edited April 2012
    from the command-line these work perfect:

    ffmpeg -i sample.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 final_video.flv
    ffmpeg -i sample.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv final_video.flv

    but not this:

    ffmpeg -i sample.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv

    Says: At least one output file must be specified.
  • edited April 2012
    Inside the admin area... when i try and change the FFMPEG Path: to one of the others above. I get a warning message saying "invalid path".., then it automatically reverts back to the auto-detect-original-path. :(
  • edited April 2012
    Create a php file on your site and add this content:

    <?php

    echo exec ('whoami') . '<br /><;br />';
    echo exec ('echo $PATH') . '<br /><br />';
    echo exec ('which ffmpeg') . '<br /><br />';
    exec ('ffmpeg -version 2>&1', $results);
    echo implode ('<br />', $results);

    ?>

    Visit this page on your website and post the output here.
  • edited April 2012
    php output
    -- -- -- -- -- -- -- -- -- --

    apache

    /sbin:/usr/sbin:/bin:/usr/bin

    /usr/bin/ffmpeg

    ffmpeg version N-40079-g068d0b4-syslint

    built on Apr 23 2012 19:47:48 with gcc 4.4.6 20110731 (Red Hat 4.4.6-3)
    configuration: --prefix=/usr/local/cpffmpeg --enable-shared --enable-nonfree --enable-gpl --enable-pthreads --enable-libopencore-amrnb --enable-decoder=liba52 --enable-libopencore-amrwb --enable-libfaac --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --extra-cflags=-I/usr/local/cpffmpeg/include/ --extra-ldflags=-L/usr/local/cpffmpeg/lib --enable-version3 --extra-version=syslint

    libavutil 51. 47.100 / 51. 47.100
    libavcodec 54. 15.100 / 54. 15.100
    libavformat 54. 3.100 / 54. 3.100
    libavdevice 53. 4.100 / 53. 4.100
    libavfilter 2. 72.100 / 2. 72.100
    libswscale 2. 1.100 / 2. 1.100
    libswresample 0. 11.100 / 0. 11.100
    libpostproc 52. 0.100 / 52. 0.100
  • edited April 2012
    Plesk 10.4.4 | CentOs 6 |

    If its easier' I can give you root access to my server and cumulus?
  • edited April 2012
    F***,

    Now i have "HTTP Error" on anything i try to Upload, after doing an Apache restart...
  • Try setting this as the FFMPEG in the Admin Panel:

    /usr/local/bin/ffmpeg
  • edited April 2012
    Rejected with

    The following errors were found. Please correct them and try again.

    - Invalid path to FFMPEG



    p.s. ~~~ I Think if we remove auto-detection from the video setting admin area and manual override through the source it will work! but not sure how...
  • What do you get when running this:

    ls -l /usr/local/bin/ffmpeg
  • lrwxrwxrwx 1 root root 30 Apr 23 19:47 /usr/local/bin/ffmpeg -> /usr/local/cpffmpeg/bin/ffmpeg
  • And without the local "ls -l /usr/bin/ffmpeg" i get:

    lrwxrwxrwx 1 root root 30 Apr 23 19:47 /usr/bin/ffmpeg -> /usr/local/cpffmpeg/bin/ffmpeg
  • edited April 2012
    Ill try changing the permissions to apache 0777 on them, :D
  • nope, no luck yet :(
  • I wasn't aware that this was a symbolic link. Have you tried setting the FFMPEG path to:

    /usr/local/cpffmpeg/bin/ffmpeg
  • edited April 2012
    Fixed, just installed linux again but this time without Plesk, the problem was Plesk dosen't like symbolic links and i don't no how two allow them properly :)
This discussion has been closed.