By passing FTP page on FreeBSD cumulusclips installation

edited April 2012 in Bugs and Errors
Dear Admin,
I already tried to install cumulusclips on my local server with FreeBSD OS , apache2.2 , PHP5.2
After requirements page always directed to FTP pages.
How to solve this problem?

I already tried to chmod and chown but not worked..

my apache user is root if i command ps -aux | grep apache

I uploaded the installation files on folder /usr/local/www/apache22/data/video

and i already make all directory and sub directory of video with mod 777

Help me please....

Comments

  • Please post here the results of both:

    ps -aux | grep apache

    and:

    ps -aux | grep http
  • 10# ps -aux | grep apache
    root 1686 0.0 0.1 1660 1064 p0 D+ 11:40PM 0:00.00 grep apache

    10# ps -aux | grep http
    root 1693 0.0 0.1 1660 1064 p0 D+ 11:41PM 0:00.00 grep http
    10#
  • Ok, not the result I was expecting.

    The request you're making, and correct me if I'm mistaken, is that you're trying to get past the FTP stage in our installer. To do this you will need to make the CumulusClips directory owned by the web server user.

    This user is typically either: 'www-data' or 'apache'.

    We need to first find which user Apache is running as. To find this, search in your Apache config file, usually 'apache.conf' or 'httpd.conf'. Within this file there is a section that should look like this:

    User www-data
    Group www-data

    For me, the config file was located in: /etc/apache2/apache.conf and had 'www-data' listed as the user. This may differ for you.

    Once you find the username Apache is running as simply execute this command:

    sudo chown -R {USERNAME}:{GROUP} /usr/local/www/apache22/data/video

    Then retry your install. That will get you passed the FTP step.
  • Thank you very much Damian..
    It's work..

    configuration of /usr/local/etc/apache22/httpd.conf
    user www
    group www

    and i changed my owner of directory chown -R www:www /usr/local/www/apache22/data/video

    Results... No FTP Page anymore..
    Greats..

    Problem SOLVED..
    Thanks a lots.
This discussion has been closed.