install error Installation error

edited March 2013 in Bugs and Errors
installation error
log is:
[Mon Mar 11 02:23:53 2013] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 36 bytes)
[Mon Mar 11 02:23:53 2013] [notice] mod_bw : Version 0.92 - Initialized [0 Confs]
[Mon Mar 11 02:23:53 2013] [notice] Apache/2.2.21 (Unix) mod_ssl/2.2.21 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 configured -- resuming normal operations
[Mon Mar 11 02:23:55 2013] [error] client denied by server configuration: /home/mahtat/public_html/index.perl
[Mon Mar 11 02:23:55 2013] [error] client denied by server configuration: /home/mahtat/public_html/index.pl
[Mon Mar 11 02:23:55 2013] [error] client denied by server configuration: /home/mahtat/public_html/index.ppl
[Mon Mar 11 02:23:55 2013] [error] client denied by server configuration: /home/mahtat/public_html/index.cgi
[Mon Mar 11 02:23:55 2013] [error] SoftException in Application.cpp:256: File "/home/mahtat/public_html/index.php" is writeable by group
[Mon Mar 11 02:23:55 2013] [error] Premature end of script headers: index.php
[Mon Mar 11 02:23:55 2013] [error] File does not exist: /home/mahtat/public_html/500.shtml

Comments

  • There are absolutely no useable information or useful errors in that log file, this is not your fault though.

    Turn "display_errors" "on" in your PHP settings. Make sure all errors, notices, and warnings will display. Ensure that mod_rewrite is enabled in Apache. And finally, chmod all files to 777, we want to eliminate all possibilities.
  • One more thing I noticed. There an exception being thrown in your log file regarding the permissions of index.php.

    [Mon Mar 11 02:23:55 2013] [error] SoftException in Application.cpp:256: File "/home/mahtat/public_html/index.php" is writeable by group

    Before you anything I mentioned in previous post, fix this error first. Ask your web host for help if you can't figure it out. After you fix that problem try again. If you still get the 500 error, then proceed to what I suggested in my first post.
  • error in step 3 install
    Unable to set permissions (420 on /home/mahtat/public_html/cc-core/config/config.php)
  • It looks like you have a file mask set on your filesystem. Notice the permissions on the error message '420'. If you're using FTP this is very common. Remove or relax the file/directory mask. The permissions for this file should be at least 644.
  • Also please stop creating new threads for the same issue.
  • thanks

    Where can I find file mask or haw i remove it

  • Login to your VPS via the command line. Open the config file for your FTP server. There should be a setting for file create mask. Change this something like '000'. It really depends on what FTP software you're using for your server. Servers like vsftp usually place their config in the /etc directory.

    Please note, the problem you're seeing is not with CumulusClips directly but rather your FTP server isn't able to set permissions on files properly.
This discussion has been closed.