Invalid path to FFMPEG

edited February 2013 in Bugs and Errors
My hosting company said:


Staff 02/16/2013 20:33
Hello

We have checked the issue for the domain http://klip.sinanh79.com. Both the functions are already installed on the server. Please set below path for both the functions
For PHP-CLI :- /usr/bin/php-cli
For FFMPEG :- /usr/local/bin/ffmpeg

Let us know, if you still face the same issue


Please feel free to contact us back in case of any further information.

Thank you,
Technical Support Department
.........................................................................................................................

Client 02/17/2013 04:04
I used PHP-CLI and FFMPEG functions, but getting follow error:

The following errors were found. Please correct them and try again.

- Invalid path to FFMPEG


Staff 02/17/2013 04:21
Hello Sinan Hosukoglu,

We have checked please used the following path where FFMPEG installed on server:
--------------------------------------------------------
/usr/local/bin/ffmpeg
--------------------------------------------------------

Please feel free to contact us back in case of any further information.

Thank you,
Technical Support Department
..............................................................................................................................

What can I do ??????????

Comments

  • Did you set both paths in "Admin -> Settings -> Video" correctly?
  • Yes,
    PHP path is correct but FFMPEG invalid.
  • What I meant was:
    you did set ffmpeg path to "/usr/local/bin/ffmpeg" in the admin panel and it still gives you this error?
  • hi x96

    Yes, I enter ffmpeg path in th admin panel and I getting this error.

    if you want I provide admin panel user and password for you for test.
  • hey,

    I believe you :) this was the only thing I could think of. Be patient and wait for more experienced users or a dev to have a look. I'm not sure what might cause your problem, either ffmpeg permissions or something related to php-ffmpeg?
  • Try this first, completely remove the FFMPEG path from the Admin Panel, leave it blank. Then submit the form. CumulusClips will try and detect the path on it's own if none is provided.

    If the above gives an error, and entering the path provided by your technical support also gives an error, then it seems to be a permissions issue.

    - Verify that there are no "open_basedir" restrictions and it's value is "none".
    - Verify that the "exec" function isn't disabled in PHP
    - Finally, also verify that the executable path that your technical support is providing you is accessible by PHP and it has permissions to it.
  • edited February 2013
    Hi Damian
    My at php.ini open_basedir = none

    I leave blank but I getting:

    The following errors were found. Please correct them and try again.

    - Invalid path to FFMPEG
    - Invalid path to PHP-CLI

    and


    I Gettin this error too in my Dashboard:


    News from the mothership


    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/sinanhos/public_html/klip/cc-admin/index.php on line 32
    CumulusClips version 1.3 is out! Make sure you didn't make any modifications to the default theme or the core application. Any modifications made to these files will be lost during update.
  • Seems to me like safe_mode is on in your php.ini
  • Already safe mode = off in my php.ini
  • edited February 2013
    That error you posted is telling you your problem. You either have safe_mode enabled or there is an open_basedir restriction in place. I think you're checking in the incorrect location for your PHP settings.

    Create a file on your server (at the root of your site) called info.php. Add this content to it: <?php phpinfo(); ?> and post a link to it here.
  • I have the same problem.
    I am on vps.
    Safe mode is already off , open_basedir is set to none.
    I am sure i have ffmpeg in this path /usr/local/bin/ffmpeg .
  • Are you really sure you edited the right php.ini and restarted your httpd after that?
    Did you follow Damians instructions to check which php.ini your HTTPD uses?
  • sinanh79, I am not sure but I think your problem might be the disable_functions in your hosters php.ini. They disable exec, safe_mode and a lot more.
  • @x96 :
    I am sure i have edit the right php.ini file
    /etc/php5/apache2/php.ini
    Also php-cli have it is own php.ini file, and it was effect the main php.ini file. So, i edit php-cli own php.ini file.
  • What part of the php.ini file, replace?
  • x96x96
    edited February 2013
    @sinanh79
    I think you would have to talk to your hoster, as you don't have access to the php core php.ini. But wait for Damian to get up to confirm that ;)

    @Medow
    what is the output of http://pastebin.com/pRk8dvh8 ?
  • @x96 :
    When i browse to this code, the browser give my a white blank page.
  • İ accessing my php.ini file.
  • @x96 :
    Sorry i write a mistake code.

    Here is the output:

    www-data

    /usr/local/bin:/usr/bin:/bin

    /usr/local/bin/ffmpeg

    ffmpeg version git-2013-02-20-8d1dd5b
    built on Feb 20 2013 11:48:01 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
    configuration: --enable-gpl --enable-libass --enable-libfaac --enable-libfdk-aac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libspeex --enable-librtmp --enable-libtheora --enable-libvorbis --enable-libvpx --enable-x11grab --enable-libx264 --enable-nonfree --enable-version3
    libavutil 52. 17.102 / 52. 17.102
    libavcodec 54. 92.100 / 54. 92.100
    libavformat 54. 63.100 / 54. 63.100
    libavdevice 54. 3.103 / 54. 3.103
    libavfilter 3. 38.103 / 3. 38.103
    libswscale 2. 2.100 / 2. 2.100
    libswresample 0. 17.102 / 0. 17.102
    libpostproc 52. 2.100 / 52. 2.100
  • mh ok, so php is able to exec ffmpeg. I have no idea then :)
  • Thank you every one, especially @x96 .
    I figure out the reason of my problem, I use zpanel control panel, and it was add special condition for every host in vhost file.
    And they allow open_basedir on for every site, so i go to site vhost and disable open_basedir.
    Thanks.
  • edited February 2013
    @sinanh79 Wow your web host has disabled alot of functions on your account. I'd bet that one of those disabled functions is causing your problem.

    Create a file on your server named check.php. Paste this into the file when you create it:

    <?php

    exec('whereis ffmpeg 2>&1', $results);
    echo '<pre>',print_r($results,true),'</pre>';

    exec('which ffmpeg 2>&1', $results);
    echo '<pre>',print_r($results,true),'</pre>';

    ?>

    The visit that page in your browser. Please post here the results and output of the page.
  • Hi Damian
    http://klip.sinanh79.com/check.php



    Array
    (
    [0] => ffmpeg: /usr/bin/ffmpeg /usr/local/bin/ffmpeg /usr/share/ffmpeg /usr/share/man/man1/ffmpeg.1.gz
    )
    Array
    (
    [0] => ffmpeg: /usr/bin/ffmpeg /usr/local/bin/ffmpeg /usr/share/ffmpeg /usr/share/man/man1/ffmpeg.1.gz
    [1] => /usr/bin/ffmpeg
    )
  • edited February 2013
    Hi all;
    My hosting company solved.

    Thank you for support.
  • Did they tell you what the problem was?
  • I don' know. My hosting company created php.ini than problem solved.

    Paths: /usr/local/bin/php and /usr/bin/ffmpeg
This discussion has been closed.