error to upload file

edited February 2012 in Bugs and Errors
i've problem again.
when i try to upload a file n when it hit 100% then appear a message "Errors were encountered during the processing of your file, and it cannot be uploaded at this time. We apologize for this inconvenience."

what should i do? Thanks again

Comments

  • That usually means your server doesn't meet the minimum requirements. See this page: Requirements

    Create a file on your server called: info.php and add this to it:

    <?php phpinfo(); ?>

    View that page in your browser and share with us the values for these PHP settings:

    upload_max_filesize
    post_max_size
    max_execution_time
    open_basedir
    safe_mode
    register _globals
  • edited February 2012
    upload_max_filesize 2M
    post_max_size 8M
    max_execution_time 30
    open_basedir no value
    safe_mode Off
    register_globals Off

    hmm strange... coz in /etc/php5/php.ini i'd change to 450M for upload n post maxsize n max execution to 1500 but ini php info different?
    I'd change /etc/php5/cli/php.ini too
  • That is why you are getting upload errors.

    If setting those values didn't work in the php.ini, you can try to change them in your vhost file.

    Look for /etc/apache2/sites-available/

    Replace with your vhost name. In that file add the settings you need like this:

    php_admin_value upload_max_filesize 120M

    Save the file, restart Apache, and you should be ok.
  • oh great... Thanks
    but i'll ready fix it
    for the PHP 5.3

    I Added PHPINIDIR /[location of php.ini]

    Thanks for your support

    Another Question [sorry]
    I've set the upload_max_filesize to 450M but why only 100M max on the site?

    o yeah,
    Damian,, I'll try to translate to Indonesian Language if it's Okay...

    Thanks... :D
  • Glad you got it working. The 100M is just an arbitrary minimum. You can actually set it higher than this, just make sure to update your settings.
This discussion has been closed.