Increase file limit to 1gb help!

edited February 2013 in Customizations
hi i installed cumulusclips script 2 days ago and it is PERFECT i love it but i need help becuase i want it to be able to allow upload upto 1gb
http://cumulusclips.org/forums/discussion/268/how-to-increase-the-maximum-allowed-upload-filesize
i followed this but kinda confused at "max_execution_time" and i think maybe that is causing the problem other info is right here
upload_max_filesize = 1g
post_max_size = 1g

max_execution_time = 64424509440
memory_limit = 550M

1073741824 in video settings

if there is something wrong please tell me i need help
i really need help thanks

Comments

  • max_execution_time is the number seconds a PHP script is allowed to run for before it fails with a timeout message. This setting is measured in seconds. In the case of transcoding video files to different formats this can be time consuming, so this setting needs to accommodate for that.

    The number you listed above for max_execution_time seems way too high and might actually throw errors. I recommend changing you setting to 18000 (which is 5 hours).

    As far as the other settings go, I recommend setting them slightly higher than what you anticipate uploading. For example if you expect to upload 1G files then set the settings to 1536M (1.5G). This applies to upload_max_filesize, post_max_size, and memory_limit.
  • i did exactly what you said but it did not work any help ?? please thanks
  • You haven't really explained what the problem you're having is. Any errors or messages?

    Also, please post the above settings exactly as you have them in your php.ini file.
  • it gives me the error this error when i upload from admin
    Errors were encountered during the processing of your file, and it cannot be uploaded at this time. We apologize for this inconvenience.
    and some other error like it when i upload from public part
    and here are the settings
    memory_limit = 1536M;
    post_max_size = 1536M;
    upload_max_filesize = 1536M;

    max_execution_time = 18000;
    max_input_time = 18000;

    in settings

    Video Site Limit:576716800

    can you pleasee help ? and also i need help with pesedu streaming with jwplayer people cant forward can you tell me step by step guide for it pleasee ? thanks
  • Your 'Video Size Limit' from the Admin Panel is too small. You listed it as 550MB. You need at least 1610612736 (1.5GB).

    1024 * 1024 * 1024 * 1.5 = 1610612736
    (Bytes in 1 KB) * (KB in 1 MB) * (MB in 1 GB) * 1.5 = 1610612736

    Update the above setting in the Admin Panel then try again.
  • Ok thank you damian i will try that tommorw since i shut down my pc now and also i have some modification to talk about can you please email me at
    Shezimalik83@yahoo.com
    For futhur deatails thanks
  • http://prntscr.com/scms8

    i tryed uploading a 500mb file it still didn't uploaded it
  • edited February 2013
    Run this from the command line:

    chmod -R 777 cc-content/uploads

    If you don't have access to a command line you could use an FTP client to changes the permissions of the directory to 777 (rwxrwxrwx). Make sure you do it recursively so that all the child files and directories are affected.

    Also please create a file called info.php with this content: <?php phpinfo(); ?> and post a link to it here.
  • did what you said and heres the link and also can you please email me ?
    bdbangla.tv/cc-content/uploads/info.php
  • Can access that file, please put it at the root of CumulusClips, same level as cc-core, cc-content, cc-admin, etc.
  • can you also please email me ?
  • If there's something you would like to discuss, please post it on the forums so that other members of the community can benefit from any information provided. Also, we do NOT perform any consulting or custom jobs.

    I reviewed your info.php file and your settings are incorrect and not as described above.

    These are your current PHP settings:

    upload_max_filesize = 256M
    post_max_size = 256M
    max_execution_time = 600

    Please change them according to this guide:

    http://cumulusclips.org/forums/discussion/268/how-to-increase-the-maximum-allowed-upload-filesize

    And make sure the values can handle your target upload file size of 500MB.
  • after i tell you then if you want i will post it here too but please email me
  • and oh i think i was making all those settings in clip-bucket php.ini file i installed it before and did not liked it but forgot to remove it sorry but how do i get a php.ini file ?
  • the customization i need is not even rlated to cumulusclips!
  • It depends on your web server. Ask your web host about how you can add custom php.ini settings. They will tell you where to put them.
  • ok i will do that thank you very much for AWESOME support but i need some customization which is not related to cumulusclips and i cant say it here can you email me please ?
  • upload limit can be changed on Apache setings... like here on my server: you need to change this on apache2 setings on virtual server: change this line size:

    FcgidMaxRequestLen "4294967296"

This discussion has been closed.