"HTTP Error" but no description

edited February 2012 in Bugs and Errors
Hello,

I've just installed CumulusClips but I have a problem when I want to upload a video. I write a title, a description, keywords. Then I choose a file to upload and I click on the "Upload Video". We can see the progress bar going from 0 to 100% but a problem appends at the end and the video is not uploaded.

I have a webpage with his message at the top : "Errors were encountered during the processing of your file, and it cannot be uploaded at this time. We apologize for this inconvenience. Our support team has been notified and will investigate into the cause and fix for this issue. If you continue to experience problems using this feature please contact us for further assistance." and at the bottom of the progress bar, there is the following message : "HTTP Error" (here is a picture of the webpage : http://desmond.imageshack.us/Himg88/scaled.php?server=88&filename=cumulus.jpg&res=medium).

I went to the admin panel and check "Log Encoding" but there isn't any log file in the folder cc-core/logs/.

CumulusClips looks perfect for my needs but this problem is awful :(

I hope you will be able to help me !

Comments

  • Hello,

    Sorry for the delay, been really busy with our 1.2 release. The error you're receiving most of the time is a result of configuration on your server either PHP or Apache.

    Did you double check your PHP.ini to make sure your PHP settings are correct and meet the minimums in our Requirements section?

    Also, is this publicly facing? So that I can attempt to debug from my end.

    Let me know
  • Hello,

    Thank you for the answer, you were right, I had a problem with my php.ini file.

    Now, I haven't the HTTP Error anymore. But I have another problem, when I upload a video, I have no error messages but the video is still not visible in my admin panel.

    I looked at the other topic about CGI, etc. but I think the problem is not here : when I look at the log file generated at upload, I can see the following line : "Unsupported codec for output stream #0.1" for the mobile encoding. Then I receive an email who tells me : "The temp Mobile file was not created. The id of the video is: 6".
  • Ok, I have no problem anymore ! I tryed to install phpmotion and to do it, I had to add some extensions and write some updates on my php.ini file. When I try again uploading a video here, it works.
  • I'm happy you got it working. Would you mind sharing what extensions and changes to your php.ini file you made?

    The error you described during the mobile encoding:

    "Unsupported codec for output stream #0.1"

    Indicates that MPEG4 encoding isn't supported by your servers FFMPEG. If you're using a personal or dedicated server I recommend these two guides based on your environment to fix your issue.

    Ubuntu / Debian - http://ubuntuforums.org/showthread.php?t=786095

    CentOS / RHEL - http://cumulusclips.org/docs/install-ffmpeg-x264-on-centos/

    Since you said you got it working, this is almost unnecessary, however these are the instructions I would'ved provided in the event you weren't able to get it working.
  • I use a Debian server. I don't know what is the update I did that repaired uploads but I can list what I did :

    Install the following packages :
    LAME MP3 Encoder
    Libogg + Libvorbis
    Mencoder and also Mplayer
    GD Library

    And in php.ini -> enable_dl = On


  • I see, thanks for sharing.

    I'm pretty sure the php.ini setting of 'enable_dl', and installation of Mencoder/Mplayer wouldn't affect your issue. Those aren't used by CumulusClips.

    What most likely fixed it for you was the LAME MP3 & Theora /Vorbis codecs, since they're codecs used by FFMPEG.

    Either way, again I'm glad it works now and let us know if you need any further assistance by simply opening a new thread here on our forums.
This discussion has been closed.