videos won't upload

edited October 2012 in Bugs and Errors
i tried uploading a video it can only get to about 10% if even that and then it shuts down with an error or just freezes the progress bar I've tried uploading from admin panel and fronted panel it does the same thing. my mac os x server meets the requirments ive changed the php.ini to allow those settings but if youd like to look over it its located at techowl.t27.us/phpinfo.php also everything else seems to work fine still trying to change the logo but it doesnt seem to work at my end and the video site is at video.t27.us is there a solution you seem to allow the videos to upload?

Comments

  • Only Linux is supported. I understand the underlying OS of a Mac is BSD (which is similar to Linux) but at the end of the day it's not supported. It hasn't been tested and isn't guaranteed to work. Try using a supported host instead.
  • can i at least try something like a guide to increase the file upload size limit. everything works and wouldnt it be great to say your software is mac compatible im willing to attempt this.
  • i found out its an http error and iv seen it be solved for other users
  • the isntall passed the checkup and i have everything working except the http error for the uploads its creating a database entry and everything its i think its either the ffmpeg or the file upload limit because i know i have my php written with uploads cabable of 2gb and this seems like its something wrong with the settings of the script if i knew where to change those settings i could at least rule out that. and also it says is unix cabable and from what i understand mac os x is a spiced up unix system.
  • it has an io error when the file size is over 100mb can you please tell me how to increase the upload file size limit for the videos
  • There's a couple of PHP settings, they're listed in the requirements page. Increase those to 150M etc.

    Then increase the size in the admin panel as well.
  • edited October 2012
    Ok so I've increased it to 2 gb and also in the admin panel under video the weird thing I noticed is that it gets a http error is there some sort of configuration I need to fix or ad to get it to work properly. The only issues I'm having are with updating. Also I reconfigured the ffmpeg using your guide the only issue I came across was I couldn't compile libvpx. I was wonder if that is a necessary library for ffmpeg to work. And also I noticed that no logs are being generated when the encoder logs are on. Any suggestions on where Togo from here?
  • Libvpx is only needed for webm videos.

    As far as the logs and uploads go, you're going to continue to get strange behavior because your setup hasn't been tested.

    Please understand, it's not that we don't want to help you. It's that we have limited resources and can't spend them helping users in unsupported setups.
  • alright i fixed the http error for at video under 30mb and it goes to processing and then it creates a converter.log file and in it it states 1.nohup: can't detach from console: Inappropriate ioctl for device. do you have anysuggestions?

    btw anyone following this all i did to fix the http error was chmod to allow for all executbles.
  • it works i just removed the nohup section from /cc-core/system/upload.ajax.php and it works on mac o x. if you'd like i can write a tutorial for mac users and you can edit the grammar if you'd like XD
  • ok so maybe i did a few more extra steps but that for the most part was the trickiest fix
  • well i shouldn't say completely fixed videos over 100mb still produce a io error even after increasing the upload limit under admin panel video settings on the left bottom panel and so far video files under 40 mb work fine video files above 40mb shoot an http error and then files above 100mb ar shooting an io error any idea on a fix i don't think im the only user with this issue it looks like there are others.
  • the php.ini file is maxed out with 9000 second on most time related things and then 4096M for data limits
  • ive traced the issue to the uploadify plugin and i have been working on a fix. ive also noticed people have a lot of problems with the uploadify script and most are unanswered on their own forums. i keep at it. i got small videos to work now its just time for the big videos
  • Which issue did you track down to the Uploadify plugin? Was it the IO Error?
  • yes it is and i know their is a mac targeted fix for the file UploadifyField.php which im unable to find but heres the link to the change maybe you'd be able to make more sense of it then me. meanwhile im attempting several htaccess fixes for the http error but all the big file over 100mb are producing this io error it seems to trace to the folder /myaccount/upload/validate its stopping the uploads mid way and then produces a socket bad pipe error
  • ive also traced it back to a suhosin php setting that ive been trying to change but now my server is unstable and am trying to fix apache from restarting so much
  • edited October 2012
    The IO error is exactly that, an "I/O" error. Usually there's a dropped packet in the HTTP connection between your Flash client/browser and the server.

    From what I understand, there is rarely anything you can do about it except try your upload again. If it's persistent then you may want to verify you're Flash plugin is updated and not throwing any errors.

    Ultimately, this is an issue with Uploadify itself.
  • @damian i think has the same issue that has been resolved in an another topic. its the session timeout that causes it , i think.

    @techyowl try this topic : http://cumulusclips.org/forums/discussion/179/large-upload-never-converts#Item_9
This discussion has been closed.