Embedding 16:9 aspect ratio problem

STCSTC
edited June 14 in General
My 16:9 videos seem to upload and encode correctly and play properly on my CumulusClips site.

However when I embed them, the window gets stretched and misses off the far right side of the video, and also cuts off the volume and fullscreen controls. In order to see the whole video consistently and to get the controls to display I have to force a 4:3 resolution (eg width="480" height="360"); but this results in black bars at the top and bottom.

Is there a way to make the embedding work correcrtly with a 16:9 aspect ratio?

I am currently using:
<iframe src="https://stcvideo.com:443/cclips/embed/31/" width="480" height="360" frameborder="0" allowfullscreen=""></iframe>

And I have tested removing the width and height arguments as well as forcing a 16:9 ratio instead.

I have chatted with the guys in the ffmpeg IRC and they say my encoding options are fine so I believe it is an issue with CumulusClips embed function, or my use of it.

Thank you!

Comments

  • Take a look at the player on the embed view file, embed.phtml. Maybe the format is getting set there.
  • I've gone through embed.phtml and I cannot find anything that would be creating this issue. The file does reference a video-js.css which contains a great many variables some of which reference the player but I'm struggling to find the cause, if it's in here.

    Does anybody have any more ideas or clues? I'm using the default settings with the latest version of cumulus.
Sign In or Register to comment.