Error During Video Encoding

I get this erro, not for all videos but most and they are less than 100mb.
The Temp H.264 file was not created. here is error log, please help

==================================================================
H.264 ENCODING
==================================================================

H.264 Encoding Command: /home/elvisinn/public_html/Elvisinmaine.com/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/temp/05Aee0DqWoNjbIvqCjxd.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -ab 96k -ar 44100 -f mp4 /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/h264/05Aee0DqWoNjbIvqCjxd_temp.mp4 >> /home/elvisinn/public_html/Elvisinmaine.com/cc-core/logs/05Aee0DqWoNjbIvqCjxd.log 2>&1

H.264 Encoding Output:


ffmpeg version 3.3.4-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2017 the FFmpeg developers
built with gcc 6.4.0 (Debian 6.4.0-4) 20170820
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc-6 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gray --enable-libfribidi --enable-libass --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-librtmp --enable-libsoxr --enable-libspeex --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzimg
libavutil 55. 58.100 / 55. 58.100
libavcodec 57. 89.100 / 57. 89.100
libavformat 57. 71.100 / 57. 71.100
libavdevice 57. 6.100 / 57. 6.100
libavfilter 6. 82.100 / 6. 82.100
libswscale 4. 6.100 / 4. 6.100
libswresample 2. 7.100 / 2. 7.100
libpostproc 54. 5.100 / 54. 5.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/temp/05Aee0DqWoNjbIvqCjxd.mp4':
Metadata:
major_brand : mp42
minor_version : 0
compatible_brands: isommp42
creation_time : 2015-10-05T21:21:30.000000Z
Duration: 00:02:42.75, start: 0.000000, bitrate: 355 kb/s
Stream #0:0(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p, 202x360 [SAR 1:1 DAR 101:180], 280 kb/s, 30 fps, 30 tbr, 30 tbn, 60 tbc (default)
Metadata:
handler_name : VideoHandler
Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, mono, fltp, 72 kb/s (default)
Metadata:
creation_time : 2015-10-05T21:21:31.000000Z
handler_name : IsoMedia File Produced by Google, 5-11-2011
Stream mapping:
Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
Stream #0:1 -> #0:1 (aac (native) -> aac (native))
Press [q] to stop, [?] for help
[libx264 @ 0x49692a0] using SAR=1/1
[libx264 @ 0x49692a0] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
[libx264 @ 0x49692a0] profile High, level 2.0
[libx264 @ 0x49692a0] 264 - core 152 r19 ba24899 - H.264/MPEG-4 AVC codec - Copyleft 2003-2017 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=11 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=abr mbtree=1 bitrate=800 ratetol=1.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
[AVFilterGraph @ 0x4fe0c40] Error initializing threading.
[AVFilterGraph @ 0x4fe0c40] Error creating filter 'anull'
Error reinitializing filters!
Failed to inject frame into filter network: Cannot allocate memory
Error while processing the decoded data for stream #0:1
[libx264 @ 0x49692a0] final ratefactor: 21.10
Conversion failed!

Comments

  • here are my video settings in admin panel

    PHP Path:
    /usr/local/bin/php

    FFMPEG Path
    /home/elvisinn/public_html/Elvisinmaine.com/cc-core/system/bin/ffmpeg-64-bit/ffmpeg

    qt-faststart Path:
    /home/elvisinn/public_html/Elvisinmaine.com/cc-core/system/bin/ffmpeg-64-bit/qt-faststart


    H.264 Encoding Options:
    -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -ab 96k -ar 44100 -f mp4
  • here is ss of my admin panel
    admin panel.jpg
    1280 x 1024 - 114K
  • Seems 1-9 mb uploads fine more than that its giving me the error, how can file upload size be adjusted?
  • Looking at the error in your logs it seems to be complaining about memory. Which would make sense given that you're seeing smaller files encode fine. Can you try increasing the memory of your machine.
  • I just tried it again with your new code lines did same thing
    // Converter Called...
    Values passed to encoder:
    Array
    (
    [video] => 94
    )


    Checking FFMPEG permissions...

    Checking qt-faststart permissions...
    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: H.264 Encoding...
    H.264 Encoding Command: /home/elvisinn/public_html/Elvisinmaine.com/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/temp/qAb02cdf3HiPQiCct0LK.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvo-aacenc -ab 96k -ar 44100 -f mp4 /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/h264/qAb02cdf3HiPQiCct0LK_temp.mp4 >> /home/elvisinn/public_html/Elvisinmaine.com/cc-core/logs/qAb02cdf3HiPQiCct0LK.log 2>&1
    sh: line 1: 4174970 Segmentation fault /home/elvisinn/public_html/Elvisinmaine.com/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/temp/qAb02cdf3HiPQiCct0LK.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvo-aacenc -ab 96k -ar 44100 -f mp4 /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/h264/qAb02cdf3HiPQiCct0LK_temp.mp4 >> /home/elvisinn/public_html/Elvisinmaine.com/cc-core/logs/qAb02cdf3HiPQiCct0LK.log 2>&1
    Verifying H.264 video was created...
    The temp H.264 file was not created. The id of the video is: 94
    ---------------------------
    log





    ==================================================================
    H.264 ENCODING
    ==================================================================

    H.264 Encoding Command: /home/elvisinn/public_html/Elvisinmaine.com/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/temp/qAb02cdf3HiPQiCct0LK.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libvo-aacenc -ab 96k -ar 44100 -f mp4 /home/elvisinn/public_html/Elvisinmaine.com/cc-content/uploads/h264/qAb02cdf3HiPQiCct0LK_temp.mp4 >> /home/elvisinn/public_html/Elvisinmaine.com/cc-core/logs/qAb02cdf3HiPQiCct0LK.log 2>&1

    H.264 Encoding Output:

    ,

    I ask hosting to up memory more, I had 512, the upgraded to 768 still not enough
    thank you for replying
  • Hi Damian, waiting on them to add more memory.
    can you tell me where to find the google analytics plugin? or any more plugins? I like plugins lol, thank you
  • The current google analytics plugin is only for the old version 1. It doesn’t work on the current version. You can easily just add the google code to the header view file of your theme.
  • Also, 768MB of Ram is not enough. You meed at least 1GB and even that is low.
  • I'll put ga code in there thanks. My host hostupon wants to charge me 50 a month for 1 gig vps. I unistalled it and reinstalled it now most under 10mb videos upload and working now. But still getting the error over 9mb. Can you recommend a host for this script? I clicked the link and its ng. ty
  • correction they said 70.00 a month yeh ok. I'll just import the videos
  • Thats absurd. For that price you can get a private cloud server on Amazon AWS or Digital Ocean with 2GB of memory. I recommend those two as they'll give you the best performance. The only downside is that you're responsible for setting up the server.
  • I'll just have to deal with it. Stick with 512. Hey Can you make me the logo for home page in same font as clips mobile? Just the word ( Relvis ) its 264x102. Or if you can tell what font it is or attach fonts. thanks man.
  • does mine look good on your end? http://elvisinmaine.com
Sign In or Register to comment.