The temp H.264 file was not created.

Guys, started getting these almost every time i uploaded some WMV files and even some AVI files. i found the following infomration out and was looknig for thoughts on it.

The temp H.264 file was not created. The id of the video is: 10

http://cumulusclips.org/forums/discussion/1397/videos-not-showing-after-upload


I found after digging a little i found the following.

https://trac.ffmpeg.org/ticket/6375

can you comment on this command line?

-vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -max_muxing_queue_size 4000 -acodec aac -ab 96k -ar 44100 -f mp4
-vcodec libx264 -vf "scale=min(480\,iw):trunc(ow/a/2)*2" -vb 600k -max_muxing_queue_size 4000 -ac 2 -ab 96k -ar 44100 -f mp4

Comments

  • What is the error you are seeing?
  • Via Email - The temp H.264 file was not created. The id of the video is:
    In the logs - Too many packets buffered for output stream 0:1.
  • Damian one other note. i keep getting these after i made the change. so i have a feeling it involved the virtual memory when trying to encode.

    Time: Wed Oct 25 10:49:22 2017 -0400
    Account: USERNAME
    Resource: Virtual Memory Size
    Exceeded: 580 > 512 (MB)
    Executable: /home/USERNAME/public_html/cc-core/system/bin/ffmpeg-64-bit/ffmpeg
    Command Line: /home/USERNAME/public_html/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/USERNAME/public_html/cc-content/uploads/temp/mYKjk9iOMFdRPUYEhthb.wmv -vcodec libx264 -vf scale=min(640\\,iw):trunc(ow/a/2)*2 -vb 800k -max_muxing_queue_size 4000 -acodec aac -ab 96k -ar 44100 -f mp4 /home/USERNAME/public_html/cc-content/uploads/h264/mYKjk9iOMFdRPUYEhthb_temp.mp4
    PID: 6005 (Parent PID:6004)
    Killed: No
  • I'm not sure what would cause the original "too many packets" error. However 512MB of is way too little for video transcoding. I would recommend at least 2GB of RAM and even that is a bit low.
  • yea i think that is just a setting in my system that i am using that is notifying on that. but keep in mind before that muxing queue size i wasn't getting these. i mean im running the software on an enterprise server 16 gb ram with 16 cores ($109 on ebay!)
Sign In or Register to comment.