Try CumulusClips Cloud Hosting

[Fixed] "A valid base URL is needed" when using localhost

edited September 27 in General
I'm trying to install locally but I'm getting this error. I came across this other post: http://cumulusclips.org/forums/index.php?p=/discussion/45/a-valid-base-url-is-needed-installation-problem but I can't find the file .htaccess the solution proposes. Can anyone help?

Comments

  • The .htacess file is hidden. You need to use ls -a to see it. It is located in the root of the script.
  • Okay, there it is. But where do I have to put it? It is already located in the root.
  • edited June 18
    Let's forget about the .htaccess for a second. Looking at the discussion you referenced, I'm not entirely sure the member knew what he was talking about.

    What are you entering in the "Base URL" field? It has to be a complete URL. So if you're using "localhost", it should be in the form of "http://localhost".
  • edited June 19
    I'm literally using this: http://localhost:8888/platea which is the default value it had.
  • edited June 21
    The REGEX validation in the installer is too strict. I have reported this to our engineering team. In the mean time, here is a work around so that you can install the script.

    Open and find: /cc-install/site-details.php line 26

    And replace it with:

    $pattern = '/^https?:\/\/[a-z0-9][a-z0-9\.\-]+.*$/i';
    It should allow you to use your URL listed above.
  • This has been fixed in version 2.5.3.
This discussion has been closed.