[Fixed] Unable to connect to FTP host () - Version: 2.5.1

edited September 27 in Bugs and Errors
Files uploaded, permissions and other requirements OK.
The database was created, tables installed, but i can't move on. Same error over and over. What is wrong?

picture below:
http://prnt.sc/eqccss

Thx

Comments

  • What values are you providing in the previous step?
  • Only php tags was changed at requirements, than went to database, the installation skipped ftp settings
  • edited March 30
    I'm not sure where the issue is originating from. Let's make two quick changes to see if they point us in the right direction.

    1) Open the file /cc-install/database.php, and change line 158 to this:

    . $e->getMessage() . '<br>'
    . 'In: ' . $e->getFile() . ', on line: ' . $e->getLine()

    2) Open the file /cc-core/lib/Filesystem.php, and change line 103 to this:

    if (static::_canUseNative($filename, false)) {
    Then try again.
  • http://prnt.sc/eqm189

    Welcome->Requirements->Database. It didn't went through FTP connection

    Thx
  • i re-installed the script in a different folder.
    steps:
    upload the script;

    # chmod -R 777 cc-core/logs
    # chmod -R 777 cc-content/uploads/flv
    # chmod -R 777 cc-content/uploads/mobile
    # chmod -R 777 cc-content/uploads/temp
    # chmod -R 777 cc-content/uploads/thumbs
    # chmod -R 777 cc-content/uploads/avatars

    chown -R www-data:www-data /var/www/.../cc

    Database created;
    FTP user created;

    results
    http://prnt.sc/eqr3cl
    http://prnt.sc/eqr3wl

    tryed to change localhost to 127.0.0.1
    change the path to: /cc or /httpdocs/cc
  • Those folders you listed in the chmod commands are old, from version 1.x.

    So you re-installed the latest version of the script in a new location, and you managed to get to the FTP screen. What is the issue you are having now?
  • error message: We were unable to navigate to the CumulusClips directory. Please verify your ftp path is correct and your account has access.

    Ftp connection working fine:

    Warning: Plaintext FTP is insecure. You should use explicit FTP over TLS.
    Status: Resolving address of Adrianapaivamakeup.com
    Status: Connecting to 5.77.61.89
    Warning: The entered address does not resolve to an IPv6 address.
    Status: Connected, waiting for welcome message...
    Reply: 220 ProFTPD 1.3.5b Server (ProFTPD) [5.77.61.89]
    Command: CLNT https://ftptest.net on behalf of 2600:1:f50b:6529:c0a5:2c4:e425:f915
    Reply: 500 CLNT not understood
    Command: USER clip2
    Reply: 331 Password required for clip2
    Command: PASS ********
    Reply: 230 User clip2 logged in

    Performed at ftptest.net
  • Ah, ok. I understand now. It's complaining because the FTP path is not accessible. Let's do this:

    1) Log into your site via FTP
    2) Once logged in, navigate to the CumulusClips directory
    3) Perform a "pwd" command while logged in to FTP and inside the CumulusClips directory
    4) Whatever value you get after doing the "pwd" command, that is the value you should use in the FTP Path field.
  • Path:/var/www/vhosts/adrianapaivamakeup.com/httpdocs/cc

    Error:
    We were unable to navigate to the CumulusClips directory. Please verify your ftp path is correct and your account has access.

    Tried localhost and 127.0.0.1 same credentials to ftp user

    I downloaded the latest version on the website

    Thx
  • Is that what you got back when you ran the "pwd" command via FTP, not directly in the command line? Please be aware that they can and often ARE different.

    When logging in via FTP sometimes your server creates virtual paths, so if your directory is normally i.e. /var/www/vhosts/sample.com, when using FTP it may be i.e. /sample.com or even just "/". That is why I asked you to log in via FTP and actually navigate to the CumulusClips directory using FTP, not just plain command line.

    That error is given when the given FTP user cannot navigate to the directory. If you provided:

    /var/www/vhosts/adrianapaivamakeup.com/httpdocs/cc

    to the installer and it failed then something must be wrong. Maybe a typo or improper FTP configuration.
  • This is the pwd output :
    /var/www/vhosts/adrianapaivamakeup.com/httpdocs/cc
  • At this point I don't know.

    We can have one our engineers take a look at this and fix it for you. If you accept, please send your SSH login, FTP login (if different from SSH), database login, and CumulusClips admin login to: support at cumulusclips dot org. I will forward this information to our engineers who will login into your server and attempt to fix the issue for you.

    Let me know.
  • Got your information. I will pass along to our engineers. Please allow 4-6 hours for them to complete their work. I will keep you posted with their findings.
  • OK. Thx
  • I received an update from our engineering team. Below is what they said:

    ==========================

    We were able to login via FTP to the client's server and confirm that the FTP path they were using was incorrect. It was not "/var/www/vhosts/adrianapaivamakeup.com/httpdocs/cc" but rather just "/". This is most likely because the FTP user in a chroot jail.

    We also discovered a bug in the installer that prevents users from entering "/" as the FTP path. However we were unable to fix it on the clients server because the files appear to be owned by "root" thus producing permission denied errors.

    Once the updated code is pushed and the user uses the correct path "/", they should be able to continue in the installer wizard. We could not confirm this because we did not have permissions to make the fix.

    As far as the original error the user complained about, "Unable to connect to FTP host ()..." we could not reproduce it because the user switched to a different directory and we are getting the permission denied error.

    The client has two options:

    1) Grant the FTP user owner ship of the "cc" directory recursively, then upload the updated files with the bug fix

    2) Switch back to the original directory and have us take another look to see what was causing the original problem

    ==========================
  • Still not working
    Uploaded to root at adrianapaivamakeup.com, same credentials to ftp and db.

    thx
  • Our engineer tried to access the FTP site after you moved it to the root and the logins no longer work.
  • I just changed it back. Try again please.

    Warning: Plaintext FTP is insecure. You should use explicit FTP over TLS.
    Status: Resolving address of adrianapaivamakeup.com
    Status: Connecting to 5.77.61.89
    Warning: The entered address does not resolve to an IPv6 address.
    Status: Connected, waiting for welcome message...
    Reply: 220 ProFTPD 1.3.5b Server (ProFTPD) [5.77.61.89]
    Command: CLNT https://ftptest.net on behalf of 2600:6c64:647f:fcc3:2173:4a8c:27d9:9d3e
    Reply: 500 CLNT not understood
    Command: USER ###
    Reply: 331 Password required for ####
    Command: PASS ********
    Reply: 230 User #### logged in
    Command: SYST
    Reply: 215 UNIX Type: L8
    Command: FEAT
    Reply: 211-Features:
    Reply: CCC
    Reply: PBSZ
    Reply: AUTH TLS
    Reply: MFF modify;UNIX.group;UNIX.mode;
    Reply: REST STREAM
    Reply: MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
    Reply: UTF8
    Reply: LANG en-US*
    Reply: EPRT
    Reply: EPSV
    Reply: MDTM
    Reply: SSCN
    Reply: TVFS
    Reply: MFMT
    Reply: SIZE
    Reply: PROT
    Reply: 211 End
    Command: PWD
    Reply: 257 "/" is the current directory
    Status: Current path is /
    Command: TYPE I
    Reply: 200 Type set to I
    Command: PASV
    Reply: 227 Entering Passive Mode (5,77,61,89,176,222).
    Command: MLSD
    Status: Data connection established.
    Reply: 150 Opening BINARY mode data connection for MLSD

    Status: Skipped display of 1 listing lines
    Status: Success
  • Hello,

    Our techs our still getting Permission denied errors. As we stated previously, your files are owned by root so the user you provided doesn't have permissions. Please either move the files to a new location and provide FTP/SSH access to the new location, or update the permissions on the current location so that we can fix your original issue.

    ftp> put ftp.php
    local: ftp.php remote: ftp.php
    227 Entering Passive Mode (5,77,61,89,211,162)
    550 ftp.php: Permission denied
  • I had a chat with my host technician, he asked for his senior admin help. Something was wrong there. They fixed the issue. Thank you guys from cumulusclip! You are the best.
  • This has been fixed in version 2.5.3.
This discussion has been closed.