FTP Error on installing

Hi,
i am trying to install CumulusClips on my VPS.
My FTP server accepts connections only over TLS.
The user can write on all directories and the wizard can create ftp-test file, but always show this message:

We were unable create a test file. Please verify your account has write access.

Another question is:
It is necessary maintain the cumulusclips directory or I can copy all included files in the root directory?

Comments

  • I also tried on another direcotry with another user and I obtain the same error...
  • Who owns the directory where you are trying to install the script to? Does the FTP user you're using have write access to that directory?
  • Yes, sure!
  • Can you post here the result of "ls -la" of the directory you are trying to install to.

    Also keep in mind that the FTP path that you provide in the wizard needs to be the to the same directory where you have the script installed. However the actual path maybe slightly different than the FTP path due to FTP chroot, etc.
  • I wrote the full path /var/www/streaming in FTP Path field, in fact the wizard creates ftp-test file in the root directory.
    /var/www/streaming is also the root directory for ftp user
    The screenshot is on http://151.236.56.51/screenshot.jpg
    Attachment in this form don't works
    Screenshot 2017-03-14 19.08.24.png
    1165 x 693 - 45K
    Screenshot 2017-03-14 19.08.24.png
    1165 x 693 - 45K
    screenshot.png
    1165 x 693 - 45K
    screenshot.jpg
    1165 x 693 - 197K
    screenshot.jpg
    1165 x 693 - 69K
    screenshot.jpg
    1165 x 693 - 69K
  • can't you help me?
  • That error you're getting means that PHP cannot create a file via FTP using the credentials you provided. The test file was never created.

    Based on your screenshots, it looks like the directory is owned by "admin" who is the only user with write access there. You should be using "admin" as the FTP username, and his password.

    Can you try to upload a file to your server with FTP using the same information you are providing to the installer? Make sure once you are logged in to FTP that you "cd" to the path you are providing in the installer. See if you can do that and upload a file.
  • I have tried to chown the entire directory to user "cumulus" and I have also tried to login in the wizard with the user "admin" and his password, obtaining always same error.
    The ftp-test file was created many times, then I think that PHP can write.
    Chmod 777 presents same problem..... :( I' m hopeless
    Screenshot 2017-03-15 20.45.06.png
    712 x 455 - 51K
  • On another server has been installed correctly. I can't understand...
  • I have an idea. Open the file: /cc-install/ftp.php and on line 2 add:

    ini_set('display_errors', 1);
    ini_set('display_startup_errors', 1);
    error_reporting(E_ALL);

    and on line 101, remove the "@" symbol. Then try again. Not promising anything, but maybe it will give us a clue.
  • Sorry, it don't show anything.
  • There is something strange on your environment because if you notice the test files all have 0 bytes file size. They should have 8 bytes of filesize. This is why it's failing. Do you have safe mode turned on in PHP?

    Can you create a file named info.php with this content at the root of the script:

    <?php phpinfo();
    Then post a link to it.
  • Also, if you have SELinux installed, can you temporarily turn it off.
  • edited March 16
    Can you try and upload a file, to the root of the script manually via FTP, using the same user you are providing to the installer. Try to create/upload a file via FTP. Let me know how that works out.
  • Sure! I can read write and delete on the root directory.
  • At this point I can only suggest you allow one of out engineers to take a look on your server. He would investigate the cause of the issue and recommend a solution. If you agree, please provide root SSH username and password to your server via an email to support at cumulusclips dot org.
Sign In or Register to comment.