short_open_tags showstopper

Any workaround for the short_open_tags needing to be enabled? I am using php7 on centos7. I saw that there was a post about it but was wondering if you could give any more specific help in getting cc installed.

Comments

  • PHP7 isn't supported yet anyways. Version 2.6 will be PHP7 compatible and not include short tags in the theme. Version 2.5 will be out in a few days but it still makes use of the tags. Your best bet is to use a PHP 5.x.
  • I actually built a new server and I did a php -v and I see PHP 5.4.16 installed but I am still having the same problem with that error. Any other thoughts?
  • edited February 13
    If you're running 5.4 then short_open_tags should not throw errors. They were removed in 7. Verify your php.ini that it is enabled.
  • edited February 13
    in /etc/php.ini I have "short_open_tag = On

    I have restarted apache many times as well
  • What is the error you're seeing?
  • in the requirements page under php settings. short_open_tags - this needs to be enabled
  • Create a file in the root of your site called "info.php" with the following content:

    <?php phpinfo();

    Then post the url to that file here.
  • edited February 14
    The PHP Info file that you linked above indicates that short_open_tag is off.

    If you indeed verified that /etc/php.ini has short_open_tag set to On. Then that value is being overridden somewhere.
  • I just tried it on a centos 6.x brand new build with the same results. Do you have a suggested OS that should work? Im not sure what else to try at this point.
  • The OS should not have anything to do with it.

    Where is your Apache vhost config file for this particular site. Sometimes there are PHP setting override there. Sometimes it's in /etc/httpd/conf/httpd.conf or /etc/httpd/vhosts/...

    Check those files and see if any of them are overriding your short_open_tag setting. Another option is to override it yourself. Open the vhost file for your site and add this:

    php_admin_flag short_open_tag on

    Then check your info.php file and see if was updated. Be sure to reload Apache after saving your changes.
  • excuse my ignorance on al of this. All my cc files are in the /var/www/html Im not seeing any reference to vhost anywhere. I looked in httpd.conf and didn't see anything about short_open_tag
Sign In or Register to comment.