Video upload not working (MAMP, Mac OS X Lion)

edited December 2011 in General
Hope you can help. Been doing a lot of googling and reading in your forums but can't seem to find an answer to my latest issue.

I've installed cumulusclips for testing purposes on my mac (OSX Lion, 10.7.2) within a "cumulusclips" sub-folder under "Sites" managed by MAMP at localhost:8888 (i.e. http://localhost:8888/cumulusclips). Cumulus seems to load fine and I am able to upload a video using the GUI but the video doesn't appear to get processed (it only appears in the temp folder and never appears in flv or mobile - nor on the list of pending videos in the cumulus GUI). The converter log only contains the message, "Unable to connect to database" but when I check the db (cumulus inside a MySQL instance managed by MAMP at port 8889) , I do see the newly added video with a status of "pending conversion". No other errors as far as I can see.

Any ideas?

Thanks in advance!

Comments

  • I understand OS X is based on a BSD variant which is very similar to Unix/ Linux, however I must let you know up front that CumulusClips is only tested and supported on Linux.

    Now to answer your question, does the version of PHP have PHP CLI installed?

    Also, just for giggles, bring up your CumulusClips database, and open the settings table. There should be an entry that reads PHP or PHP path. Change the value of that record to just "php". No path or anything, just simply php. Then erase all logs in your cc-core/logs directory, turn log encoding "On" in the admin panel and try your upload again.
  • Thanks for the quick reply Damian.

    I tried what you suggested but still got the same result ("Unable to connect to database"). Then I tried changing the path to "/Applications/MAMP/bin/php/php5.3.6/bin/php" (MAMP installs it's own copy of PHP 5.3.6) and got a little closer - i think :-)

    I now have a different converter.log showing the following:


    ### Converter Called...
    Values passed to encoder:
    Array
    (
    [0] => /Users/jonathan/Sites/cumulusclips/cc-core/system/encode.php
    [1] => --video=19
    )

    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: FLV Encoding...
    FLV Encoding Command: /usr/bin/ffmpeg -i /Users/jonathan/Sites/cumulusclips/cc-content/uploads/temp/U2K727Ws4YIaJ1Js4ilG.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv /Users/jonathan/Sites/cumulusclips/cc-content/uploads/flv/U2K727Ws4YIaJ1Js4ilG.flv >> /Users/jonathan/Sites/cumulusclips/cc-core/logs/U2K727Ws4YIaJ1Js4ilG.log 2>&1
    Verifying FLV video was created...
    The FLV file was not created. The id of the video is: 19

    And in the U2K727Ws4YIaJ1Js4ilG.log:

    ==================================================================
    FLV ENCODING
    ==================================================================

    FLV Encoding Command: /usr/bin/ffmpeg -i /Users/jonathan/Sites/cumulusclips/cc-content/uploads/temp/U2K727Ws4YIaJ1Js4ilG.mp4 -s 640x480 -vb 800k -ac 2 -ab 96k -ar 44100 -f flv /Users/jonathan/Sites/cumulusclips/cc-content/uploads/flv/U2K727Ws4YIaJ1Js4ilG.flv >> /Users/jonathan/Sites/cumulusclips/cc-core/logs/U2K727Ws4YIaJ1Js4ilG.log 2>&1FLV Encoding Output:


    FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
    Mac OSX universal build for ffmpegX
    configuration: --enable-memalign-hack --enable-mp3lame --enable-gpl --disable-vhook --disable-ffplay --disable-ffserver --enable-a52 --enable-xvid --enable-faac --enable-faad --enable-amr_nb --enable-amr_wb --enable-pthreads --enable-x264
    libavutil version: 49.0.0
    libavcodec version: 51.9.0
    libavformat version: 50.4.0
    built on Apr 15 2006 04:58:19, gcc: 4.0.1 (Apple Computer, Inc. build 5250)

    Seems that stream 0 comes from film source: 1000.00 (1000/1) -> 15.00 (15/1)
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Users/jonathan/Sites/cumulusclips/cc-content/uploads/temp/U2K727Ws4YIaJ1Js4ilG.mp4':
    Duration: 00:00:05.0, start: 0.000000, bitrate: 203 kb/s
    Stream #0.0(eng), 15.00 fps(r): Video: mpeg4, yuv420p, 352x288
    /usr/bin/ffmpeg: unrecognized option '-vb'

    Am I closer to a solution...?
  • Yes you are closer! Apparently the path you provided to MAMPP's PHP has CLI, which got you passed your first issue.

    If you don't mind me asking, what was it before?

    Anyways, the encoding failed because your install of FFMPEG doesn't supprt the "vb" option. Change the "-vb" to just "-b" in Admin Panel -> Settings -> Video -> Flv Options. That should do it.
  • The path for php before I changed it was "/usr/bin/php".

    I went ahead and changed "-vb" to "-b" and...IT WORKED!!

    Thanks so much for your help. Looking forward to further exploration.

    Awesome stuff... :-)
This discussion has been closed.