i uploaded video, it got uploaded but doesn't show up on the website

so i just migrated my cumulus clips website to another server
everything works, playing video and everything got migrated over, can play videos and all that.

Now when i tried to upload new video(11MB in size), i noticed ffmpeg got to work and video got uploaded without any errors BUT it doesn't show up on my website

I looked inside the ../cc-content/uploads/flv directory and i was able to see the new video i just tried to upload there..tracked it by date added BUT again nothing shows up on the website

I looked at apache error logs NO errors

SO what do i do to fix this and what could be the issue?

I am running a newer ffmpeg by the way new one is ffmpeg version 2.6.8 (old one was ffmpeg version N-49406-g8c4aebb Copyright (c) 2000-2013 the FFmpeg developers)

So is the FLV settings on my admin panel that is the issue?
Right now it is

FLV Options: -vf 'scale=1280:trunc(ow/a/2)*2' -ac 2 -ab 128k -ar 44100 -f flv -vcodec libx264 -crf 26

Mobile Options: -s 480x360 -b 600k -ac 2 -ab 96k -ar 44100 -f mp4

Thumbnail Options: -s 640x480 -t 1 -r 1 -f mjpeg

So please help. Not sure where to look for errors on why the video is not showing up

CURRENT cumulus clips version: v1.3.1

NEW server: CentOS 7,3 php 7.0, mysql 5.7, apache 2.4.6

OLD server: CentOS 6.3, php 5.2, mysql 5.5, apache 2.2.22

531 x 501 - 27K


  • What do your encoding logs say? There was most likely an error during encoding.

    By the way two things I noticed. You're running PHP7 which is not supported yet. You should downgrade PHP to the latest PHP 5.x.x. Also, you're running CumulusClips v1.3.1, the current version is 2.4.1.
  • here is the log output from the file cc-core/logs/xxxx.log
  • That log seems like the transcoding completed successfully. What does the other log say?
  • which other log?
  • converter.log, it should be in the same directory.
  • oh you meant this one?

    right here

  • edited December 2016
    i think i see what was missing
    the converter.log part is missing the thumbnail section

    after the last part of the converter.log file i uploaded above, there is supposed to be the thumbnail part but it didn't get to the thumbnail part.

    Is that the problem? and what causes that?

    I checked all the other directories and found the video but under the cc-content/uploads/thumbs the file is not there. So the thumbnail is what i nailed it to.

    What do you think?
  • It looks like it failed right after obtaining the video duration. Probably in the code where it formats the duration into seconds, because I don't see where it output that to the log.

    I suspect it's a PHP error related to your PHP version 7, like a deprecated/removed feature. I would also give a check to your PHP error log.
  • i just enabled php error logging and can't see anything

    tried uploading videos like 3 times for test and also enabled displaying php errors and nothing is showing errors
  • After displaying turning on display errors in PHP and setting error_reporting to "E_ALL" do you see anything different in the converter.log file?
  • edited December 2016
    Actually yes! (thanks a lot for having me take a look at the converter logs again, almost gave up already)

    so here is what the converter logs show after enabling display errors

    and inside the cc-core/lib/Functions.php file referring to line 92..i am showing the line numbers number

    85 /**
    86 * Format video duration into seconds
    87 * @param string $duration in hh:mm:ss or mm:ss format
    88 * @return integer Total seconds
    89 */
    90 static function DurationInSeconds ($duration) {
    92 if (eregi ('^[0-9]{2}:[0-9]{2}:[0-9]{2}$', $duration)) {
    94 $total = 0;
    95 $hours = (int) substr ($duration, 0, 2);
    96 $minutes = (int) substr ($duration, 3, 2);
    97 $seconds = (int) substr ($duration, -2);
    98 $total += $hours*3600;
    99 $total += $minutes*60;
    100 $total += $seconds;
    101 return $total;
    103 } elseif (eregi ('^[0-9]{2}:[0-9]{2}$', $duration)) {
    105 $total = 0;
    106 $minutes = (int) substr ($duration, 0, 2);
    107 $seconds = (int) substr ($duration, -2);
    108 $total += $minutes*60;
    109 $total += $seconds;
    110 return $total;
    112 } else {
    113 return FALSE;
    114 }
    116 }

    So am thinking

    for php7 i think i need to change eregi to preg_match?

  • @Damian

    Finally worked!!!

    after changing eregi to preg_match

    You are the best man.
    You always like to help. Thanks a trillion times!
This discussion has been closed.