Videos are not converting


// Converter Called...
Values passed to encoder:
Array
(
[0] => /home/alteryou/public_html/cc-core/system/encode.php
[1] => --video=110
)


Checking FFMPEG permissions...

Checking qt-faststart permissions...
Validating requested video...
Establishing variables...
Verifying raw video exists...
Verifying raw video was valid size...

Preparing for: H.264 Encoding...
H.264 Encoding Command: /home/alteryou/public_html/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/alteryou/public_html/cc-content/uploads/temp/i0ktGAGd6O0V1KIdcjuh.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -ab 96k -ar 44100 -f mp4-strict-2 /home/alteryou/public_html/cc-content/uploads/h264/i0ktGAGd6O0V1KIdcjuh_temp.mp4 >> /home/alteryou/public_html/cc-core/logs/i0ktGAGd6O0V1KIdcjuh.log 2>&1
Verifying H.264 video was created...
The temp H.264 file was not created. The id of the video is: 110



==================================================================
H.264 ENCODING
==================================================================

H.264 Encoding Command: /home/alteryou/public_html/cc-core/system/bin/ffmpeg-64-bit/ffmpeg -i /home/alteryou/public_html/cc-content/uploads/temp/i0ktGAGd6O0V1KIdcjuh.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec aac -ab 96k -ar 44100 -f mp4-strict-2 /home/alteryou/public_html/cc-content/uploads/h264/i0ktGAGd6O0V1KIdcjuh_temp.mp4 >> /home/alteryou/public_html/cc-core/logs/i0ktGAGd6O0V1KIdcjuh.log 2>&1

H.264 Encoding Output:


ffmpeg version 2.8.5-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2016 the FFmpeg developers
built with gcc 4.9.3 (Debian 4.9.3-10)
configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --cc=gcc-4.9
libavutil 54. 31.100 / 54. 31.100
libavcodec 56. 60.100 / 56. 60.100
libavformat 56. 40.101 / 56. 40.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 40.101 / 5. 40.101
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.101 / 1. 2.101
libpostproc 53. 3.100 / 53. 3.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/alteryou/public_html/cc-content/uploads/temp/i0ktGAGd6O0V1KIdcjuh.mp4':
Metadata:
major_brand : isom
minor_version : 512
compatible_brands: isomiso2mp41
creation_time : 2012-04-07 20:41:19
encoder : Lavf52.54.0
Duration: 00:04:08.33, start: 0.000000, bitrate: 530 kb/s
Stream #0:0(und): Video: mpeg4 (Simple Profile) (mp4v / 0x7634706D), yuv420p, 320x240 [SAR 4:3 DAR 16:9], 386 kb/s, SAR 213:160 DAR 71:40, 15 fps, 15 tbr, 15 tbn, 15 tbc (default)
Metadata:
creation_time : 2012-04-07 20:41:19
handler_name : VideoHandler
Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 140 kb/s (default)
Metadata:
creation_time : 2012-04-07 20:41:19
handler_name : SoundHandler
[NULL @ 0x39b26a0] Requested output format 'mp4-strict-2' is not a suitable output format
/home/alteryou/public_html/cc-content/uploads/h264/i0ktGAGd6O0V1KIdcjuh_temp.mp4: Invalid argument

Comments

  • You have an error in your encoding options.

    In your encoding options, you have:

    -f mp4-strict-2

    this should be

    -f mp4 -strict -2

    i.e. there needs to be a space between "mp4" and "-strict" and "-2"
Sign In or Register to comment.