[Solved] Video upload error: last atom in file was not a moov atom

edited June 2016 in General
Hello. I successfully uploaded a video but after changing some settings, then changing them back (to what i am 99% sure are the same settings) I am getting this error in the log output:

ftyp 0 32
free 32 8
mdat 40 0
last atom in file was not a moov atom

How can i fix this?


  • reinstalled the site from scratch and am getting the same errors
  • This seems like a problem with the videos original encoding. Do tyou get this issue with all videos?
  • Yes. I actually reinstalled the site from scratch again, the first two uploaded videos worked, any video after is not working, same error.

    I'm guessing something is changing by itself?
  • Are you running out of diskspace perhaps?
  • No the file's are successfully uploaded to the /uploads directory and play fine, but on the website, they upload and get stuck as processing, the log file shows it failed with the atom error
  • Can you provide a link to download 3 separate videos that fail with this error.

    You can find those videos in:


    Please also provide the raw original videos located in:

  • ended up fixing this by setting the temp video file's permissions to 0777 in encode.php. New files in the upload directory were not writable.
This discussion has been closed.