CumulusClips on different partition

edited April 2016 in General
Hello, I'm completely new to working with Linux and I currently am using Ubuntu Server 14.04 LTS. I was following steps listed on a website which required me to:
# cd /var/www/
# wget http://cumulusclips.org/cumulusclips.tar.gz
# tar -xvf cumulusclips.tar.gz
# cd cumulusclips
# chmod -R 777 cc-core/logs
# chmod -R 777 cc-content/uploads/flv
# chmod -R 777 cc-content/uploads/mobile
# chmod -R 777 cc-content/uploads/temp
# chmod -R 777 cc-content/uploads/thumbs
# chmod -R 777 cc-content/uploads/avatars
# chown -R apache:apache /var/www/html/cumulusclips
# chown -R www-data:www-data /var/www/cumulusclips

But instead I:
# cd /opt/
# wget http://cumulusclips.org/cumulusclips.tar.gz
# tar -xvf cumulusclips.tar.gz
# cd cumulusclips
# chmod -R 777 cc-core/logs
# chmod -R 777 cc-content/uploads/flv
# chmod -R 777 cc-content/uploads/mobile
# chmod -R 777 cc-content/uploads/temp
# chmod -R 777 cc-content/uploads/thumbs
# chmod -R 777 cc-content/uploads/avatars
# chown -R apache:apache /opt/cumulusclips
# chown -R www-data:www-data /opt/cumulusclips

It then asks me to access the installation wizard using my browser but I can't bring it up. I'm not sure what else I need to do at this point to get everything to link right. Any help?

Thanks in advance.

Comments

  • It looks like the instructions you have are old. They seem to be for version 1 intead of 2.

    Set these permissions:

    chmod -R 777 cc-core/logs
    chmod -R 777 cc-content/uploads

    Do you know what user Apache is running as? It should be listed in your Apache config file.

    To access the installer from your browser you should go to:

    http://your-site.com/cc-install/

    If you installed the script in a sub-directory, update the link above accordingly. If you can't access the installer using that link, please tell us what error message you're getting. Also check your Apache error logs for any additional errors.
  • I've set the permissions and it looks like they took.
    Checked Apache, returning "www-data".
    Can't connect to that link.
    Apache error log has the following entry:

    [Mon Apr 04 15:47:26.752619 2016] [:error] [pid 7183] [client 192.168.1.152:62301] script '/var/www/html/info.php' not found or unable to stat
  • What error do you see when you visit the address I gave you?

    Just to make sure, you are replacing the placeholder "your-site" with your actual domain name, in the above link right?
  • I've used my domain name, internal & external IPs. It just says either Not Found or This Site Can't Be Reached.
  • Got it. It sounds like Apache isn't hitting the script.

    What does the vhost entry for the script look like in your Apache config? Can you post it here?
  • Could not find the entry in the Apache2.conf file.
  • Would there be an updated installation instructions that can take me through the whole process step-by-step? Maybe I can follow that and figure out what I missed?
  • Took me a while to figure out but this is what I found in /etc/apache2/sites-available/000=default.conf


    <VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port t$
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /opt/cumulusclips

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
    </VirtualHost>

    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet


    Is there anywhere else I should look?
  • edited April 2016
    You definitely have an Apache/routing issue. Your vhost file looks like it's setting your CumulusClips directory has the main default site for your server.

    Is your Apache server running? What do you get when you log in to your server via SSH and run this:

    wget http://127.0.0.1

    Another thing to try is to add a simple HTML file in the server root (/opt/cumulusclips in your case) named index.html with this content:

    <h1>Hello World</h1>

    And try to load the webpage in a browser. Make sure you temporarily rename the script's index.php to something else while you try this. Otherwise the two index files will conflict.
  • --2016-04-06 11:30:18-- http://127.0.0.1/
    Connecting to 127.0.0.1:80... connected.
    HTTP request sent, awaiting response... 403 Forbidden
    2016-04-06 11:30:18 ERROR 403: Forbidden.


    I went into the config file and changed "/opt/cumulusclips" to "/var/www/html" and tried the wget command again:

    --2016-04-06 11:50:25-- http://127.0.0.1/
    Connecting to 127.0.0.1:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 11510 (11K) [text/html]
    index.html: Permission denied

    Cannot write to ‘index.html’ (Permission denied).
  • Is there a general apache config? I know you posted the default.conf. I'd like to see both files in their entirety.

    Also can you also perform the following commands and post the results of each:

    ls -la /var/www/
    ls -la /var/www/html
    ls -la /opt
  • This is what I have for /etc/apache2/apache2.conf, sorry, I included everything because I don't know enough yet to cut out what I don't need to post here:


    # This is the main Apache server configuration file. It contains the
    # configuration directives that give the server its instructions.
    # See http://httpd.apache.org/docs/2.4/ for detailed information about
    # the directives and /usr/share/doc/apache2/README.Debian about Debian specific
    # hints.
    #
    #
    # Summary of how the Apache 2 configuration works in Debian:
    # The Apache 2 web server configuration in Debian is quite different to
    # upstream's suggested way to configure the web server. This is because Debian's
    # default Apache2 installation attempts to make adding and removing modules,
    # virtual hosts, and extra configuration directives as flexible as possible, in
    # order to make automating the changes and administering the server as easy as
    # possible.

    # It is split into several files forming the configuration hierarchy outlined
    # below, all located in the /etc/apache2/ directory:
    #
    # /etc/apache2/
    # |-- apache2.conf
    # | `-- ports.conf
    # |-- mods-enabled
    # | |-- *.load
    # | `-- *.conf
    # |-- conf-enabled
    # | `-- *.conf
    # `-- sites-enabled
    # `-- *.conf
    #
    #
    # * apache2.conf is the main configuration file (this file). It puts the pieces
    # together by including all remaining configuration files when starting up the
    # web server.
    #
    # * ports.conf is always included from the main configuration file. It is
    # supposed to determine listening ports for incoming connections which can be
    # customized anytime.
    #
    # * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
    # directories contain particular configuration snippets which manage modules,
    # global configuration fragments, or virtual host configurations,
    # respectively.
    #
    # They are activated by symlinking available configuration files from their
    # respective *-available/ counterparts. These should be managed by using our
    # helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
    # their respective man pages for detailed information.
    #
    # * The binary is called apache2. Due to the use of environment variables, in
    # the default configuration, apache2 needs to be started/stopped with
    # /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will n$
    # work with the default configuration.


    # Global configuration
    #

    #
    # ServerRoot: The top of the directory tree under which the server's
    # configuration, error, and log files are kept.
    #
    # NOTE! If you intend to place this on an NFS (or otherwise network)
    # mounted filesystem then please read the Mutex documentation (available
    # at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>);
    # you will save yourself a lot of trouble.
    #
    # Do NOT add a slash at the end of the directory path.
    #
    #ServerRoot "/etc/apache2"

    #
    # The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
    #
    Mutex file:${APACHE_LOCK_DIR} default

    #
    # PidFile: The file in which the server should record its process
    # identification number when it starts.
    # This needs to be set in /etc/apache2/envvars
    #
    PidFile ${APACHE_PID_FILE}

    #
    # Timeout: The number of seconds before receives and sends time out.
    #
    Timeout 300

    #
    # KeepAlive: Whether or not to allow persistent connections (more than
    # one request per connection). Set to "Off" to deactivate.
    #
    KeepAlive On

    #
    # MaxKeepAliveRequests: The maximum number of requests to allow
    # during a persistent connection. Set to 0 to allow an unlimited amount.
    # We recommend you leave this number high, for maximum performance.
    #
    MaxKeepAliveRequests 100

    #
    # KeepAliveTimeout: Number of seconds to wait for the next request from the
    # same client on the same connection.
    #
    KeepAliveTimeout 5


    # These need to be set in /etc/apache2/envvars
    User ${APACHE_RUN_USER}
    Group ${APACHE_RUN_GROUP}

    #
    # HostnameLookups: Log the names of clients or just their IP addresses
    # e.g., www.apache.org (on) or 204.62.129.132 (off).
    # The default is off because it'd be overall better for the net if people
    # had to knowingly turn this feature on, since enabling it means that
    # each client request will result in AT LEAST one lookup request to the
    # nameserver.
    #
    HostnameLookups Off

    # ErrorLog: The location of the error log file.
    # If you do not specify an ErrorLog directive within a <VirtualHost>
    # container, error messages relating to that virtual host will be
    # logged here. If you *do* define an error logfile for a <VirtualHost>
    # container, that host's errors will be logged there and not here.
    #
    ErrorLog ${APACHE_LOG_DIR}/error.log

    #
    # LogLevel: Control the severity of messages logged to the error_log.
    # Available values: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the log level for particular modules, e.g.
    # "LogLevel info ssl:warn"
    #
    LogLevel warn

    # Include module configuration:
    IncludeOptional mods-enabled/*.load
    IncludeOptional mods-enabled/*.conf

    # Include list of ports to listen on
    Include ports.conf


    # Sets the default security model of the Apache2 HTTPD server. It does
    # not allow access to the root filesystem outside of /usr/share and /var/www.
    # The former is used by web applications packaged in Debian,
    # the latter may be used for local directories served by the web server. If
    # your system is serving content from a sub-directory in /srv you must allow
    # access here, or in any related virtual host.
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
    </Directory>

    <Directory /usr/share>
    AllowOverride None
    Require all granted
    </Directory>

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
    </Directory>

    #<Directory /srv/>
    # Options Indexes FollowSymLinks
    # AllowOverride None
    # Require all granted
    #</Directory>




    # AccessFileName: The name of the file to look for in each directory
    # for additional configuration directives. See also the AllowOverride
    # directive.
    #
    AccessFileName .htaccess

    #
    # The following lines prevent .htaccess and .htpasswd files from being
    # viewed by Web clients.
    #
    <FilesMatch "^\.ht">
    Require all denied
    </FilesMatch>


    #
    # The following directives define some format nicknames for use with
    # a CustomLog directive.
    #
    # These deviate from the Common Log Format definitions in that they use %O
    # (the actual bytes sent including headers) instead of %b (the size of the
    # requested file), because the latter makes it impossible to detect partial
    # requests.
    #
    # Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
    # Use mod_remoteip instead.
    #
    LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" $
    LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combin$
    LogFormat "%h %l %u %t \"%r\" %>s %O" common
    LogFormat "%{Referer}i -> %U" referer
    LogFormat "%{User-agent}i" agent

    # Include of directories ignores editors' and dpkg's backup files,
    # see README.Debian for details.

    # Include generic snippets of statements
    IncludeOptional conf-enabled/*.conf

    # Include the virtual host configurations:
    IncludeOptional sites-enabled/*.conf

    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet


  • ls -la /var/www/
    total 12
    drwxr-xr-x 3 cesar0q www-data 4096 Apr 3 23:02 .
    drwxr-xr-x 13 root root 4096 Apr 3 23:02 ..
    drwxr-xr-x 2 cesar0q www-data 4096 Apr 3 23:02 html

    ls -la /var/www/html
    total 20
    drwxr-xr-x 2 cesar0q www-data 4096 Apr 3 23:02 .
    drwxr-xr-x 3 cesar0q www-data 4096 Apr 3 23:02 ..
    -rw-r--r-- 1 cesar0q www-data 11510 Apr 3 23:02 index.html

    ls -la /opt
    total 49216
    drwxr-xr-x 6 root root 4096 Apr 6 22:27 .
    drwxr-xr-x 22 root root 4096 Apr 7 16:18 ..
    drwxr-xr-x 6 www-data www-data 4096 Jan 17 23:08 cumulusclips
    -rw-r--r-- 1 root root 29704194 Jan 18 19:41 cumulusclips.tar.gz
    drwxr-xr-x 6 root root 4096 Apr 4 08:33 ffmpeg
    drwx------ 2 root root 16384 Apr 3 02:23 lost+found
    drwxr-xr-x 6 root root 4096 Apr 7 14:02 ubooquity
    -rw-r--r-- 1 root root 20648905 Feb 21 03:14 ubooquity.zip
  • edited April 2016
    Your main Apache config looks good, I don't see any issues there.

    Did you restart or reload Apache when you made changes to your default.conf? If not, the changes won't take place.

    Looking closely. It looks like your second wget command actually worked, the one where you moved the file to /var/www/html. It appears that you got a permission denied error because you used wget which fetches and saves instead of curl which just fetches.

    Let's do another test. Login to your server as the root account and run the following commands:

    mkdir /opt/test
    echo "<h1>Test</h1>" > /opt/test/index.html
    chown -R www-data www-data /opt/test

    Next (while still logged in as root) edit your default.conf and change the DocumentRoot to /opt/test.

    Then (still as root) restart Apache, should be either one of these commands, depending on your version of Ubuntu:

    service apache2 restart
    or
    restart apache2
    or
    apache2ctl restart
    or
    /etc/init.d/apache2 restart

    Once you're done with all that, try this:

    Try this: curl http://127.0.0.1 and post the results here.

  • curl http://127.0.0.1
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

    403 Forbidden

    Forbidden
    You don't have permission to access /
    on this server.

    Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80

  • edited April 2016
    Hmm, this one is tricky. Let's try these two:

    curl http://127.0.0.1/
    *Notice the trailing slash

    curl http://127.0.0.1/index.html

    and post the results of both here.
  • Here's what I got:


    curl http://127.0.0.1/
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /
    on this server.</p>
    <hr>
    <address>Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80</address>
    </body></html>



    curl http://127.0.0.1/index.html
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>403 Forbidden</title>
    </head><body>
    <h1>Forbidden</h1>
    <p>You don't have permission to access /index.html
    on this server.</p>
    <hr>
    <address>Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80</address>
    </body></html>
  • It looks like the changes we're making are not taking effect
  • Not sure what to do, guess i'll just start over and see if it makes a difference
This discussion has been closed.