[Solved] CC-ERROR-200 after installation within Cloud Foundry container

edited February 2016 in Bugs and Errors
Hi guys,

I'm currently trying to install CC within a Cloud Foundry container. Installation works well without any errors, but as soon as I finish the site details section and get recirected to cc-admin/?first-run I get a "CC-ERROR-200 CumulusClips has encountered an error and cannot continue".

The PHP mysql, mysqli and pdo extensions are loaded and the MySQL credentials are ok, I have tried with both, the service user and the root user and have tested them also via MySQL Workbench. And I can also see that the tables have been created.

Any idea how to troubleshoot this? There is nothing in the Apache error logs and therefore I'm a bit lost :-(

Thanks,
Marcus

Comments

  • It's an error while connecting to the database. Make sure that the file /cc-core/system/config.php has the correct values. Also, while debugging ONLY, open the file /cc-core/lib/Database.php and on line 25 replace:

    exit('CC-Error ...');
    with:
    exit($exception->getMessage());
    With that, when it fails again at cc-admin?first-run you'll see the actual error being thrown.
  • Make sure to revert your Database.php changes when you're done debugging.
  • Hi Damian,

    The values are correct. The error message once I add the getMessage line is "could not find driver". Seems there is a problem with PDO then. But the extension has been loaded successfully :-(
    I will have a deeper look at it. Thanks for the hint regarding debugging.
  • Ok fixed, I had to add the PHP extension pdo_mysql in addition to the pdo extension. Thanks again..
This discussion has been closed.