[Solved] Upgrade to 2.3 - no executable permissions on qt-faststart

edited January 2016 in Bugs and Errors
Hello team,

I did an automatic upgrade from 2.2 to 2.3 this morning and noticed that the upgrade sets the path to qt-faststart to the newly bundled ffmpeg-[32|64]-bit/qt-faststart. Unfortunately these binaries do not have the executable bits set, so after upgrading, any new video uploads will fail.

I know that the instructions for a fresh install tell you to make the necessary permission changes, but these "automatic" updates have never needed that, nor do the instructions mention this.

So this is something folks just need to be aware off. Even with an automatic update, permissions need to be updated on the /cc-core/system/bin/ffmpeg-[32|64]-bit/ffmpeg and qt-faststart files.

Comments

  • Good catch.

    We're releasing a patch release tonight or tomorrow that will address this.
  • I had same isue. Else from that a very easy upgrade :)
    I could not do a clean 2.3 install thou. During step 4 (setting up database) I got a blank white screen. Tried wiping cache etc, puling source directly with wget, but no luck. Installing 2.2 -> upgrade to 2.3 no prob.
  • @mrpink @GreenMotion Version 2.3.1 was released last night. It addresses the permissions issue with the qt-faststart & FFMPEG binaries. It also addresses some bugs in the installer.
  • @Damian, that's awesome! Other than the qt-faststart executable issue, my update went smooth. Can I stay on 2.3 or should I apply 2.3.1? (i.e. were there any bugs in the upgrade installer other than the executable permissions I should be concerned about?)
  • Yes, I recommend updating. They were with the encoder, the updater, and the video video settings page. The fixes were mainly in this commit:

    https://github.com/cumulusclips/cumulusclips/commit/b3d1ac4e258d171147224806f57181bf57c8c909

    There were also some changes to the installer and README & LICENSE files, but these were minor.
  • Got it. Any changes to any of the themes in this hotfix?
  • No, not in 2.3.1.
  • I did an in-app upgrade from 2.3.0 to 2.3.1 and it reset the permissions on the ffmpeg files to -x: :(

    [root@ bin]# find . -type f -exec ls -al {} \;
    -rwxrwxrwx 1 apache apache 2533 Dec 14 16:29 ./qtfaststart
    -rw-r--r-- 1 apache apache 30008712 Jan 19 10:03 ./ffmpeg-32-bit/ffmpeg
    -rw-r--r-- 1 apache apache 645488 Jan 19 10:03 ./ffmpeg-32-bit/qt-faststart
    -rw-r--r-- 1 apache apache 40050648 Jan 19 10:03 ./ffmpeg-64-bit/ffmpeg
    -rw-r--r-- 1 apache apache 814568 Jan 19 10:03 ./ffmpeg-64-bit/qt-faststart


  • Yes, that's because the fixed file is being added. The old version is the one that was running in memory at the time. The old one had the wrong permissions. To accommodate for this, we set the permissions in the encoder. See /cc-core/system/encode.php "Step 1".

    Try an upload and let me know what happens.
  • AAAAH, OK. Yes, you are right, Everything works and after a video upload it does update the permissions. Cool.
  • Glad it works. Let me know if you notice any other issues.
This discussion has been closed.