Links to do not work in CumulusClips after installation

edited December 2011 in Bugs and Errors
I tried to install CumulusClips at localhost (Ubuntu 10.10, Apache 2.2.17, PHP 5.3.5).
and have installed all the required libs in Ubuntu and configured php.ini and httpd.conf.
Links to Videos, Menbers, Upload do not work after installation (Error 404 "Page not found").

I assume it has something to do with Apache web server /mod_rewrite.
But I have enabled:
LoadModule rewrite_module modules/mod_rewrite.so
and
<Directory />
Options FollowSymLinks
AllowOverride All
XAMPP
Order deny,allow
Allow from all
</Directory>

What may be the problem here?
Aages

Comments

  • edited December 2011
    Hello,

    Yes, I think you're correct when you say it could have something to do with mod_rewrite or at the very least the Apache configuration of the vhost.

    Let's try several things.

    ======================================

    First let's be absolutely positive that mod_rewrite is enabled and loaded.


    Run these two commands from the command line:

    sudo a2enmod rewrite
    sudo /etc/init.d/apache2 -restart

    Once those two commands have been executed run this command:

    ls /etc/apache2/mods-enabled

    In the list of files that gets output, search for 'rewrite', it could go by several names such as:

    rewrite
    rewrite.load
    rewrite.conf
    rewrite.so
    mod_rewrite
    mod_rewrite.load
    mod_rewrite.conf

    Once you run the first two commands to load mod rewrite and made sure that it's enabled, we can move to another

    ========================================

    You mentioned you installed it at localhost,

    1) What directory exactly did you install CumulusClips into? ('/var/www/cumulusclips' maybe?)

    2) Please provide us with the vhost configuration for your site. This is the text you used to create the vhost, in the directory /etc/apache2/sites-available or httpd.conf.

    It should look something similar to this:

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName cumulusclips
    DocumentRoot /var/www/cumulusclips
    <Directory /var/www/cumulusclips/>
    AllowOverride All
    </Directory>
    </VirtualHost>

    Please let us know.


    =========================================

    Can you hit these URL's (replace the domain with the one you're using)

    http://your-cumulusclips-site.com/cc-core/controllers/index.php
    http://your-cumulusclips-site.com/cc-core/controllers/videos.php
    http://your-cumulusclips-site.com/cc-core/controllers/members.php

  • edited December 2011
    Thank you for help!

    mod_rewrite seems to be enabled and loaded.
    When I used this command:
    root@aages-desktop:/home/aages# ls /etc/apache2/mods-enabled
    I got: rewrite.load

    root@aages-desktop:/home/aages# sudo a2enmod rewrite
    Module rewrite already enabled

    1.
    Cumulusclips is installed in:
    '/opt/lampp/htdocs/cumulus'

    2.
    # 'Main' server configuration
    ServerAdmin you@example.com
    ServerName localhost
    DocumentRoot "/opt/lampp/htdocs"

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    #XAMPP
    #Order deny,allow
    #Deny from all
    </Directory>

    <Directory "/opt/lampp/htdocs">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    <IfModule dir_module>
    #DirectoryIndex index.html
    # XAMPP
    DirectoryIndex index.html index.html.var index.php index.php3 index.php4
    </IfModule>
    #
    # The following lines prevent .htaccess and .htpasswd files from being
    # viewed by Web clients.
    <FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
    </FilesMatch>

    # "/opt/lampp/cgi-bin" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have that configured.
    <Directory "/opt/lampp/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    aages
  • edited December 2011
    The setup you have is a little different from what I'm used to seeing in Ubuntu v10.10.

    Typically there is an Apache config file located at:

    /etc/apache2/apache2.conf

    And there are individual vhosts located in:

    /etc/apache2/sites-available/

    i.e. /etc/apache2/sites-available/default

    Within that directory you would put the vhost configuration for each site you want Apache to manage.

    Additionally the default document root for Apache should be:

    /var/www

    What you have provided to us is totally different and tells me either:

    1) You purposely changed the Apache setup, (which is okay, that's your decision)
    2) You installed Apache separately yourself (again, also okay)
    3) or You are working with the incorrect set of config files

    I'm going to assume you know what you're doing and that #1 or #2 are the case.

    ============================================


    Can you try this:

    sudo vi /etc/apache2/sites-available/default

    and change EVERY instance of:

    AllowOverride None

    to

    AllowOverride All

    Then run:

    sudo /etc/init.d/apache2/restart

    and try loading your site again.


    =============================================

    You didn't answer my question about being able to access these URLs:


    http://localhost/cc-core/controllers/index.php
    http://localhost/cc-core/controllers/videos.php
    http://localhost/cc-core/controllers/members.php

    Please try each link and report your results here.
  • edited December 2011
    Hi

    I used XAMPP for Linux to install the LAMP-stack. See:
    http://www.apachefriends.org/en/xampp-linux.html
    The setup was done by XAMPP.
    '/var/www/' exists, but according to installation manual for XAMPP '/opt/lampp/htdocs/' is set to be "The Apache DocumentRoot directory".

    I can't find a apache2 directory under etc and therefore can't see individual vhosts located in:/etc/apache2/sites-available/

    But used:
    sudo vi /etc/apache2/sites-available/default
    and got:
    "<VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
    Options FollowSymLinks
    AllowOverride None (should be corrected)
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None (should be corrected)
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None (should be corrected)
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>"

    But can't locate this text to correct it.

    I was able to access all these URLs:
    http://localhost/cumulus/cc-core/controllers/index.php
    http://localhost/cumulus/cc-core/controllers/videos.php
    http://localhost/cumulus/cc-core/controllers/members.php

    Aages
  • Oh, i see. That explains alot then!

    The fact that you were able to access the 3 URLs provided earlier tells me that CumulusClips is running fine and that the issue is the Xampp/Lampp configuration.

    Now that I know what context we're working in let's try a couple things. I'm not that familiar with Xampp but I'll try to help you out.

    First of all, forget all the stuff I previously mentioned about apache2, etc. You're using Xampp and thus it doesn't apply to you.


    1) In your httpd.conf file, look for the line that reads:

    <Directory "/opt/lampp/htdocs">

    And add a trailing slash so that it looks like this:

    <Directory "/opt/lampp/htdocs/">


    2) Add this block at the very end of the file:

    <Directory "/opt/lampp/htdocs/cumulusclips/">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    Notice that I added "cumulusclips/" to the directory directive. I'm assuming you have CumulusClips installed at: /opt/lampp/htdocs/cumulusclips/. If this is incorrect, then please update that path to the proper one.


    3) Once you make the changes outlined above, run this command:

    sudo /opt/lampp/lampp restart

    And try to visit this URL: http://localhost/cumulusclips/videos/

    Again, CumulusClips is installed and running fine, we just need to correct your mod_rewrite issue. Please report back your results.

  • edited December 2011
    Good that Cumulusclips was installed correctly and is functioning properly and that the only problem is Xampp/Lampp configuration related to mod_rewrite!

    I made the proposed changes. Added a trailing slash to the path and made the new Directory for the path "/opt/lampp/htdocs/cumulus/" where CumulusClips is installed.

    Restarted lampp, but still I get Error 404 "Page not found" when going to http://localhost/cumulus/videos/

    aages
  • Could you please provide your Apache error log. It should be a file called: error.log

    in the directory:

    /opt/lampp/logs or /opt/lampp/apache/logs or something similar.
  • Hello,

    I just installed XAMPP for Linux 1.7.7 on Ubuntu Desktop 11.4

    Here's what I did:

    1) Installed XAMPP per their instructions for Linux on http://www.apachefriends.org/en/xampp-linux.html
    2) Installed CumulusClips at /opt/lampp/htdocs/cumulusclips
    3) Accessed http://localhost/cumulusclips/videos/ and it worked fine.

    I read through their documentation and they state that mod_rewrite is enabled by default. That being said I made NO changes at all to the default httpd.conf located at:

    /opt/lampp/etc/httpd.conf

    I simply installed XAMPP, then CumulusClips and both ran with the default settings.

    Additionally I ran:

    /opt/lampp/bin/httpd -M

    and on the output I saw 'rewrite_module (shared)' which indicates it's installed and enabled.

    Please run the command above to see if rewrite_module is there, and provide us with your error log located at:

    /opt/lampp/logs/error_log

    We will investigate your error log for clues. However, if you continue to have problems with mod_rewrite I suggest you re-install XAMPP and DO NOT make any changes to the default configuration. Then install CumulusClips and see if that fixes your mod_rewrite problem.

    Of course afterwards you'll need to update the PHP settings so that CumulusClips can work correctly, i.e.

    MAX_POST_FILESIZE = 120M
    MAX_EXECUTION_TIME = 3600
    etc.

    Keep us updated
  • I am happy to tell that the links in cumulusclips is working now, but embarrassed about the reason.
    Under installation I selected and dragged the files from the installation folder (cumulusclips) to the folder on localhost. But because the .htaccess file was a hidden file, it was not included in the transfer.
    It didn't work simply because the .htaccess file was missing. When I discovered this mistake it was easy to fix it, but sorry you spent so much time on this issue. Thanks a lot for your helpfulness and interest!

    aages
  • No worries, I'm glad you got it to work!

    If you need any assistance with any other issues please open another thread and let us know. We will be happy to help!
This discussion has been closed.