Getting video to play on iPhone

I've tried the CC demo site, and iPhone videos play fine. On mine I've tried countless settings, and in the mobile site the videos show the play arrow as if they will play, but absolutely nothing happens when pressed.

Can anyone share with me some ffmpeg settings that work for them. I can play the videos from the mobile site fine on a pc.

Comments

  • Did you modify the FFMPEG settings at all in the admin panel?
  • yep, I've tried lot's of suggested settings. I'd happily try the original defaults again if you can send them to me
  • Go to admin panel - settings - video and set these setting values:

    h264 encoding options:
    -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libfaac -ab 96k -ar 44100 -f mp4'

    mobile encoding options:
    -vcodec libx264 -vf "scale=min(480\iw):trunc(ow/a/2)*2" -vb 600k -ac 2 -ab 96k -ar 44100 -f mp4
  • Hi, Thanks, have tried these settings but exactly the same outcome. Video thumbnail appears fine with a play arrow on it, but pressing it does nothing at all.
  • What version of CC are you running?

    Can you share your "view-source" for the mobile page?

    Thanks.

  • Hi, running Version 2.2.0 (Latest)
    I have managed to get the videos on the mobile page to play on Android phones before (haven't tried for a while, so the current encoding may not work, will check tomorrow), it seems to be an iPhone issue. I've attached the view source from the mobile page as displayed on my PC.
    txt
    txt
    mobile_page_source.txt
    7K
  • Is your site publicly accessible? It would make debugging a lot easier and help us find the issue.

    Also can you attach the encoding logs for a few of your videos (admin panel - dashboard - system logs)

    The encoding process is obviously working and completing because you're able to see the videos being listed. It doesn't seem like an encoding configuration because the defaults which we provided you work on both iOS and Android.
  • Hi, Thanks for all your help. I've tried a mobile wifi hotspot into our network, it all works now, so we must have some internal security issue.
This discussion has been closed.