change website URL

I am trying to change my website URL to a new URl
How do i do this?

Why i tried doing it from the database its now working

Please advice



  • The only change required is to update the base url. This can be done from the Admin Panel -> Settings -> General. If you have to do it in the database, update the record in the settings table with a name value of "base_url". It is recommended to use the Admin Panel route.
  • i did that and it is not working
    if we can exchange message privately then i can show you the website and what issue am facing

  • do you have an email i can send you the website
  • Send an email to support [at]
  • just sent the email now..thanks
  • Your issue is not related to CumulusClips. What I have mentioned above to update base url is all that is needed.

    When visiting your website, you are redirected before CumulusClips even gets a chance to load. This is a hosting/domain configuration issue.

    Hope that helps.
  • in my email i mentioned i wanted to clone the site to a new i copied over the same files and took mysql dump and restored all files and database and changed the base_url in the database settings and yet the links to videos still showing old URL
  • edited May 2015
    Ok, I just visited your site again and this time I got a different result. I was able to successfully see the site and confirmed what you're saying about the URLs.

    The output I'm seeing on your site is exactly what it would look like if the base_url setting is incorrect. Double check the database again and make certain that the setting is the new URL. This is what is causing your problem.

    I also noticed that you're getting PHP Safe Mode or PHP open_basedir errors, see your admin panel.
  • did you see the old URL? you will when you change the hosts file on your computer to point the URL to the server IP address. That is on the same server and there is no error so PHP safe mode is not the problem like i said the previous URL works fine. The second or new URL is just a clone of the old one

    Did you also see the screenshot of the second email? I showed the database and you will see base_url is set properly.

    If you reply to that email i can provide you the access to the server and database if you will like to take a look.

    Again just to make sure you get what i am trying to so. I am trying to clone one website and use it on a second URL. And the problem is the second URL is not pointing well even after making the proper vase_url change in the database.
  • remember to remove the host file entry when you testing or checking the second URL..else it will be using the URL of old to look like everything is fine
  • damian am willing to pay
    i really want to fix this issue
    its a little urgent but just want to fix it
  • Sorry we don't accept paid jobs.

    Your links are broken because the base_url in the admin panel/database is set to the old URL. There is no doubt about that. You've got to do some investigating.

    Make sure that the database that the new site is pointing to has the updated base_url value in the settings table.

    Ensure that the file /cc-core/system/config.php has the information for the new MySQL server not the old one. It could be that even though you changed the setting on the new server's table it's still connecting to the old database due to the old config.

    Maybe there is a caching layer somewhere that needs to be cleared.
  • Nokia, I am not part of the cumulus team, but I'd be more than happy to have a look at this for you tonight / this weekend if you'd like. Just email me at greenmotion{at}gmail{dot}com
  • edited May 2015
    @Damian at least reply to email..there are some information i want to send but you never respond to email

    #1. I checked the old URL and there is no config.php under the cc-core/system directory, and everything works fine on the old url as explained

    but for the new URL the one having problems, there is config.php and all settings are correct. Why is there config.php in the new URL and there is none in old URL?

  • That is strange. The only reason there should not be a config file there is if the script was never installed or you're still running version 1 of the script.

    If you did a straight copy of files from one location to another then the files should match. Was this a copy or did you upgrade or change anything in the process?

    Another option is to do a clean install and import the old data using SQL. You would have to ensure that the table structures match up.
  • Yes i think the old URL uses version 1

    Well first i did a copy and it didn't work and then i installed a new script and then try to dump old database into new one and also copy over the files and yet still didn't work either.

    So that is why, the config file probably is the left over of the time i installed a new setup and then copied database and files after

    I can give you the database and you can see all of this, it wont take long at all, as you are familiar with the script. I show you the working URL which works fine and the new URL with problems and you can see the database and also see the files
  • edited May 2015
    Now things are starting to make sense. Let's take a few steps back. I'm going to walk you through this.

    - Remove all files from the new location (server) including the database. We're going to start fresh in the new server.

    - Copy all of the original files to the new location and import the old database backup.

    - Once the old database backup has been imported into the new location, using your preferred database UI tool, i.e. Phpmyadmin, connect to the newly imported database and update the base_url value in the settings table. The value should be that of your new URL.

    - Open the file /cc-core/configs/config.php (this should be the old file you copied over) and update the values so that they reflect your new database host, user, password, etc.

    - After doing all that, visit your new address and tell me specifically what you see or what specifically happens

    Thanks a lot Damian, really really really appreciate your help
    Someone else would have quit on me, but you did not. Really happy man..thanks man
  • one last problem

    When i click a video it gives 404 error not found page, but the URL is pointing in the right place now so that is good
    the videos files are there because i copied everything over.

    Also when i tried to login to the admin section of the new URL /cc-admin
    I get this error

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /cc-core/lib/Functions.php on line 330

    Warning: Cannot modify header information - headers already sent by (output started at /cc-core/lib/Functions.php:330) in /cc-core/lib/Functions.php on line 44

    Now understand the setting of the server is not the issue because the old URL works fine and is running with same settings

    I am thinking there is another settings i need to make elsewhere

  • edited May 2015
    You have two different issues currently.

    1) 404 issue - Make sure you have the .htaccess file located at the root of the script. It is a hidden file.

    If the above doesn't fix it then also make sure mod_rewrite is enabled in the Apache config and your vhost has AllowOverride set to "All". If you're on a shared web host then the mod_rewrite and AllowOverride should already be fine.

    2) Admin Panel Error - Go to your php settings (php.ini) and set safe_mode to "off" and set open_basedir to "none".
  • the issue was with the .htaccess so copied the one from the old url and it works fine now..NEW issue is the redirect for the admin is also showing error

    Warning: Invalid argument supplied for foreach() in /cc-admin/plugins.php on line 112

    Also going to the /cc-admin redirects back to /myaccount until i put /cc-admin/settings.php then am able to access the admin dashboard

    I think there is something i need to change from somewhere again and i will be totally fine
This discussion has been closed.