Installation problem

Hi Damian, I'm in the process of installing CumulusClips on a new website. I unzipped the 2.2 file and ftp'ed it up and set the permissions and it checks automatically up to the point of adding the database information, then I receive a error that it can't connect to ftp (image attached). I have added one copy of CumulusClips to my server a few months ago with no problems. I'm using sftp if that's a problem.

Thanks
ScreenShot001.jpg
1061 x 680 - 104K

Comments

  • Try changing the FTP Host to: 127.0.0.1
  • It's still unable to connect to ftp
  • What happens when you FTP to your site using the credentials you provided to the installer?
  • Meaning, open an FTP client and try connecting using the same credentials.
  • It's bypassing the FTP setup, the installer bypasses both the installation requirements and the ftp credentials and it doesn't give me the option to edit anything.
  • I have an idea, of what's going on. I think you manually set the permissions of the files manually and this confused the installer into thinking that FTP wasn't needed. However when file ownership was required FTP failed as a result because the FTP step was skipped.

    Let's try something to see if I'm correct. Open the file: /cc-install/ftp.php and on line 22

    Change it from:

    if (posix_getuid() == fileowner(DOC_ROOT) && is_writable(DOC_ROOT)) {

    to:

    if (posix_getuid() == fileowner(__FILE__) && is_writable(__FILE__)) {

    Also delete the file /cc-core/system/config.php if it exists. Then delete your cookies and restart the installer. Let me know how that works out.
  • Ok I changed line 22, removed my cookies and cleared the browser cache and deleted the system config file. Then manually typed domain.com/cc-install/index.php and the url changed to domain.com/cc-install/cc-install/?requirements with a white screen so I truncated it down to domain.com/cc-install/?requirements and it advanced back to the database credentials page as it was earlier bypassing the requirements and ftp setup. I then added the database information and it went back to - Unable to connect to FTP host (). The 375 byte system config.php returned to the folder, but line 22 didn't change back.
  • Change it back as I requested. The white screen you got means there's a PHP setting missing. Turn display_errors = on in your php.ini to display what the error was.
  • OK php.ini error log is on and I've attached it, I've cleared the cookies, cache and deleted the config.php several times, but it goes directly to the database info now.
    txt
    txt
    error_log.txt
    1K
  • You re-applied the change I suggested when you did all this?
  • Yes line 22 is still: if (posix_getuid() == fileowner(__FILE__) && is_writable(__FILE__)) {
  • In the file: /cc-install/index.php on line 2 add the following:

    error_reporting(-1);
    ini_set('display_errors', 1);

    Then delete all cookies, the config file, and visit http://yoursite.com/cc-install/

    When you get the blank screen report back what the URL is.
  • edited March 2015
    Ok I inserted the code, deleted all cookies, there wasn't a config file and ran cc-install. The welcome screen pulled up, but when I clicked continue it went straight to the database info. I used a different browser this time and Chrome picked up on some errors, I've attached both the Chrome errors and the inserted log errors. I'm using a subfolder this time.
    txt
    txt
    insert error log.txt
    1K
    txt
    txt
    errors displayed using Chrome.txt
    1K
  • That is really strange. The FTP error you received is because of missing FTP credentials. You have missing FTP credentials because the installer bypassed the FTP step. What I don't understand is why is the installer bypassing the FTP step.

    The only thing I can think of is to force the FTP step by deleting lines 21-33 on the file /cc-install/ftp.php and restarting the installer.

    Can you tell me who (what user) the owner of the files are?
  • Yes it is strange, but I did as you said and setup the sftp. When I added the database info it now says: Unable to set permissions via FTP (511 on /cc-core/system/bin/qtfaststart), the user is songs.
  • Ok at this point we can either try to find and fix the issue in the installer which will allow you to complete the install and prevent this type problem happening again.

    Or

    I can walk you through a manual install, which is faster and completely skips these problems.

    I recommend the first option because if you just skip the installer the problem is still there and will cause issues later on.

    Your choice.
  • Ok sounds good Damian, just let me know what you need on my end
  • Send an email with your FTP (or SSH prefereably) credentials to support@cumulusclips.org. We will login and see if we can debug this issue for you. When we find what the problem was we will post the solution here for posterity.
  • edited March 2015
    I tried several times yesterday to setup a sftp account for you, but kept blacklisting myself from the server, not sure what is up with that, but I went ahead and installed CumulusClips on densong.com and it installed just fine so I'll just use that domain. I removed it from heartsongs.org because I could never get the search engines to list any pages using the script so I went back to Joomla.

    Thanks for your help Damian...
This discussion has been closed.