Convert problems v2

edited December 2014 in General
Hi

I have installed v2 without problems, but video converting is not working.
When I upload video, than I gets massage "Processing".
Script is installed on Arvixe hosting.
Error log:

// Converter Called...
Values passed to encoder:
Array
(
[0] => /home/xxx/public_html/video/cc-core/system/encode.php
[1] => --video=5
)

Validating requested video...
Establishing variables...
Verifying raw video exists...
Verifying raw video was valid size...

Preparing for: H.264 Encoding...
H.264 Encoding Command: /usr/local/bin/ffmpeg -i /home/xxx/public_html/video/cc-content/uploads/temp/7UYGHmucXhEh75MlZpVj.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libfaac -ab 96k -ar 44100 -f mp4 /home/xxx/public_html/video/cc-content/uploads/h264/7UYGHmucXhEh75MlZpVj_temp.mp4 >> /home/xxx/public_html/video/cc-core/logs/7UYGHmucXhEh75MlZpVj.log 2>&1
Verifying H.264 video was created...

Warning: Missing argument 2 for Mail::send(), called in /home/xxx/public_html/video/cc-core/lib/App.php on line 59 and defined in /usr/local/lib/php/Mail.php on line 114

Warning: Missing argument 3 for Mail::send(), called in /home/xxx/public_html/video/cc-core/lib/App.php on line 59 and defined in /usr/local/lib/php/Mail.php on line 114
The temp H.264 file was not created. The id of the video is: 5

Thanks

Comments

  • can anyone help me with this problem please?
  • What does the log file: 7UYGHmucXhEh75MlZpVj say happened? Can you share its contents, it's located in admin panel - dashboard - system logs
  • Hello Damian

    Here are the logs:
    VIdeo log:
    =============
    ==================================================================
    H.264 ENCODING
    ==================================================================

    H.264 Encoding Command: /usr/local/bin/ffmpeg -i /home/xxx/public_html/video/cc-content/uploads/temp/sWdNXjcWEoVG6yrzEtKT.mp4 -vcodec libx264 -vf "scale=min(640\,iw):trunc(ow/a/2)*2" -vb 800k -acodec libfaac -ab 96k -ar 44100 -f mp4 /home/xxx/public_html/video/cc-content/uploads/h264/sWdNXjcWEoVG6yrzEtKT_temp.mp4 >> /home/xxx/public_html/video/cc-core/logs/sWdNXjcWEoVG6yrzEtKT.log 2>&1

    H.264 Encoding Output:

    FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers
    built on Jan 29 2012 17:52:15 with gcc 4.4.5 20110214 (Red Hat 4.4.5-6)
    configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --disable-avisynth --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --enable-avfilter --enable-avfilter-lavf --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-vdpau --enable-version3 --enable-x11grab
    libavutil 50.15. 1 / 50.15. 1
    libavcodec 52.72. 2 / 52.72. 2
    libavformat 52.64. 2 / 52.64. 2
    libavdevice 52. 2. 0 / 52. 2. 0
    libavfilter 1.19. 0 / 1.19. 0
    libswscale 0.11. 0 / 0.11. 0
    libpostproc 51. 2. 0 / 51. 2. 0
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/xxx/public_html/video/cc-content/uploads/temp/sWdNXjcWEoVG6yrzEtKT.mp4':
    Metadata:
    major_brand : isom
    minor_version : 512
    compatible_brands: isomiso2avc1mp41
    encoder : Lavf55.12.100
    Duration: 00:03:42.16, start: 0.000000, bitrate: 3030 kb/s
    Stream #0.0(und): Audio: aac, 44100 Hz, stereo, s16, 253 kb/s
    Stream #0.1(und): Video: h264, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 2772 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
    Unrecognized option 'vf'
  • You have a really old version of ffmpeg. It doesn't accept the vf option, see bottom of your logs:

    Unrecognized option 'vf'

    Try changing the -vf to -vfilter in the admin panel - settings - video - h264 & mobile encoding options. I think that worked in your version of ffmpeg. Then attempt another upload.

    If it still fails then report the problem to your web host and ask them to upgrade ffmpeg as your version is too old.

    Also I recommend against using the ffmpeg binary provided by the package manager because they're buggy and usually out of date. The best bet is to grab the latest stable code from ffmpeg and compile it themselves.

    Grab the latest from videolan's website recompile and try again. That should fix your issue.
  • Thanks Damian,
    -vfilter is not working.
    I have send a mail to Arvixe hosting for ffmpeg update.
  • I've same problem and send support mail to Arvixe hosting.
  • I have answer from Arvixe:
    Usually we wouldn't make changes to the FFMPEG as it works for the majority of our customers, and compiling it from source may cause problems for other customers. Anyone wanting a custom setup in terms of FFMPEG would need to upgrade to a dedicated server/VPS.
  • Yes eshayem I get same message:
    Hello,

    Please note that we cannot change the ffmpeg version on our shared servers on our individual requests as the same is affecting all users on the server. You would need to upgrade to our VPS Plan in order to have that.

    Current FFMPEG Version on your server is:-

    FFmpeg version 0.6.5
  • @damain
    @eshayem

    I getting now this mail for Arxive Hosting:


    Hello,

    We have a newer version of FFMPEG on all of our Servers, it can be found at:

    /usr/src/ffmpeg/ffmpeg/ffmpeg

    tarsier:/usr/src/ffmpeg/ffmpeg# ./ffmpeg
    ffmpeg version git-2014-01-31-dce9321 Copyright (c) 2000-2014 the FFmpeg developers
    built on Jan 31 2014 20:37:02 with gcc 4.4.7 (GCC) 20120313 (Red Hat 4.4.7-4)
    configuration: --prefix=/usr/local/ffmpeg --extra-cflags=-I/usr/local/ffmpeg/include --extra-ldflags=-L/usr/local/ffmpeg/lib --bindir=/usr/local/ffmpeg/bin --extra-libs=-ldl --enable-gpl --enable-nonfree --enable-libfdk_aac --enable-libfaac --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libfreetype --enable-libtheora

    and is at the 2014 Version.

    You can set your scripts to call this version if you need. The main version of ffmpeg can't be updated, that is why we offer two versions.

    Best Regards,

    Patrick Stein
    Quality Assurance Team
  • edited December 2014
    @sinanh79 @eshayem Update your FFMPEG path to the newer one Arxive provides. Go to:

    Admin Panel - Settings - Video - FFMPEG Path

    Change that value to the newer one provided by Arxive:

    /usr/src/ffmpeg/ffmpeg/ffmpeg
  • Correction:

    /usr/src/ffmpeg/ffmpeg/ffmpeg
  • Hello
    I changed new FFMPEG Path and upload a video. But I see this error in Converter Log

    "The temp H.264 file was not created......"

    (Permission: 777)
    What can I do?





    // Converter Called...
    Values passed to encoder:
    Array
    (
    [0] => /home/sinanh79/public_html/video-klip/cc-core/system/encode.php
    [1] => --video=8
    )

    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: H.264 Encoding...
    H.264 Encoding Command: /usr/src/ffmpeg/ffmpeg/ffmpeg -i /home/sinanh79/public_html/video-klip/cc-content/uploads/temp/dpYK68x4xMPL9KTfxpaU.flv -vcodec libx264 -vf \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"scale=min(640\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\,iw):trunc(ow/a/2)*2\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\" -vb 800k -acodec libfaac -ab 96k -ar 44100 -f mp4 /home/sinanh79/public_html/video-klip/cc-content/uploads/h264/dpYK68x4xMPL9KTfxpaU_temp.mp4 >> /home/sinanh79/public_html/video-klip/cc-core/logs/dpYK68x4xMPL9KTfxpaU.log 2>&1
    Verifying H.264 video was created...
    The temp H.264 file was not created. The id of the video is: 8
  • Your h264 command is messed up. You need to remove all those extra "\". There should only be one after the 640, i.e. min(640\,iw)

    Find it here admin panel - settings - video - h264 options
  • It's working now for me.
    Install new version 2.0.2 on Arvixe hosting (manually)
    Than go to admin panel - settings - video and change
    Log Encoding: On
    PHP Path: /usr/local/bin/php
    FFMPEG Path: /usr/src/ffmpeg/ffmpeg/ffmpeg

    You can convert one file at once.
  • Working fine.
    I installed by Softcolous, and use Arvixe Supports setting.
    PHP Path: /usr/local/bin/php
    FFMPEG Path: /usr/src/ffmpeg/ffmpeg/ffmpeg

    Thank you all
This discussion has been closed.