Installation problem v2

edited November 2014 in General
Hello

I am very excited to test out the new version 2.0. I seem to have a problem during installation however. I arrive at the welcome screen for installation. When I click next I then arrive at the Database setup, which means that Requirements and FTP connection are green. When I have completed the database from and click "Submit database login" the script gives me an error message "Unable to connect to FTP host()". Do you have any idea what I am doing wrong?

Compared to the previous version when I needed to add FTP information version 2 skippes that page.

Thanks in advance!
Chris

Comments

  • me too

    Fatal error: Call to undefined function posix_getuid() in /home/adhi/www/myvideo/cc-install/includes/FilesystemInstaller.php on line 331

    how to solve it.. thanks
  • @santijepara you have a different issue. Can you create a separate discussion so that we can address it specifically.
  • Hello Chris,

    We're looking into it. I'll let you know what we find.
  • Hello Damian

    Thank you for your response. Please let me know if I can support you in any way. Does it seem to be related to the ftp settings or is something totally different?

    Best regards
    Chris
  • No, not right now. I have a hunch of what's going on. I just want to confirm with another engineer on our team first before I give you any direction.

    I'll keep you posted.
  • Okay thank you again. I look forward to your directions.
  • Hello

    I think I found the problem and why nobody else had it. I installed the version 2 in a subfolder of the cumulus version 1 to test it out. In order to get around the error I have I tested to give the ftp input directly in ftp.php install file. That way I managed to complete the installation without the ftp host error. When I then tried to navigate the new site I kept getting into problems that resulted in a mixture of version 1 and version 2 with errors. What I now tried was to temporarely move version 1 and just install version 2 in the base folder alone. This time I had to add the ftp information as I did for the version 1 installation. I will now create a new mysql database and see if I can complete the installation.

    I just wanted to let you know my progress. I will post here again if I am free of this issue. I also want to apologize for not anticipating that installing version 2 in a subfolder of version 1 could lead to a problem.

    Best Regards
    Chris
  • Hello again!

    The solution I found works and this is no longer a problem. Thank you for your efforts and sorry for wasting your time. I at least hope that someone else has use for this thread.

    You may now close this.

    Best regards
    Chris
  • Hey Chris,

    My suspicions were correct, there was a bug in the installer. This is why you weren't prompted for FTP info.

    You should be able to install the software anywhere, root of domain or subfolder. If that fixed it for you then something else was going on. In any rate in glad you got it working.
This discussion has been closed.