Some clips appear, some don't

edited June 2012 in General
OK a strange problem.
Some videos upload ok, and appear ok on the site.
While others appear to upload ok, but they do not appear on the site.
(They do however seem to be actually get uploaded the the server in the relevant cc-content folder).

It's difficult to troubleshoot, but generally smaller files seem to be ok (<10MB) whereas the larger files (>10MB) simply don't appear online.

I looked at that other thread on here about them not appearing and that was not the problem.
Any ideas on what might be preventing some vids from appearing?
Thanks.

Comments

  • Yes try the following:

    Go into the admin panel and enable log encoding in the video settings section.

    Next delete any existant log files located in /cc-core/logs

    Then try to upload one of the videos that always seems to produce this issue.

    Wait a while (~ 30 minutes) and grab the newly created log files.

    Post them here. (we prefer a link to the files rather then posting their content)
  • OK will try.
    Tech guy just told me the permissions were not all 777 as per on the install guide - might this be the issue?
  • No, I doubt it since some of the videos are able to be uploaded normally.
  • Does this make any sense?

    ----

    ### Converter Called...
    Values passed to encoder:
    Array
    (
    [0] => /home/sjt/public_html/sj/cc-core/system/encode.php
    [1] => --video=94
    )

    Validating requested video...
    Establishing variables...
    Verifying raw video exists...
    Verifying raw video was valid size...

    Preparing for: FLV Encoding...
    FLV Encoding Command: /usr/local/bin/ffmpeg -i /home/sjtv/public_html/sj/cc-content/uploads/temp/eF7XOh5tYX9WTe1rB1Tw.wmv -s 640x480 -qscale 1 -ac 2 -ab 96k -ar 44100 -f flv /home/sjtv/public_html/sj/cc-content/uploads/flv/eF7XOh5tYX9WTe1rB1Tw.flv >> /home/sjtv/public_html/sj/cc-core/logs/eF7XOh5tYX9WTe1rB1Tw.log 2>&1
    Verifying FLV video was created...

    Preparing for: Mobile Encoding...
    Mobile Encoding Command: /usr/local/bin/ffmpeg -i /home/sjtv/public_html/sj/cc-content/uploads/temp/eF7XOh5tYX9WTe1rB1Tw.wmv -s 480x360 -vb 600k -ac 2 -ab 96k -ar 44100 -f mp4 /home/sjtv/public_html/sj/cc-content/uploads/mobile/eF7XOh5tYX9WTe1rB1Tw_temp.mp4 >> /home/sjtv/public_html/sj/cc-core/logs/eF7XOh5tYX9WTe1rB1Tw.log 2>&1
    Verifying temp Mobile file was created...

    Checking qt-faststart permissions...

    Shifting moov atom on Mobile video...
    Faststart Command: /home/sjt/public_html/sj/cc-core/system/bin/qtfaststart /home/sjt/public_html/sj/cc-content/uploads/mobile/eF7XOh5tYX9WTe1rB1Tw_temp.mp4 /home/sjtv/public_html/sj/cc-content/uploads/mobile/eF7XOh5tYX9WTe1rB1Tw.mp4 >> /home/sjt/public_html/sj/cc-core/logs/eF7XOh5tYX9WTe1rB1Tw.log 2>&1
    Verifying final Mobile file was created...

    Retrieving video duration...
    Duration command results:
    Array
    (
    [0] => Duration: 00:01:14.00, start: 5.000000, bitrate: 3980 kb/s
    )

    Duration in Seconds: 74
    Thumb Position: 37

    Preparing to create video thumbnail...
    Thumbnail Creation Command: /usr/local/bin/ffmpeg -i /home/sjtv/public_html/sj/cc-content/uploads/flv/eF7XOh5tYX9WTe1rB1Tw.flv -ss 37 -s 640x480 -t 1 -r 1 -f mjpeg /home/sjt/public_html/sj/cc-content/uploads/thumbs/eF7XOh5tYX9WTe1rB1Tw.jpg >> /home/sjt/public_html/sj/cc-core/logs/eF7XOh5tYX9WTe1rB1Tw.log 2>&1
    Verifying valid thumbnail was created...

    Updating video information...
    Unable to select database
  • Here's what my server people say after trying to fix this:

    This is a very strange problem, because like I said the videos are being recognized by the software in the Video Categories section. So it seems like a very specific issue that is preventing it from displaying these videos in the Browse Videos or on the Front page of the site. I haven't been able to find anything relevant on this in the discussion forums at http://cumulusclips.org/. Everything related doesn't seem to fix the issue, or things are already setup as they should be.
    The situation now, is the software seems to operate as it should. It processes videos, and they are located in the correct directories. They seem to have the same permissions, ownership, and properties of videos that are being displayed. There are no errors in the Apache error log, or the MySQL error log. There are also no errors generated by PHP. While there have been some errors in the Cumulus Clips logs, all of the files that I've uploaded have not had any errors. The number of videos present is displayed in the Video Categories section, but the videos aren't being displayed on the front page, or when browsing the videos. They are also not listed in Pending Videos.
    So unfortunately, there's no way for me to trace this down to a specific problem. There is nothing for me to go on except for the code of the software, and I am not familiar enough with it to troubleshoot.

    -----

    :(

    Damian are you contactable off the forums (ie. not in public)?
    Thank you
  • And here's the log file for a clip I just tried to upload. It is on the server, but not appearing on the site/

    ---
    ==================================================================
    FLV ENCODING
    ==================================================================

    FLV Encoding Command: /usr/local/bin/ffmpeg -i /home/sjtv/public_html/sj/cc-content/uploads/temp/zzHPrABR2CCmK2MaDilI.flv -s 640x480 -qscale 1 -ac 2 -ab 96k -ar 44100 -f flv /home/sjt/public_html/sj/cc-content/uploads/flv/zzHPrABR2CCmK2MaDilI.flv >> /home/sjt/public_html/sj/cc-core/logs/zzHPrABR2CCmK2MaDilI.log 2>&1FLV Encoding Output:


    FFmpeg version SVN-r26076, Copyright (c) 2000-2011 the FFmpeg developers
    built on Jun 14 2012 21:23:24 with gcc 4.4.6 20110731 (Red Hat 4.4.6-3)
    configuration: --enable-version3 --enable-gpl --enable-nonfree --enable-shared --enable-postproc --enable-avfilter --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvpx --enable-libfaac --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --disable-ffplay --disable-indevs --disable-outdevs --disable-demuxer=v4l --disable-demuxer=v4l2 --extra-cflags=-fPIC --enable-pthreads
    libavutil 50.36. 0 / 50.36. 0
    libavcore 0.16. 1 / 0.16. 1
    libavcodec 52.108. 0 / 52.108. 0
    libavformat 52.93. 0 / 52.93. 0
    libavdevice 52. 2. 3 / 52. 2. 3
    libavfilter 1.74. 0 / 1.74. 0
    libswscale 0.12. 0 / 0.12. 0
    libpostproc 51. 2. 0 / 51. 2. 0
    [flv @ 0x1c27510] Estimating duration from bitrate, this may be inaccurate

    Seems stream 0 codec frame rate differs from container frame rate: 1000.00 (1000/1) -> 29.97 (30000/1001)
    Input #0, flv, from '/home/sjt/public_html/sj/cc-content/uploads/temp/zzHPrABR2CCmK2MaDilI.flv':
    Metadata:
    hasKeyframes : true
    audiodatarate : 50
    hasVideo : true
    stereo : true
    canSeekToEnd : false
    framerate : 30
    audiosamplerate : 22000
    videocodecid : 2
    datasize : 15727311
    lasttimestamp : 148
    audiosamplesize : 16
    audiosize : 993255
    hasAudio : true
    audiodelay : 0
    videosize : 14725356
    metadatacreator : inlet media FLVTool2 v1.0.6 - http://www.inlet-media.de/flvtool2
    lastkeyframetimestamp: 148
    height : 240
    filesize : 15767612
    hasMetadata : true
    audiocodecid : 2
    videodatarate : 794
    duration : 148
    hasCuePoints : false
    width : 320
    Duration: 00:02:27.89, start: 0.000000, bitrate: 864 kb/s
    Stream #0.0: Video: flv, yuv420p, 320x240, 813 kb/s, 29.97 tbr, 1k tbn, 1k tbc
    Stream #0.1: Audio: mp3, 22050 Hz, 2 channels, s16, 51 kb/s
    [buffer @ 0x1c2f900] w:320 h:240 pixfmt:yuv420p
    [scale @ 0x1c2fcd0] w:320 h:240 fmt:yuv420p -> w:640 h:480 fmt:yuv420p flags:0xa0000004
    Output #0, flv, to '/home/sjt/public_html/sj/cc-content/uploads/flv/zzHPrABR2CCmK2MaDilI.flv':
    Metadata:
    hasKeyframes : true
    audiodatarate : 50
    hasVideo : true
    stereo : true
    canSeekToEnd : false
    framerate : 30
    audiosamplerate : 22000
    videocodecid : 2
    datasize : 15727311
    lasttimestamp : 148
    audiosamplesize : 16
    audiosize : 993255
    hasAudio : true
    audiodelay : 0
    videosize : 14725356
    metadatacreator : inlet media FLVTool2 v1.0.6 - http://www.inlet-media.de/flvtool2
    lastkeyframetimestamp: 148
    height : 240
    filesize : 15767612
    hasMetadata : true
    audiocodecid : 2
    videodatarate : 794
    duration : 148
    hasCuePoints : false
    width : 320
    encoder : Lavf52.93.0
    Stream #0.0: Video: flv, yuv420p, 640x480, q=2-31, 200 kb/s, 1k tbn, 29.97 tbc
    Stream #0.1: Audio: libmp3lame, 44100 Hz, 2 channels, s16, 96 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #0.1 -> #0.1
    Press [q] to stop encoding
    frame= 101 fps= 0 q=1.0 size= 1092kB time=3.24 bitrate=2761.9kbits/s
    frame= 173 fps=172 q=1.0 size= 2539kB time=5.72 bitrate=3635.7kbits/s
    frame= 244 fps=162 q=1.0 size= 4189kB time=8.07 bitrate=4251.2kbits/s
    frame= 317 fps=158 q=1.0 size= 5744kB time=10.55 bitrate=4458.8kbits/s
    frame= 391 fps=156 q=1.0 size= 7334kB time=12.98 bitrate=4627.8kbits/s
    frame= 459 fps=152 q=1.0 size= 9375kB time=15.23 bitrate=5042.8kbits/s
    frame= 531 fps=151 q=1.0 size= 11063kB time=17.63 bitrate=5139.6kbits/s
    frame= 602 fps=150 q=1.0 size= 12780kB time=20.04 bitrate=5225.4kbits/s dup=0 drop=1
    frame= 672 fps=148 q=1.0 size= 14683kB time=22.39 bitrate=5372.7kbits/s dup=0 drop=1
    frame= 747 fps=149 q=1.0 size= 16314kB time=24.87 bitrate=5373.9kbits/s dup=0 drop=1
    frame= 820 fps=148 q=1.0 size= 17846kB time=27.30 bitrate=5355.5kbits/s dup=0 drop=1
    frame= 928 fps=154 q=1.0 size= 18893kB time=30.90 bitrate=5008.3kbits/s dup=0 drop=1
    frame= 1000 fps=153 q=1.0 size= 20677kB time=33.33 bitrate=5081.7kbits/s dup=0 drop=1
    frame= 1070 fps=152 q=1.0 size= 22384kB time=35.71 bitrate=5135.2kbits/s dup=0 drop=1
    frame= 1143 fps=151 q=1.0 size= 23980kB time=38.16 bitrate=5147.2kbits/s dup=0 drop=1
    frame= 1217 fps=151 q=1.0 size= 25383kB time=40.62 bitrate=5119.1kbits/s dup=0 drop=1
    frame= 1291 fps=151 q=1.0 size= 26705kB time=43.08 bitrate=5078.6kbits/s dup=0 drop=1
    frame= 1364 fps=151 q=1.0 size= 28025kB time=45.51 bitrate=5045.2kbits/s dup=0 drop=1
    frame= 1437 fps=150 q=1.0 size= 29548kB time=47.96 bitrate=5046.9kbits/s dup=0 drop=1
    frame= 1511 fps=150 q=1.0 size= 30854kB time=50.42 bitrate=5013.4kbits/s dup=0 drop=1
    frame= 1587 fps=150 q=1.0 size= 32384kB time=52.95 bitrate=5010.2kbits/s dup=0 drop=1
    frame= 1661 fps=150 q=1.0 size= 33910kB time=55.48 bitrate=5006.7kbits/s dup=0 drop=2
    frame= 1735 fps=150 q=1.0 size= 35332kB time=57.91 bitrate=4997.8kbits/s dup=0 drop=2
    frame= 1810 fps=150 q=1.0 size= 36812kB time=60.42 bitrate=4991.0kbits/s dup=0 drop=2
    frame= 1883 fps=150 q=1.0 size= 38381kB time=62.85 bitrate=5002.5kbits/s dup=0 drop=2
    frame= 1957 fps=150 q=1.0 size= 39764kB time=65.33 bitrate=4986.0kbits/s dup=0 drop=2
    frame= 2034 fps=150 q=1.0 size= 40983kB time=67.87 bitrate=4947.0kbits/s dup=0 drop=2
    frame= 2109 fps=150 q=1.0 size= 42249kB time=70.37 bitrate=4918.0kbits/s dup=0 drop=2
    frame= 2183 fps=150 q=1.0 size= 43530kB time=72.83 bitrate=4896.3kbits/s dup=0 drop=2
    frame= 2255 fps=150 q=1.0 size= 45022kB time=75.23 bitrate=4902.4kbits/s dup=0 drop=2
    frame= 2331 fps=150 q=1.0 size= 46384kB time=77.77 bitrate=4886.1kbits/s dup=0 drop=2
    frame= 2405 fps=149 q=1.0 size= 47819kB time=80.25 bitrate=4881.5kbits/s dup=0 drop=2
    frame= 2478 fps=149 q=1.0 size= 49234kB time=82.68 bitrate=4878.2kbits/s dup=0 drop=2
    frame= 2551 fps=149 q=1.0 size= 50511kB time=85.11 bitrate=4861.9kbits/s dup=0 drop=2
    frame= 2623 fps=149 q=1.0 size= 52138kB time=87.59 bitrate=4876.3kbits/s dup=0 drop=3
    frame= 2699 fps=149 q=1.0 size= 53745kB time=90.07 bitrate=4888.1kbits/s dup=0 drop=3
    frame= 2784 fps=150 q=1.0 size= 54393kB time=92.92 bitrate=4795.5kbits/s dup=0 drop=3
    frame= 2862 fps=150 q=1.0 size= 55522kB time=95.50 bitrate=4762.4kbits/s dup=0 drop=3
    frame= 2941 fps=150 q=1.0 size= 56644kB time=98.14 bitrate=4728.2kbits/s dup=0 drop=3
    frame= 3019 fps=150 q=1.0 size= 57726kB time=100.75 bitrate=4693.5kbits/s dup=0 drop=3
    frame= 3102 fps=151 q=1.0 size= 58651kB time=103.50 bitrate=4642.3kbits/s dup=0 drop=3
    frame= 3183 fps=151 q=1.0 size= 59638kB time=106.21 bitrate=4599.7kbits/s dup=0 drop=3
    frame= 3261 fps=151 q=1.0 size= 60856kB time=108.85 bitrate=4579.9kbits/s dup=0 drop=3
    frame= 3334 fps=151 q=1.0 size= 62317kB time=111.23 bitrate=4589.6kbits/s dup=0 drop=3
  • 'Unable to select database' is a MySQL connect timeout issue.

    In any case I know what the problem is and we're implementing a fix in our next release.

    Someone else had the same issue the other day. We're creating a patch in the meantime but it's slightly behind schedule.
  • So the connect timeout issue thing should fix it?

    THanks
  • Update on this.

    The server guys raised the MySQL timeout setting from 5 seconds to 120 seconds.
    Some videos that were not ok yesterday are not appearing when I tried again.
    BUT, some still aren't.
    Very strange!

    Any idea when that patch might be ready Damian?
    Thanks for all the work.
  • OK update.
    We have effectively fixed this by increasing the time out value to a much larger one.
    That seemed to be the issue.
This discussion has been closed.